none
All WCF Adapters Installed EXCEPT WCF-SQL RRS feed

  • Question

  • Hi Everyone,

     

    I have BTS 2009 installed in both development and production environments.  I have successfully installed the adapter pack 2.0 (and SDK) in the development environment, and have successfully developed my BTS applications which extensively utilize the WCF-SQL adapter.

    Now in moving the applications over to the production environment, I have installed the SDK and adapter pack 2.0.  However, the WCF-SQL adapter is not listed in the adapter type list.

    Any ideas why this one adapter would not install?

    Also, and ideas how to fix this problem?  (I have re-installed both the SDK and the adapter pack 2.0.)

    Configuration on both machines:

    - Windows Server 2008 (x64)

    - SQL Server 2008

    - BTS 2009

     

    TIA,

    -Jack

     


    Jack
    Tuesday, March 29, 2011 9:29 PM

Answers

  • Did you try right clicking the Adapters folder in BizTalk Administration Console and selecting Add?  Sometimes they install, but don't add themselves to the Adapters list.  This has caught me before. 

    Kind Regards,

    -Dan

    P.S. If this answers your question, please Mark as Answer. 

    • Marked as answer by jlm27906 Friday, April 1, 2011 2:40 PM
    Thursday, March 31, 2011 9:09 PM
  • Hi Jack,

    The WCF based SQL Adapter can be used to connect BizTalk applications to SQL Server. WCF-SQL Adapter is part of BizTalk Server Adapter Pack 2.0, but can also be downloaded separately. To work with the adapter you will need to install the WCF LOB Adapter SDK SP2 before installing this adapter.See my post on WCF-SQL table operations. As stated there to add the WCF-SQL Adapter you need to start the BizTalk Server Administration Console and than perform the following steps:

    1. In the console tree, expand the BizTalk Group, expand Platform Settings, and then click Adapters.

    2. Right-click Adapters, point to New, and click Adapter.

    3. In the Adapter Properties dialog box, specify a name for the adapter and from the Adapter list, select WCF-SQL.

    4. Click Ok.

    HTH

    Regards,

    Steef-Jan Wiggers
    MVP & MCTS BizTalk Server
    http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly



    BizTalk
    • Marked as answer by jlm27906 Friday, April 1, 2011 2:40 PM
    Thursday, March 31, 2011 9:59 PM
    Moderator

All replies

  • did you install 32 bit or 64 bit adapters? On a 64 bit machines, you need to install both 32 and 64 bit versions of the adapter pack (and 64 bit version of ASDK).


    -- Please mark as answered if this answers your question.
    Wednesday, March 30, 2011 3:54 AM
  • Did you try right clicking the Adapters folder in BizTalk Administration Console and selecting Add?  Sometimes they install, but don't add themselves to the Adapters list.  This has caught me before. 

    Kind Regards,

    -Dan

    P.S. If this answers your question, please Mark as Answer. 

    • Marked as answer by jlm27906 Friday, April 1, 2011 2:40 PM
    Thursday, March 31, 2011 9:09 PM
  • Hi Jack,

    The WCF based SQL Adapter can be used to connect BizTalk applications to SQL Server. WCF-SQL Adapter is part of BizTalk Server Adapter Pack 2.0, but can also be downloaded separately. To work with the adapter you will need to install the WCF LOB Adapter SDK SP2 before installing this adapter.See my post on WCF-SQL table operations. As stated there to add the WCF-SQL Adapter you need to start the BizTalk Server Administration Console and than perform the following steps:

    1. In the console tree, expand the BizTalk Group, expand Platform Settings, and then click Adapters.

    2. Right-click Adapters, point to New, and click Adapter.

    3. In the Adapter Properties dialog box, specify a name for the adapter and from the Adapter list, select WCF-SQL.

    4. Click Ok.

    HTH

    Regards,

    Steef-Jan Wiggers
    MVP & MCTS BizTalk Server
    http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly



    BizTalk
    • Marked as answer by jlm27906 Friday, April 1, 2011 2:40 PM
    Thursday, March 31, 2011 9:59 PM
    Moderator
  • Yes I did install both the 32- and 64-bit adapters.

    Thanks!

    - Jack

     


    Jack
    Friday, April 1, 2011 2:39 PM
  • Thanks Dan, this was the solution.

    - Jack

     


    Jack
    Friday, April 1, 2011 2:39 PM
  • Thanks Steef,

    This was the solution!

    - Jack

     


    Jack
    Friday, April 1, 2011 2:40 PM