none
SMTP will randomly send emails in plain text or HTML format RRS feed

  • Question

  • Hello to all,

    I am using Windows Server 2008 R2 and I need to setup the SMTP server to send the emails from a website hosted on the same server in plain text and HTML format. The server is set to use IIS7 as a web server and PHP 5.4.The SMTP server will randomly send the emails in plain text or HTML format. When the emails are sent in plain text, the "new line" characters will be removed and the text will be displayed on a single line.No errors will be displayed when the emails are sent in plain text instead of the HTML format. The same website has been tested on other servers and the emails were sent properly.I did not find any SMTP option to configure the email format/content and there is no pattern about how SMTP will format the emails before they are sent.My first thought was that something is not working properly within the website so I asked the web development team to check the way PHP formats the emails but everything was fine on their side. I made some tests by using a Gmail SMTP server and all emails have been received in HTML format but when I switched back to my localhost SMTP server I got the same behavior: the emails will be sent randomly in plain text or HTML format without any errors displayed. I checked the server to make sure that no antivirus is installed because most of the times this software using the Anti-SPAM feature will block the emails or it will remove the HTML/rich content from them in order to prevent any virus infection for the end user. Since the server does not have an antivirus solution yet, I disabled the Anti-SPAM filter from the WAN firewall too but I got the same scenario. The biggest problem here is that no errors will be displayed when the HTML content will not be received by the end user and there is no pattern regarding how those emails are formatted.Also, I have checked the Outlook client/the BlackBerry on the end-user side to make sure that those devices do not block the HTML content but all settings were set properly.

    If you have any other tips that I can try please let me know.

    Kind regards,

    Tudor Soimusan

    Thursday, August 22, 2013 11:58 AM