none
there is no object in this control RRS feed

  • Question

  • I have an Access 2013 accde file which has references to the MSCOMCTL library for ListViews and other "activeX" controls. This past week, the application began to fail for computers that had Access 2016 installed. The error given is 2683 There is no object in this control.

    Upon further investigation, it appears that a Microsoft Update released on or around August 1 is causing this issue.

    I tried opening the original accdb file in Access 2016 and receive the same error. Looking at the design of a form that has the ListView, I cannot access the ListView Properties.

    I also tried the following to no avail:

    • Manually unregistering and registering the mscomctl file.
    • De-compiling the Access Database and recompiling it.
    • Checked for missing and broken references

    This is only an issue in Access 2016. When opening up the file in Access 2013 there is no problem.

    I have hundreds of users and this behavior is consistent for everyone using Access 2016 (and only began this past week) in different environments. Access 2013 users have no issue at all.

    Any help would be greatly appreciated.

    Thursday, August 10, 2017 10:00 PM

All replies