locked
Bingbot sprider producing errors RRS feed

  • Question

  • Recently some links have been receiving errors as follows by bingbot spider. However when I check the pages they seem to be available:

    1:

    A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)

    and

    2:

    Object reference not set to an instance of an object

    Friday, July 31, 2020 6:30 PM

All replies

  • I am completely unfamiliar with "bingbot spider", but the first error message means that the attempt to locate the SQL Server instance you wanted to access failed. This could be because the instance is not running, you have a misspelling in the connection string, there is a network disruoption, a firewall in the way, only to mention a few possibilities.

    The second message is a generic .NET error with no direct relation to SQL Server.

    If "bingbot spider" is a product you are using, you may be better off asking in a forum devoted to that product.


    Erland Sommarskog, SQL Server MVP, esquel@sommarskog.se

    • Proposed as answer by engcanada Monday, August 3, 2020 2:28 PM
    Friday, July 31, 2020 8:38 PM
  • Hi  EngCan,

    For the first error,please refer to the previous thread :

    Named Pipes Provider, error: 40 - Could not open a connection to SQL Server

    Best Regards
    Echo   



    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com


    • Edited by Echo Liuz Monday, August 3, 2020 8:15 AM
    • Proposed as answer by engcanada Monday, August 3, 2020 2:28 PM
    Monday, August 3, 2020 8:14 AM
  • Hi EngCan,

    Has your problem been solved? If it is solved, please mark the point that you 
    think is correct as an answer. This can help others who encounter similar problems.

    Best Regards
    Echo

    ""SQL Server related"" forum will be migrated to a new home on Microsoft Q&A SQL Server!
    We invite you to post new questions in the "SQL Server related" forum’s new home on Microsoft Q&A SQL Server !
    For more information, please refer to the sticky post.

    Thursday, August 6, 2020 2:45 AM