locked
installation App Service on Azure Stack integrated systems is failed RRS feed

  • Question

  • Hi Guys,

    Please help my issue :( 

    Deploy App Services Azure Stack integrated systems is failed on step Deploy App Services and i already try retry but still error.

    i check on admin portal and only created 2VM CN:

     

    i using 2x each role App and VM Size DS3_V2 :

    Please help me to solve this issue

    Thanks

    Hendra

    Wednesday, January 10, 2018 10:31 PM

Answers

All replies

  • Hi Hendra

    Please go to the admin portal and under the resource group, you should see the deployments section. Please let us know which object failed and if there is any error detail there.

    Thanks,

    Joaquín

    Wednesday, January 10, 2018 11:02 PM
  • Hi Joaquin,

    i check on RG app and found 2 error :

    SharedWorkerTierScaleSetDeploy

    

    AppService.DeployCloud

    Wednesday, January 10, 2018 11:17 PM
  • Hi Hendra

    Based on the error description, it seems that some VMs or their VM extensions are not being deployed. App Service needs Azure Stack to provide the VMs to invoke the App Service role configuration inside the given VM.

    I'm not sure if the issue is related to some capacity issue but someone from CRP should take a look. I suggest to retry the deployment from the "Retry" button and this will push the ARM template again and check if the deployment goes further.

    Other option is to try the deployment from the beginning with only one instance per tier and once it is deployed, you can scale out each tier.

    Thanks,

    Joaquín

    Wednesday, January 10, 2018 11:32 PM
  • Can you please get me detailed logs for CN0-VM

    Browse to Azure Stack Admin portal->Virtual machines->CN0-VM->Extensions->view detailed status. Please copy and send over the logs to alok.pagariya@microsoft.com

    Wednesday, January 10, 2018 11:34 PM
  • Hi Joaquin,

    i already trying to press "retry" button but still error

    for option is to try the deployment from the beginning with only one instance per tier.

    before start it maybe i must to clean up Resource Group and Database or not ? if yes please give me step by step 

    Wednesday, January 10, 2018 11:40 PM
  • If you can get me detailed log then I can have a quick look.

    --------------------------

    For re-deployment you need to first clean up earlier deployment of App Service 

    1) Browse to Admin portal and delete App Service Resource group (AppService.Local). This will delete all the ARM resources created during deployment.

    2) Delete AppService databases and logins (if any created) Or use new SQL server

    instance for re-deployment.

    for example you can run below script to clean-up database.

    Connect to App Service database and run below script

     

    --******************************************************************

    /*

    Script to clean up App Service objects (databases and logins).

    */

    USE [master]

    GO

     

    DROP DATABASE [appservice_hosting]

    GO

     

    DROP DATABASE [appservice_metering]

    GO

     

    DECLARE @sql NVARCHAR(MAX) = N'';

     

    SELECT @sql += '

    DROP LOGIN [' + name + '];'

    from master.sys.sql_logins

    WHERE name LIKE  '%_hosting_%' OR

    name LIKE  '%_metering_%' OR

    name LIKE  '%WebWorker_%';

     

    PRINT @sql;

    EXEC sp_executesql @sql;

    PRINT 'Completed';

    --******************************************************************

    Wednesday, January 10, 2018 11:54 PM
  • Hi Alok Pragariya,

    already send , please check your email

    Thanks

    Hendra

    Thursday, January 11, 2018 4:31 AM
  • Hi Alok,

    I try to delete RG AppService but error cannot delete ManagementServersPublicEndpoint

    Please Help me to solved this issue

    Thanks

    Hendra

    Friday, January 12, 2018 10:24 AM
  • I'm looping in network folks to have a look at this issue.
    Friday, January 12, 2018 6:52 PM
  • Hello Hendra,

    Can you login to your PowerShell ‘Cloud Operator’ environment (Cloud Operator environment )

    And run the following command and see if it deletes the Public IP?

      

    Get-AzureRmPublicIpAddress -ResourceGroupName `

    <yourresourcegroupname> | Remove-AzureRmPublicIpAddress 

          

    Also – An automated App-Service uninstaller ‘Remove-AppService.ps1’ is included in the App Service on Azure Stack deployment helper scripts.

      

    We apologize for any inconvenience and appreciate your time and interest in Azure Stack.

    If you experience any issues with Azure Stack or the current ASDK release, please feel free to contact us.

            

     Thanks


    Gary Gallanes

    Thursday, January 18, 2018 2:14 AM
  • Gary - I tried to run the PowerShell and it runs for a while and then I get an error.

    Remove-AzureRmPublicIpAddress : Long running operation failed with status 'Canceled'

    Any idea what I can try?

    -paul


    Paul Hacker

    Friday, May 4, 2018 2:34 AM