none
.NET 3.5 installation error and solution RRS feed

  • General discussion

  • I installed .NET Framework 3.5 the day before yesterday and when I boot up XP an error as follows appears. "Component 'MSWINSCK.OCX' or one of its dependencies not correctly registered: a file is missing or invalid."
    There is very little info during search, but it seems the problem is related to either 3.5 or an Active X problem. I have installed the SP1 and reinstalled Active X to no avail and in Add and Remove Programs .NET Framework 3.5 is not listed as uninstallable. After searching everywhere, you (Caddre) seem to have a serious grasp of 3.5. Can you help me figure this problem out. By the way, it is not affecting the operation of anything that I can see, just 2 warnings when I boot that is annoying. Also, I thought of using System Restore but I installed Avast! after 3.5 and it did a 2 hour search before boot and don't want to take a chance on the effects of Restore on it.
    Thank you,
    Rick
    • Split by CaddreModerator Friday, August 29, 2008 3:44 PM Not related to current thread
    Friday, August 29, 2008 2:55 PM

All replies

  •  Just in case anyone else has this problem, here is the solution. Go to http://www.skyenet.net/~cbeelby/pente/ and click on the MSWINSCK.OCX link and save file to desktop. Open your system32 folder and copy and paste which will put this missing OCX file in its proper place and problem solved. For some reason Microsoft left this file out of its download and it is obviously needed for .NET Framework 3.5 and Active X to work properly.
    Very unusual to see something like this missing from Microsoft!
    Thanks again,
    Rick
    Friday, August 29, 2008 3:31 PM