none
FAILURE: Update for .NET Framework 3.0: x86 (KB932471) RRS feed

  • Question

  •  

    Failing to install update for .NET 3.0

     

    Platform: Windows XP

     

    Situation:  I downloaded the .NET 3.5 update so I could use LINQ.   At the end of the install, it said to check Windows Update for possible security patches.   There was a .NET 3.0 update available so I selected it.   It threw and exception saying it could not be installed:

     

    Update for .NET Framework 3.0: x86 (KB932471)

     

    Now the little gold shield with the exclaimation point system tray icon is stuck in an endless loop where it keeps wanting me to install the 3.0 update.

     

     

    Friday, October 19, 2007 9:40 PM

Answers

  • Hi John,

    The .NET Framework 3.5 contains an updated version of the .NET Framework 3.0, and that updated version of 3.0 contains this hotfix already.  Unfortunately, there was some incorrect detection information in the Windows Update logic that is used to decide whether or not to offer this hotfix to a system.

    You can safely ignore this failure and just skip installing this hotfix since the equivalent fix is already a part of the version of the .NET Framework 3.5 that you have on your system.

    The Windows Update authoring logic that is causing this error is in the process of being fixed, and will be refreshed on the live Windows Update site in the near future. For more details, please visit: .NET Framework 3.0 hotfix (KB932471) will fail to install if .NET Framework 3.5 beta 2 is installed

    Hope this helps!

    Thanks!

    Monday, October 22, 2007 5:30 AM
  • What I ended up doing was downloading the .NET 3.0 from Microsoft directly (rather than letting the automatic updates do it) and then installing it.

    After that I could proceed.

    John Bailo
    • Marked as answer by John Bailo Friday, December 12, 2008 6:49 PM
    Friday, December 12, 2008 6:48 PM

All replies

  • Hi John,

    The .NET Framework 3.5 contains an updated version of the .NET Framework 3.0, and that updated version of 3.0 contains this hotfix already.  Unfortunately, there was some incorrect detection information in the Windows Update logic that is used to decide whether or not to offer this hotfix to a system.

    You can safely ignore this failure and just skip installing this hotfix since the equivalent fix is already a part of the version of the .NET Framework 3.5 that you have on your system.

    The Windows Update authoring logic that is causing this error is in the process of being fixed, and will be refreshed on the live Windows Update site in the near future. For more details, please visit: .NET Framework 3.0 hotfix (KB932471) will fail to install if .NET Framework 3.5 beta 2 is installed

    Hope this helps!

    Thanks!

    Monday, October 22, 2007 5:30 AM
  •  

    Thanks for the help Feng.

     

    Question: I uninstalled 3.5 and 3.0 to get rid of the update icon.

     

    Can I directly from 2.0 to 3.5 or do I still have to install 3.0 ?

     

     

    Monday, October 22, 2007 3:25 PM
  • Hi John,

    If you want to use .net framework 3.5, .net 3.0 is not necessary.

    Thanks!

    Tuesday, October 23, 2007 12:41 AM
  •  

    After a day of working ok, the MS Update shield is back with

     

    Update for .NET Framework 3.0: x86 (KB932471)

     

    And it keeps prompting me to install but then fails.

     

     

    Also, I thought by installing 3.5 I would get the ability to build LINQ projects, but VS.NET 2005 doesn't recognize my LINQ code.  

     

    Is there something else I need?

     

    Tuesday, October 23, 2007 6:08 PM
  • John,

    Don't feel like the Lone Ranger. This has been happening to me for over a month. I have been getting help from Microsoft techs, but there have been two of them and nothing they have told me has worked. I have also tried many things on my own. And, I have already done everything the techs suggest. There is NO NetFramework 3.0 listed when I go to Control Panels, ADD/REMOVE. However, I recently found it sitting in the C:Windows file under Microsoft.Net.

    All I want to do at this point is initialize my hard drive. This NetFramework 3.0 was downloaded but it will NOT install, I always get Error Code 0x643. I just want to remove the downloaded portion. There are no options for this, unless you can remove from ADD/REMOVE. Of course, it's not there.......because it won't install. Good luck with your situation. I will tell you if I get it fixed. And how.

    Wednesday, October 24, 2007 3:28 AM
  • Ah- hah ... !!!

    Soooo - "that's" where all the funny "non-programs" GO... 

     

    (see) C:/ Windows - (or "more" correctly - Dont_C:/ Everything_Working @ Windows)

     

    ha.ha.hah (???)

     

    And here I was wondering "why" my system ALWAYS ups, stutters / staggers & then SIMPLYL-

     

    CRASHES

     

    NEARLY all the time.

     

    Was going through the "endless logs / past history" - when I spotted (several) FAILED TO INSTALL ...

     

    Thinking that I'd just "bang_them" through again ... a wee voice screamed <W.A.I.T>

     

    & so I "clicked" the (?) icon beside the "FAILED" - and came "here".

     

    Very interesting ... to NOW know ...

    That MS - can "make" these - and:-

    ... STILL NOT KNOW HOW TO FIX THEM ??? ... ;-(

     

    Cheers,

    QUIX

     

    (I will simply IGNORE these "failures" in future - & "party_on")

     

    Sunday, January 13, 2008 7:31 AM
  •  

    It's now 27 February 2008 and this error has still not been fixed. I think someone's dropped the ball on this one, then wandered off to grab a beer.
    Wednesday, February 27, 2008 11:51 AM
  • Yes, OBVIOUSLY someone has dropped the ball...B/C now it is March 8, 2008, and it is STILL not fixed

    Saturday, March 8, 2008 4:59 PM
  •  

    KB932471 has been a problem since early last october. ive seen postings on other forums about this. when you update your windows just make it hidden and never be bothered with this again.
    Tuesday, April 8, 2008 5:45 PM
  •  

    a wee voice screamed <W.A.I.T>

     

     

     so I "clicked" the (?) icon beside the "FAILED" - and came "here

     

    Be very grateful the little icon brought you here.  The little icon did not bring me here....

     

    It took me two days to find 'here'........, where for the FIRST time there is anything even remotely associated with the problem.  I am less than amused that the only solution found is to ignore the problem.

     

    Operator is very grumpy now and heading back to cave, where, if there is any mercy in this world, the power supply will be disconnected and operator will go outside to garden where she belongs.

    Thursday, April 17, 2008 6:25 PM
  • I had found the same problems myself!

     

    But, after doing all I was able to do to fix the problem, what I found is a registry problem.  Especially for those using registry cleaners!  Most of the time it was fixed after reinstalling the service pack 2 disk on customers pc's.  And then my own system had the same problem after I reinstalled xp pro on my PC.  I finally got it to work after I installed xp service pack 3.  Then the 3.0 installed perfectly!  Now that it is finally out everyone will have should have no problem getting this update.

     

    But, then there is an other issue in play.  Now while trying to install the 3.5 update with the setup.exe it disconnects from the server and goes through the whole 6 times of trying then stops with a connection error.  I had tried this several times and even redownloaded the setup.exe and still the same.  I am not sure if this is a problem with the setup.exe giving the wrong address, but it seems and acts like it be the issue.  I don't really want to do a full install worried about the reinstall of components and others that I don't need and maybe causing problems with those programs and thier updates I already have.  Anyone else have this problems?

     

    I hope that this info may help those thying to get the 3.0.  But, the 3.5 is still an issue.

     

    I have been working on and playing with computers since we were using ticker tape to program and never seen update problems since after service pack 2 nor .net 2!  Still can't see how MS can put out these updates and not be able to fix or so called repair these problems.  The worse thing is you almost have to have them now days just to use the newer programs to allow them to work properly.  Really sucks!! lmao!

     

    Thanks for any reply!

    Friday, May 9, 2008 2:59 PM
  • I use an WSUS server

    and now I have Many PC's with this problem ( 224 of them ) the funny part is WSUS does not even show this as an known problem

    also removing aproval statas was of no help Tongue Tied
    Thursday, May 29, 2008 1:32 AM
  • Thanks to Feng Chen for the information on this one. Makes sense (sort of, except that they still haven't fixed the update system).

    Here's what I've done in the interim:
    1. Invoke the Windows Update Wizard by clicking on the yellow shield icon in the system tray.
    2. Click Custom Install.
    3. Click Next.
    4. De-select Update for .NET Framework 3.0: x86 (KB932471)
    5. Click Close (button may be labeled differently, like "Next" if you have other items to update).
        - "Hide Updates" message box appears.
    6. Check the Don't notify me about these updates again check box.
    7. Click OK

    I have no idea if it will actually obey my request to hide it forever, but I don't want to keep getting reminded of a problematic update item.

    We'll see how it goes from here. Hopefully it won't ask me again.

    HTH.


    [edit]

    looks like it still wants to remind me of the update... nice.

    [/edit]


    evan k. stone / sr. ux developer / dragnet solutions, inc.
    • Edited by Evan Stone Monday, June 2, 2008 11:18 PM adding additional information
    Monday, June 2, 2008 11:12 PM
  • So... it's now September 2008 (soon to be October), and I've still got this issue.

    What's going on?

    -jb
    Tuesday, September 23, 2008 2:58 PM
  •  I'm using WSUS 3.0 and have come across this problem today as well.  I have gone back and declined the update, hoping it will uninstall, however it sounds like it won't.  Rolling back the system uninstalls the update, which at least gets rid of the error.  I would love a fix for this.

    Thanks -
    Wednesday, September 24, 2008 6:35 PM
  •  

    I am having trouble installing the following (Optional) .Net from Microsoft Update.

    Microsoft .NET Framework 3.0 x86 (KB928416)

    The original File size indicated on Microsoft Update was 50 mb, (2+ hr. at 56kps) The downloaded file, that failed installation, is 26 mb. 

    ------------------------------------------------------
    Error Code: 0x643 

    Try to install the update again, or request help from one of the following resources.

    For self-help options:

    Frequently Asked Questions
    Find Solutions
    Windows Update Newsgroup

    For assisted support options:


    Microsoft Online Assisted Support (no-cost for issues related to getting updates)

    --------------------------------------------------------
    System Info:  x86

    2.4 ghz Processor
    250 HD
    1 G Ram
    1500 Memory

    OS:  Version 7.0.5730.13
    Product ID:  76487-OEM-0044222-04147
    Update Versions: 0

    ---------------------------------------------------------
    Thank You

    aschbott 
     
     

    Thursday, September 25, 2008 5:16 PM
  • Thanks Microsoft, I have 13,000 workstations throwing up errors in WSUS that cannot be resolved, why do you get off your butt's and do something, with a million programmers under your corporate hood why has this issue not been resolved? And what am I to tell my clients, Oh btw Microsoft hasen't bothered to fix this and it's been over a year?

    C'mon this is unacceptable. Our WSUS servers are not inspiring confidence with this one.
    Tuesday, September 30, 2008 1:13 PM
  • Pathetic isn't it? It's NOVEMBER 2008, and this issue is still happening here and there's no helping it.

    W



    wp
    Wednesday, November 5, 2008 3:38 PM
  • hehee, I too have this problem ^^ and 'cause I'm also using WSUS it's kinda annoying. and btw it's not only for this KB932471, also
    older NET framework updates throw the same thingie, 1.1 updates (user has 2.0) etc. Windows update tries still to install those and so
    on.

    Has anyone tried to uninstall 3.5 , install this update, reinstall 3.5 ?
    • Edited by Jari Haikonen Thursday, November 6, 2008 6:04 AM
    • Marked as answer by John Bailo Friday, December 12, 2008 6:49 PM
    • Unmarked as answer by John Bailo Friday, December 12, 2008 6:49 PM
    Thursday, November 6, 2008 6:03 AM
  • What I ended up doing was downloading the .NET 3.0 from Microsoft directly (rather than letting the automatic updates do it) and then installing it.

    After that I could proceed.

    John Bailo
    • Marked as answer by John Bailo Friday, December 12, 2008 6:49 PM
    Friday, December 12, 2008 6:48 PM