none
SSO Configuration Application MMC Snap-In problem RRS feed

  • Question

  • Hello everybody,

     

    I recently starting using this tool of Microsoft to store the config data of my BizTalk applications. In the past I've used the SSO tool of Richard Seroter but I came accross this one and thought I'd give it a try but it's giving me a headache whenever I'm trying to modify/add/delete a key/value pair. Sometimes when I add a pair to an SSO app it overwrites the existing one even though it has a different name, at other times it just deletes all other pairs in the app including the one being created. It seems to do whatever at random. It's handy and easy to access from within BizTalk applications but I'm worried that an admin might want to change a value sometime (an email adres for example) and accidently destroy the entire tree.

     

    Anybody know what's the cause of this and how it can be resolved? Is this a known issue? Many thanks in advance

    Sharif

    Tuesday, October 26, 2010 1:12 PM

Answers

All replies

  • Which tool are you using? Just the built-in SSO MMC?

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Tuesday, October 26, 2010 7:49 PM
    Moderator
  • Yes, it's been released about a year ago by Microsoft but I believe most BizTalk developers are sticking to the tool of Seroter.
    Wednesday, October 27, 2010 7:50 AM
  • I've managed to update existing key/value pairs (simply by logging out and logging back in again) but adding a pair is still problematic. Sometimes it works, other times it doesn't. Strange behavior.
    Wednesday, October 27, 2010 8:11 AM
  • i vaguely remember hearing about that tool. I have stuck with Richard's tool too.
    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Wednesday, October 27, 2010 12:43 PM
    Moderator
  • Hi Sharif,

     

    I wanted to respond to your concern about the SSO tool.  Are you referring to the SSOclientUI tool? Or the main MMC administration tool, where you create the affiliate application? 

     

    In any case, it does not look like there is any information internally to MS for this tool either.  If you can reproduce the problem send me the steps so I can setup a repro and report the problem.

     


    Regards, Imelda I
    Wednesday, November 3, 2010 11:45 PM
    Moderator
  • Hi Imelda, I'm talking about the main MMC administration tool and I'm still struggling with it. Unfortunately it's pretty simple to reproduce the problem, simply create an application and try to add numerous key/value pairs. 

    It simply doesn't do anything most of the time. If I stubbornly keep adding value/key pairs one of them might succeed after 5-10 attempts, but then when I continue doing this all my keys will be deleted all of a sudden. The event viewer doesn't give me much to work with either. 

    Very rarely do I succeed in adding 2 key/value pairs in a row. Pretty frustrating.

     

    Thanks for looking into this

    Monday, November 15, 2010 1:28 PM
  • Thank you for your response.

     

    I will start the repro. However, when you say simply create an application, are you talking about an affiliate application?

    Just to be sure that I am focussing on the right thing could you please give me the step0s that you take to create the application?  and include the type value pairs etc. 


    Regards, Imelda I
    Monday, November 15, 2010 4:20 PM
    Moderator
  • No problem, I'll list the steps. 

    1) Open SSO Configuration Application.msc

    2) On the root node (SSO configuration application), right click and select "Add application" 

    3) I usually rename the application to something more descriptive than "NewApplication," Lets say "Suppliers" 

    4) Right click on "Suppliers" and select "Add Key Value Pair" 

    5) Type in "EmailTo" for Key and "hello@hello.com" for Value. 

    6) Repeat step 5 for different keys

     

    I'm curious to hear your results. Step 5 didn't do much for me. The application "Suppliers" was left without any key value pairs. Same goes for step 6. Adding key-value pairs is a huge challenge. However, once a key-value pair is added to an app succesfully, I can always modify (change the values of either key and/or value) the pair without any troubles.

     

    On a side note, the "Alert me" function of this forum doesn't seem to "alert" me anymore (which is why I was so late to respond) 

    Tuesday, November 16, 2010 8:43 AM
  • Thank you, I will start testing it. 

     

    Ps. The problem with the alerts also occurred to me.  I had to check my

    Forum Preferences, and its working now.

     


    Regards, Imelda I
    Wednesday, November 17, 2010 6:15 PM
    Moderator
  • Hello,

    I need to ask you what other applications you have installed on your machine.  I have looked at what we have as far as configuring SSO and do I do not see what you are describing in your steps.  Are you using MIIS along with ESSO?

    What version of BizTalk are you using?

    What version of Windows?

    Maybe if you can tell me what is the executable? I can look for that, it may be part of an earlier version of the product, than I am using.


    Regards, Imelda I
    Tuesday, November 23, 2010 11:50 PM
    Moderator
  • Sure,  

     

    Windows version: Windows server 2003 R2 Standard edition

    BizTalk version: BizTalk Server 2006 

    Executable: C:\Program Files\Microsoft Services\SSO Application Configuration\SSO Application Configuration.msc

     

    I am not using MIIS. I have downloaded the SSOConfigurationMMCSnapIn.zip file from Microsoft. This file contains 3 other zip files;

    -SSOConfigurationApplicationClientHelper.zip

    -SSOConfigurationApplicationMSBuildImportTask.zip

    -SSOMMCSnapInSetup.zip

     

    I've used the setup (3rd one in the list) to install the snap in and the first file to access the SSO DB from my BizTalk orchestrations. 

     

    Hope that helps in finding what's wrong. Thanks 

     

    Regards,

    Sharif

    Monday, November 29, 2010 10:41 AM
  • Hello Sharif,

     

    I am happy to announce that I have tested this app with BizTalk 2010, it works great!

    Unfortunately, on previous versions, I could not get it to work at all.

    The mmc does not completely start; it throws an exception before it fully comes up.

    But when, using  BizTalk  2010 running on Windows server 2008R2, using the package on this link.

    http://www.microsoft.com/downloads/en/details.aspx?displaylang=en&FamilyID=94e07de1-1d33-4245-b430-9216979cd587

    It works great!

    I hope this helps

     


    Regards, Imelda I
    Sunday, December 19, 2010 12:59 AM
    Moderator
  • That's great to hear Imelda. At the moment we're upgrading to BizTalk 2010 so I don't expect to face any more issues then. Thanks for looking into this! 

    Monday, December 20, 2010 8:24 AM
  • Well, after finally installing and configuring a BT 2010 server and using this SSO tool from Microsoft I can say the working is quite a bit more stable but far from perfect. At times I still have trouble adding a key/value pair (it disappears) but it's a major improvement from using it in BT 2006
    Tuesday, January 11, 2011 3:09 PM
  • Hi Sharif,

    I tried to repro that issue, but I could not get it to fail for me on this version.  I am sorry you are still having trouble, I will check my database to see if there are any other reports of the is problem.

     

    regards,

    Imelda


    Best Regards, Imelda
    Tuesday, January 11, 2011 4:55 PM
  • I've been using this tool quite a lot now and the issues have vanished. Initially I used the import function (on the new BT 2010 server) of this tool so the data I imported was probably corrupted/unstable. Creating new apps and key/value pairs have been great ever since. 
    Wednesday, January 26, 2011 3:46 PM
  • Imelda :) Hello.

    I am also having the same problem as described by the user above.  Intermittentantly with the new "SSO Application Configuration" mmc snap in, when used on the Biztalk Servers.  When used at the SQL Server it seems to perform without error.  There are no associated error events on either Biztalk Servers or SQL Server.

    Biztalk Server=Biztalk 2010 Server Ent CU2; OS=Windows 2008R2 SP1

    I made sure to download from the link you supplied.

    Entering a new application, always suceeds.  Entering key pairs under an application, fails more often than succeeds.  There is no error message in the mmc, nor security logs,  SQL log etc.

    I finally managed to create a new application, with 4 key-pairs, before I found doing from SQL Server to work better,  but initially I  rebooted my server before getting the first key pair entered.  Then I tried stopping and starting ESSO on the BTS Servers to get the remainder built.  Are you aware of anyone finding solution to intermittent issues with remote use of this tool (Biztalk Server nodes)? 

    Friday, December 2, 2011 11:44 PM
  • I might be bashed up for this opinion but to me SSO is like an appendix in a human body.
    Saturday, December 3, 2011 4:33 AM
  • Hello Carol,

     

    This issue was only tested on a single machine by me.  I think that if the Master Secret is on the SQL server, which I don’t know that it is, that might be why you are seeing the problems.

    Unfortunately, there has been no additional testing done on this product.  It will take lots time, to setup the testing.  Using a support case would be the ideal way to get you the right kind of support for this kind of problem.

    Not much help J

     

     

    Friday, December 9, 2011 7:24 PM