Updating Content Type Failed



    Hi ,


    I regularly use infopath enabled browser forms on sharepoint. Every now and then when i update the form and publish it to a library, i get an error message "Updating Content type failed".  This occurs sometimes, and not every time the form is published.


    Can anyone help me out.



    Friday, October 12, 2007 3:41 AM


All replies

  • I have seen the same error happen all the time. What I did is publish the form with less columns, if it didn't go thorough, try to cut off even more columns until it successfully publish the form. After that you can publish the form again with all the columns you need. This time you will see all columns are published and with new form contents even the second publishing failed.

    let me know if it works for you.

    Monday, October 22, 2007 10:17 PM
  • Hi,

    I'm also facing the same problem. I've around 40-50 fields which needs to be published. For some Infopath forms it gives error "Updating the site content failed" while publishing and for some it doesn't.

    Its really strange and i've not found any solution for this. i'm still clueless

    If anyone do have an idea regarding this, please provide a solution for the same

    Nitesh Earkara
    Friday, March 13, 2009 1:57 PM
  • Hi Nitesh,

    Even I am facing the same problem. Even though it gives us an error, it publishes the form with the mentioned fields. I am safe for now using the fields in the library. But it might create a problem in the near future. If you find an answer, please do let me know!

    Thanks for any ideas!!

    Thursday, May 07, 2009 7:08 AM
    • Proposed as answer by Priya Darshini Thursday, May 07, 2009 7:12 AM
    • Unproposed as answer by Mike Walsh FIN Thursday, May 07, 2009 7:18 AM
    • Proposed as answer by Pious_sharepoint Thursday, December 03, 2009 6:59 PM
    • Unproposed as answer by Mike Walsh FIN Saturday, December 05, 2009 3:27 PM
    • Marked as answer by Mike Walsh FIN Saturday, December 05, 2009 3:30 PM
    Thursday, May 07, 2009 7:12 AM
  • hey Guys

    I found a hotfix for issue

    On a Windows SharePoint Services 3.0 site, you have a site content type that has more than 30 columns. You added this content type to many document libraries or to many lists on a Windows SharePoint Services 3.0 site. If you try to update the content type in InfoPath 2007, it may take several minutes to complete the update. Additionally, InfoPath seems to stop responding.

    Thursday, December 03, 2009 7:00 PM
  • I actually had the Same Issue, I sorted it out by creating the Share Point form library first. But you need to be a site administrator to do this

    I then republished the form again

    Saturday, June 18, 2011 5:55 PM
  • I ran into the same issue, receiveing the content type error and the issue on my side was due to the sharepoint site size limits.

    Once I deleted a few items on the site to free up space, or would have had the site size limits increased, I was able to sucessfully publish the form.  Hope this helps...

    • Proposed as answer by Andrey Fedotov Thursday, October 20, 2011 5:41 AM
    • Unproposed as answer by Andrey Fedotov Thursday, October 20, 2011 5:41 AM
    Wednesday, August 03, 2011 4:57 PM
  • there is a very simple solution:

    1. open library where you'd like to update the content type
    2. go to Actions -> Open with Windows Explorer
    3. open 'Forms' folder
    4. delete  template.xsn (or move it to your computer for safety)
    5. publish the Form again!
    Thursday, October 20, 2011 5:45 AM
  • Links is broken... 
    • Proposed as answer by iCandoall Thursday, August 29, 2013 3:03 PM
    Wednesday, July 11, 2012 8:35 PM
  • Hi all

    I know this might be a bit old, but though it would help someone. I was facing a simillar issue trying to publish a infopath 2007 from with 120+ columns to a Sharepoint Site 2007. I was using Windows XP(out dated really now with Windows 8) Simple fix: downloaded Service Pack 2 from Microsoft website as suggested somewhere in this forum and was able to publish all the columns without any problems. Hope it helps someone

    Thursday, August 29, 2013 3:10 PM
  • Hi

    The link was broken 


    Tuesday, October 08, 2013 11:03 AM
  • wow, this has been hurting me for some time.  Imagine this happening on an already published form library where the promoted columns are vital to operations.    After not much luck resolving, I simply shut everything down, rebooted, then ran a win 7 disk cleanup to get rid of any potential temp files.   I don't know if this is what fixed it but I am now back in full business updating content types and doing a full publish.  I also reopened the form from the server and tried publishing after disk cleanup - this same effort failed prior to disk cleanup.    Best of luck for anyone dealing with this situation. 
    Wednesday, December 18, 2013 6:40 PM
  • Make sure you have Full Control of all form libraries that are using the Site Content Type.
    Friday, September 26, 2014 8:59 PM