none
Azure Monitor Alerts using webhook to Microsoft Teams - No messages to Teams RRS feed

  • Question

  • I'm using Azure Monitor/Log Analytics to trigger alerts successfully. I'm trying to get the alerts into a Microsoft Teams channel (as well as a slack channel for debugging) with no success.

    I've an alert that's successfully being triggered. I have an action group with my email, sms and azure app push configured. I've been receiving these messages each time the alert triggers.

    I've got another action group with a couple of webhooks in for a Microsoft Teams and Slack channels. I'm not receiving anything on these channels.

    I've enabled the custom 'Include custom Json payload for webhook' and pasted both the suggested json and the following { "AlertName":"#alertrulename", "AlertDescription":"#description", "LinkToSearchResults":"#linktosearchresults"}

    I get the emails/sms/push notifications but not the messages to the web hooks. I've tried leaving the common alert schema set to no in the action group, the default (as well trying unsuccessfully on yes as well).

    Suspecting it's something to do with the custom payload json as mention here https://azure.microsoft.com/en-gb/blog/webhooks-for-azure-alerts/

    Any ideas on how I can get my alerts into teams?

    Thanks


    • Edited by foxj77 Friday, January 24, 2020 8:41 AM
    Friday, January 24, 2020 8:41 AM

All replies

  • Thanks for reaching out! From the information provided, I am unable to tell where it went wrong. However, I would suggest you to check this document  and give it a try on sending alerts to Teams.

    Hope this helps!

    Monday, January 27, 2020 11:12 AM
    Moderator