locked
Windows Authentication RRS feed

  • Question

  • User-515183 posted

    What is the correct way to configure windows authentication? When I make a change to the source and put a new build on production, the authentication disables windows and enables anonymous.

    This is what is in the web.config file.

       <authentication mode="Windows" />
        <authorization>
          <deny users="?" />
        </authorization>
            <identity impersonate="false" />

    Thank you
     

    Tuesday, July 19, 2016 12:40 PM

Answers

  • User-515183 posted

    Thanks got it

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, July 21, 2016 1:09 PM

All replies

  • User-286291038 posted

    Hi sbuggle,

    Please refer to the below post, you may probably have to disable anonymous authentication first and enable windows authentication.

    https://forums.iis.net/t/1216324.aspx

    Tuesday, July 19, 2016 3:13 PM
  • User-166373564 posted

    Hi sbuggle,

    To configure Windows authentication

    1. Start Internet Information Services (IIS).
    2. Right-click your application's virtual directory, and then click Properties.
    3. Click the Directory Security tab.
    4. Under Anonymous access and authentication control, click Edit.
    5. Make sure the Anonymous access check box is not selected and that Integrated Windows authentication is the only selected check box.

    In your application's Web.config file or in the machine-level Web.config file, ensure that the authentication mode is set to Windows as shown here.

    ...
     <system.web>
      ...
      <authentication mode="Windows"/>
      ...
     </system.web>
     ...

    Regards,

    Angie

    Wednesday, July 20, 2016 6:23 AM
  • User-515183 posted

    Thanks got it

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, July 21, 2016 1:09 PM