locked
Bug: Run Tests in Test Results Window RRS feed

  • Question

  • Running a web test from the test results window doesn't seem to really run the test properly. (click the checkbox next to the test and a "rerun" link apears above.) I modify the test so that it should fail, save it, and then rerun the test from the test results window and it looks like it runs it and comes back with "Passed". If I run the test by clicking the "Click here to run again" link at the top of the page, it runs the test sucessfully.

    Friday, July 15, 2005 1:09 PM

Answers

  • Hi,

    In todays builds, we've changed the hyperlink to say "Rerun original tests" -- This will re-run those checked tests with the same binaries that were used to run it previously (eg you wont see any changes). This is to allow you to tests with transient/hard to repro failures.

    So, expected behaviour (checked with a current build)...
    1) Checking tests and seleting "Run" from the toolbar will pick up any changes in the tests
    2) Checking Tests and select "rerun original tests" will rerun the tests with the same binariers that were to run it in the first place.

    Friday, July 15, 2005 5:26 PM

All replies

  • Hi,

    In todays builds, we've changed the hyperlink to say "Rerun original tests" -- This will re-run those checked tests with the same binaries that were used to run it previously (eg you wont see any changes). This is to allow you to tests with transient/hard to repro failures.

    So, expected behaviour (checked with a current build)...
    1) Checking tests and seleting "Run" from the toolbar will pick up any changes in the tests
    2) Checking Tests and select "rerun original tests" will rerun the tests with the same binariers that were to run it in the first place.

    Friday, July 15, 2005 5:26 PM
  • Thank you very much. Makes sense.

    Friday, July 15, 2005 6:47 PM