locked
Network-related or instance-specific error RRS feed

  • Question

  • Hi,

    When I run my application through IIS by specifying the server IP and virtual directory in the browser, I am getting the following error:

    A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server).

    But when I run on visual studio it is working well. What might be the problem? I am connecting to SQL Server 2000 instance on another server.

    • Moved by Bob Beauchemin Tuesday, April 1, 2014 10:01 AM Moved to the forum for client-side .NET code
    Monday, March 31, 2014 1:21 PM

All replies

  • When I run my application through IIS by specifying the server IP and virtual directory in the browser, I am getting the following error:

    A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server).

    But when I run on visual studio it is working well. What might be the problem? I am connecting to SQL Server 2000 instance on another server.

    • Moved by Bob Beauchemin Tuesday, April 1, 2014 10:01 AM Moved to the forum for client-side .NET code
    • Merged by Fred Bao Wednesday, April 2, 2014 6:29 AM Duplicate
    Monday, March 31, 2014 1:09 PM
  • Hi,

    Can you check the below link and try. Something to do with connection string in Your IIS.

    http://www.sswug.org/articlesection/default.aspx?TargetID=44331

    Things to check: 1. Make sure your database engine is configured to accept remote connections • Start > All Programs > SQL Server 2005 > Configuration Tools > SQL Server Surface Area Configuration • Click on Surface Area Configuration for Services and Connections • Select the instance that is having a problem > Database Engine > Remote Connections • Enable local and remote connections • Restart instance

    2. Check the SQL Server service account • If you are not using a domain account as a service account (for example if you are using NETWORK SERVICE), you may want to switch this first before proceeding

    3. If you are using a named SQL Server instance, make sure you are using that instance name in your connection strings in your ASweb P.NET application • Usually the format needed to specify the database server is machinename\instancename • Check your connection string as well

    <connectionStrings>

    <add name="SampleConnectionString" connectionString="Data Source=machinename\instancename;Initial Catalog=AdventureWorks;Integrated Security=SSPI;Min Pool Size=5;Max Pool Size=60;Connect Timeout=30″ providerName="System.Data.SqlClient"/>

    </connectionStrings>

    4. You may need to create an exception on the firewall for the SQL Server instance and port you are using • Start > Run > Firewall.cpl • Click on exceptions tab • Add the sqlservr.exe (typically located in C:\Program Files (x86)\Microsoft SQL Server\MSSQL.x\MSSQL\Binn, check your installs for the actual folder path), and port (default is 1433) • Check your connection string as well

    5. If you are using a named SQL Server instance, make sure you are using that instance name in your connection strings

    6. Check SQLBrowser; check that it is running. You may also need to create an exception in your firewall for SQLBrowser.

    7. Check that you have connectivity to the SQL Server.  Note what you are using to connect: machine name, domain name or IP address? Use this when checking connectivity. For example if you are using myserver • Start > Run > cmd •netstat -ano| findstr 1433 •telnet myserver 1433 •ping -a myserver

    Check what ports are IP addresses are being returned.

    If you still can’t get any connection, you may want to create a SQL account on the server, a corresponding SQL user on the database in question, and just use this username/password combo in your web application.


    Regards, PS

    Monday, March 31, 2014 1:31 PM
  • Hi,

    Can you check the below link and try. Something to do with connection string in Your IIS.

    http://www.sswug.org/articlesection/default.aspx?TargetID=44331

    Things to check: 1. Make sure your database engine is configured to accept remote connections • Start > All Programs > SQL Server 2005 > Configuration Tools > SQL Server Surface Area Configuration • Click on Surface Area Configuration for Services and Connections • Select the instance that is having a problem > Database Engine > Remote Connections • Enable local and remote connections • Restart instance

    2. Check the SQL Server service account • If you are not using a domain account as a service account (for example if you are using NETWORK SERVICE), you may want to switch this first before proceeding

    3. If you are using a named SQL Server instance, make sure you are using that instance name in your connection strings in your ASweb P.NET application • Usually the format needed to specify the database server is machinename\instancename • Check your connection string as well

    <connectionStrings>

    <add name="SampleConnectionString" connectionString="Data Source=machinename\instancename;Initial Catalog=AdventureWorks;Integrated Security=SSPI;Min Pool Size=5;Max Pool Size=60;Connect Timeout=30″ providerName="System.Data.SqlClient"/>

    </connectionStrings>

    4. You may need to create an exception on the firewall for the SQL Server instance and port you are using • Start > Run > Firewall.cpl • Click on exceptions tab • Add the sqlservr.exe (typically located in C:\Program Files (x86)\Microsoft SQL Server\MSSQL.x\MSSQL\Binn, check your installs for the actual folder path), and port (default is 1433) • Check your connection string as well

    5. If you are using a named SQL Server instance, make sure you are using that instance name in your connection strings

    6. Check SQLBrowser; check that it is running. You may also need to create an exception in your firewall for SQLBrowser.

    7. Check that you have connectivity to the SQL Server.  Note what you are using to connect: machine name, domain name or IP address? Use this when checking connectivity. For example if you are using myserver • Start > Run > cmd •netstat -ano| findstr 1433 •telnet myserver 1433 •ping -a myserver

    Check what ports are IP addresses are being returned.

    If you still can’t get any connection, you may want to create a SQL account on the server, a corresponding SQL user on the database in question, and just use this username/password combo in your web application.


    Regards, PS

    Monday, March 31, 2014 1:33 PM