none
Azure Data Factory - New Linked Service to On Prem SQL Database - Error

    Question

  • Just trying to connect to On Premises SQL Server from Azure Data Factory but unable to do so. Getting an error when testing the connection stating:

    Error: {"Message":"There was an error processing your request. Please try again in a few moments.","HttpStatusCode":"InternalServerError","XMsServerRequestId":null,"StackTrace":null}

    Not really sure what is missing. 

    NB: Microsoft Integration Runtime is all running fine and test connection within it works fine.

    Any help would be appreciable. Simply stuck at this step. Thanks



    • Edited by r4Mgmt Friday, October 12, 2018 10:02 PM
    Friday, October 12, 2018 9:46 PM

All replies

  • Hello,

    Want to understand a little bit more, Integration Runtime is installed on-prem?, what about the ports on the source sql server, are they open.


    Cheers,

    Tuesday, October 16, 2018 4:54 AM
  • Hey

    We have the same issue

    self hosted integration runtime installed on on-premise computer

    connected to data factory - showing as connected on both local app and azure

    new linked service > SQL Server > use gateway etc gives error

    Error: {"Message":"There was an error processing your request. Please try again in a few moments.","HttpStatusCode":"InternalServerError","XMsServerRequestId":null,"StackTrace":null}

    ports 443 and 1433 reportedly opened in corporate network for outbound

    any suggestions?

    Wednesday, October 17, 2018 10:12 AM

  • Just to note that this issue was resolved by changing the location of the data factory - was in UK South - moved to West Europe and connected fine

    • Proposed as answer by wilbur24 Wednesday, October 17, 2018 1:00 PM
    Wednesday, October 17, 2018 1:00 PM