locked
Is there a way to set a default solution .runsettings file in VS2013? RRS feed

  • Question

  • This is a question my coworker asked over on StackOverflow [here], but hasn't received a single comment or answer. Thought I'd repost it here since I know the VS guys are more likely to see it here...

    I'm using VS2013 with the built-in unit test framework. I've created a .runsettings file that sits in the Solution Items folder. When I select Test -> Test Settings -> Select Test Settings File, I am able to choose my .runsettings file and it works as expected.

    When I exit out of VS2013 and then re-load the project, I have to re-select the .runsettings file. Is there any way to set the default .runsettings file at solution level so it gets persisted?

    Monday, January 13, 2014 2:08 PM

Answers

  • Hi,

    I can’t get your issue on my side(VS2012 Update 4 machine and VS2013 Update 1 RC machine). If you are using VS2012, please upgrade it to VS2012 Update 4. If you are using VS2013, please upgrade it to VS2013 Update 1 RC.

    When I restart VS and re-load the project, the .runsettings file is still selected with the Select Test Settings File menu option and .runsettings file is still used when I run the unit test.

    I doubt that there is anything wrong with your VS. As I mentioned above, please reset your VS settings through Tools->Import and Export settings->Reset all settings…

    If no help, try some other devenv commands to fix:

    1.devenv.exe  /safemode

    2.devenv.exe  /resetskippkgs

    3.devenv.exe  /installvstemplates

    4.devenv.exe  /resetuserdata 

    devenv.exe can be located under your VSlocation/Common7/IDE

    What your need is to put it to run prompt and add commands to it.

    If the issue still exists, please repair or reinstall your VS.

    Meanwhie, if you have some anti-virus software running when you work with VS, please close them to check the reuslt.

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Amanda Zhu Monday, January 20, 2014 1:01 AM
    Tuesday, January 14, 2014 3:38 AM

All replies

  • Hi,

    I can’t get your issue on my side(VS2012 Update 4 machine and VS2013 Update 1 RC machine). If you are using VS2012, please upgrade it to VS2012 Update 4. If you are using VS2013, please upgrade it to VS2013 Update 1 RC.

    When I restart VS and re-load the project, the .runsettings file is still selected with the Select Test Settings File menu option and .runsettings file is still used when I run the unit test.

    I doubt that there is anything wrong with your VS. As I mentioned above, please reset your VS settings through Tools->Import and Export settings->Reset all settings…

    If no help, try some other devenv commands to fix:

    1.devenv.exe  /safemode

    2.devenv.exe  /resetskippkgs

    3.devenv.exe  /installvstemplates

    4.devenv.exe  /resetuserdata 

    devenv.exe can be located under your VSlocation/Common7/IDE

    What your need is to put it to run prompt and add commands to it.

    If the issue still exists, please repair or reinstall your VS.

    Meanwhie, if you have some anti-virus software running when you work with VS, please close them to check the reuslt.

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Amanda Zhu Monday, January 20, 2014 1:01 AM
    Tuesday, January 14, 2014 3:38 AM
  • If I run VS2013 as Administrator I get the exact problem described here. When I say run as Administrator I mean right clicking on the icon and select Run as Administrator. If I run VS2013 normally (i.e. Not as Administrator) then the problem goes away. Not sure why though, maybe someone could help?
    Wednesday, March 5, 2014 9:14 AM
  • Our team has the same issue and it is annoying. We need to use as admin due to IIS integration. I am also looking for a solution to persist the runsettings. I also have issue with default Test Architecture going back to X86 from X64. Due to this, not all tests show up. We need to keep selecting it and rebuilding the solution.
    Friday, March 13, 2015 10:07 PM