locked
Visual studio hangs while debugging in iOS RRS feed

  • Question

  • User6481 posted

    Hello,

    For a while, I've been having problems while debugging my app running in the simulator. Visual studio would simply hang randomly, I would get the "Visual Studio is busy" bubble and I would need to kill devenv.exe and restart it. It used to happen a few times every day, just enough to be annoying. Since a few releases however, it hangs 2 out of 3 runs and is a real productivity killer.

    Anyone else experiencing this?

    I'm using Windows7, Xamarin.iOs 8.4.0.26 and Visual Studio 2012 11.0.61030.00 Update 4

    Wednesday, November 12, 2014 8:56 PM

All replies

  • User6481 posted

    Is VS 2012 still officially supported or should I upgrade to VS 2013?

    Thursday, November 13, 2014 3:23 PM
  • User44756 posted

    Same here, did you solve this issue?

    Monday, January 19, 2015 7:38 PM
  • User73234 posted

    I did a repair of VS. It did not fix it in its entirety although it is noticing better. Also seems that closing certain code windows helps the cause as does not having SSMS open.

    Monday, January 19, 2015 7:52 PM
  • User3412 posted

    there is another thread for this, see here

    Monday, January 19, 2015 7:53 PM
  • User65319 posted

    Same problem here: after I manually updated my solution to iOS Unified debugging problems started.

    It also seems to be the same problem as another Android developer found here:

    https://forums.xamarin.com/discussion/comment/98265

    Setup: Xamarin.Forms PCL solution, current stable versions of Xamarin.Forms, Xamarin Studio and Visual Studio Xamarin add-on, Visual Studio 2013 Update 4, Windows 8.1 Update 64bit, NuGet packages: Json.NET 6.0.8, RestSharp 105.0.1, SQLite.NET PCL 2.5.

    Starting iOS debugging is not a problem, but it's almost for sure that while debugging at some point Visual Studio freezes saying "Visual Studio is busy" when trying to activate its window and also the app in the iOS Simulatur hangs. This happens e.g. when just clicking on a SwitchCell in my app that causes a RestSharp call using a binding like "On='{Binding ...}'".

    I then have to force quit Visual Studio 2013 via Task Manager.

    I also tried to wait and see what happens when let Visual Studio open after its freeze. After approximately 12 minutes Visual Studio got force quit by the OS. See attached file for the last entry in the %LOCALAPPDATA%\Xamarin\Log\12.0\devenv....log at that time.

    Please fix this annoying issue as soon as possible! Alas, I am not such a man of genius that I do not need to debug in order to develop...

    Thanks in advance!

    Friday, January 23, 2015 1:26 PM
  • User47902 posted

    Same issue here! When will we have a fix for this? I'm tired of running to the mac whenever I need to debug something.

    Wednesday, January 28, 2015 12:54 AM
  • User6481 posted

    Updating to the build mentionned here build fixes some of the occurrences of that bug for me. It happens but not every debug sessions like it used to.

    https://forums.xamarin.com/discussion/comment/98145/#Comment_98145

    That thread mentions that disabling resharper might help, it didn't in my case. You might want to try it anyways:

    Tool->Options->Reshaper and click "Suspend Now"

    Wednesday, January 28, 2015 4:02 PM
  • User727 posted

    I got this exact same issue. Although in my case it freezes up almost instantly (if it's because of creating a Rest call, it makes sense, since my app fetches data remotely when the app launches).

    I'm currently forced to use a custom debugger, where I send data over SignalR and I can then inspect it on the PC. But unless I catch exceptions, I'll never know the exception thrown when the app crashes. So yeah, we really need a fix for this.

    Thursday, February 19, 2015 11:57 AM
  • User65389 posted

    @Hodor (and all others that develops in VS2013)

    I'm tired of running to the mac whenever I need to debug something.

    I think, it will help you a lot, reading my post here: forums.xamarin.com/discussion/33514/important-tip-for-vs2013-developers-to-easily-access-the-mac-from-windows#latest

    And - to the real theme here - I'm not able to debug iOS and/or Android for about two months now .
    I have posted various messages, I have sent my whole project, and ... nothing happens (the only platform, I am able to debug without problems, is WP) .
    I don't understand that... as I have started in mid 2014, I don't had as much Problems as now!
    Instead of being better now (what should be normal) it has become worse and worse and...worse!
    It has already come so far, that I am afraid to install an update...
    Xamarin people - you are doing something completely wrong!

    Thursday, February 19, 2015 1:08 PM
  • User6481 posted

    Build 3.9.289 fixed most of my issues regarding debugging in visual studio

    Thursday, February 19, 2015 6:45 PM
  • User65389 posted

    I have 3.9.289 installed.

    Thursday, February 19, 2015 8:58 PM
  • User65389 posted

    @all reader of this thread: There are various problems with the debugger (iOS and Android) right now (I'm not able to debug iOS and Android now for months). There also are various threads in the VS-Forum, very confusing and time-consuming. Therefore, I have opened a new thread (proposal to solve the problems on a new and professional way):

    forums.xamarin.com/discussion/33738/proposal-solving-of-the-debugger-problems-version-3-9-302#latest

    But... this seems to interest nobody (not Xamarin and also not the other pained users).
    So.. If you want to change something, read the thread and vote...!

    Thursday, February 26, 2015 2:01 PM