none
Win CE 6.0 driver working with Ethernet Boot (EBOOT.bin) but not with Local Boot (NK.bin) RRS feed

  • Question

  • Hi Community!!

    I ported a Win XP Driver to Win CE 6.0 on x86 platform. The driver works fine when I boot the target machine (CEPC) through Ethernet. However, when I try booting the CEPC locally (using NK.bin image in a USB Flash Drive), the driver gets loaded successfully but an ASSERT fails during Association/Authentication Process. One more strange thing is this ASSERT is checked once in case of Ethernet boot but twice in case of Local boot. The ASSERT check fails during second time check.

    My question is: The OSDesign is same, Driver code is same..everything is same except the booting process. Does it make any difference at all??


    • Edited by deepak_ Tuesday, February 19, 2013 11:53 AM
    Tuesday, January 22, 2013 7:14 AM

Answers

  • Its working now!!! Seems like it was a timing issue. I removed the debug prints to minimum and now the driver works fine!!
    • Marked as answer by deepak_ Wednesday, January 30, 2013 9:47 AM
    Wednesday, January 30, 2013 9:47 AM

All replies

  • It could be a timing issue or a dependent module is loading late in case of USB boot.

    Try with sleep or change the load order.

    --- Misbah


    Senior Design Engineer T.E.S Electroni Solutions (Bangalore-India) www.tes-dst.com email-misbah.khan@tes-dst.com

    Tuesday, January 22, 2013 1:05 PM
  • yes, in both the cases same NK.bin is getting loaded.
    Tuesday, January 22, 2013 2:16 PM
  • Misbah Bhai, I gave a trial to your suggestion regarding "Load Order". I checked and found out that if "Order" is not specified, driver is loaded at last on this link. So, in my case driver gets loaded after all modules. I am looking in other things to get more clues.

    Thanks
    Thursday, January 24, 2013 2:34 PM
  • Its working now!!! Seems like it was a timing issue. I removed the debug prints to minimum and now the driver works fine!!
    • Marked as answer by deepak_ Wednesday, January 30, 2013 9:47 AM
    Wednesday, January 30, 2013 9:47 AM
  • I suspected the same ... And advised you the same .

    Good that you resolved it.

    --- Misbah


    Senior Design Engineer T.E.S Electroni Solutions (Bangalore-India) www.tes-dst.com email-misbah.khan@tes-dst.com

    Wednesday, January 30, 2013 6:06 PM