locked
How do I remove the autonumbering within Visio? RRS feed

  • Question

  • I have inherited a file of Visio maps from a previous contractor who loved to use the Autonumbering feature.  Unfortunately, I now have to figure out how to get rid of a gazillion little numbers in the shapes. I know how to turn ON the autonumber feature and how to Hide the numbers. But, what I really need to know is how to eliminate them entirely. My only option right now is to enter each shape individually and backspace the number out. I don't have the time or patience to do that through the whole stack of maps, so please help!
    Thursday, February 13, 2014 5:50 PM

Answers

  • Hiding the numbers will also eliminate the numbers from shape completely.

    Steps to Hide/eliminate Numbers

    On the View menu, point to Add-Ons, point to Visio Extras, and then click Number Shapes.

    • Click the Advanced tab. select "Hide Shape numbers" checkbox.

    • Proposed as answer by Mohan.Muthyala Wednesday, February 19, 2014 7:03 AM
    • Marked as answer by George123345 Thursday, February 27, 2014 4:23 AM
    Wednesday, February 19, 2014 7:03 AM

All replies

  • Hiding the numbers will also eliminate the numbers from shape completely.

    Steps to Hide/eliminate Numbers

    On the View menu, point to Add-Ons, point to Visio Extras, and then click Number Shapes.

    • Click the Advanced tab. select "Hide Shape numbers" checkbox.

    • Proposed as answer by Mohan.Muthyala Wednesday, February 19, 2014 7:03 AM
    • Marked as answer by George123345 Thursday, February 27, 2014 4:23 AM
    Wednesday, February 19, 2014 7:03 AM
  • The accepted answer is not correct.  In Visio 2016, using the "Hide Shape numbers" checkbox does not remove the Shape Number property, it only sets the "Hide Shape number" property to TRUE.  Furthermore, hiding the shape number doesn't remove the space from where the number would be, so the alignment of text on all the images is broken.

    The correct answer to the question is below.  HOWEVER, this solution also does not solve the original problem because it also doesn't cleanly remove the numbers without leaving spaces or zeros.  I have not found a full solution to that problem.  If anyone has that solution, please share it! :)

    To remove all the "Number Shapes" Add-on properties from multiple objects at once:

    1. Select all of the objects with numbers you want to remove.
    2. Right click and select Data -> Define Shape Data...
    3. Then in the Define Shape Data dialog box, select and Delete the 3 properties (Shape Number, Shape Number Text, and Hide Shape Number)
    4. Press OK

    Good luck!






    • Edited by AugustoMcM Monday, July 3, 2017 8:46 PM
    Monday, July 3, 2017 8:28 PM