locked
Translator Widget RRS feed

  • Question

  • Hi, What's going the Translator Widget doesn't respond and stuck at sending "request to api.microsofttranslator.com". Its' happening regularly, and for the past 12+ hrs it is simply not responding, and ending with RTO (requests time out) error, when I ping "api.microsoftranslator.com" and its IP "65.55.177.205". Right now, I've disabled the Widget, because the entire site become non-responsive.

     

    I thinks, its right time to add something new to the Widge code:

    1. Either add some alternate working IPs

    2. or add check to bypass the request, when the Widget server is down.

    So the sites running Widget continue working.

     

    DG...
    http://www.ditii.com/

    • Edited by diTii Monday, August 24, 2009 9:03 PM
    Monday, August 24, 2009 8:58 PM

Answers

  • Thank you DG... since your reports we have turned on health check services from various places worldwide to track down if there are any DNS issues that might cause this behavior. Once we are able to gather enough data we should have a clearer idea.
    Also - thank you for the suggestion on loading the widget asynchronously. We will shortly be adding it to the widget snippet. If you would like to test it - go ahead and add this javascript to your widget code snippet .
    <script type="text/javascript">
                    setTimeout(function()
                    {
                                    var s = document.createElement("script");
                                    s.type = "text/javascript";
                                    s.charset = "UTF-8";
                                    s.src = " http://api.microsofttranslator.com/v1/widget.svc/Embed?appId={appId}&from={siteLanguage}&layout={translationLayout}";
                                    document.documentElement.appendChild(s);
                    }, 0);
    </script>
    

    Vikram Dendi, Biz, Product Strategy & UX
    Microsoft Translator
    • Marked as answer by Vikram Dendi Saturday, September 5, 2009 5:37 AM
    Saturday, September 5, 2009 5:36 AM

All replies

  • DG - thank you for letting us know. I am not aware of any downtimes (scheduled or otherwise). We will dig deeper to look into any other issues that might have caused this behavior. I will also certainly pass on to the dev team your suggestions about how to deal with potential downtimes.
    If the behavior repeats itself, please go ahead and contact us at mtcont@microsoft.com and we will work with you 1:1 to get to the bottom of it.
    Vikram Dendi, Biz, Product Strategy & UX
    Microsoft Translator
    Tuesday, August 25, 2009 8:37 AM
  • Hi Vikram, Thanks for the reply. I couldn't response earlier, because my father is not well for quite some time. And as said in my original post, I kept the widget disabled for about 3-4 days, and didn't face any slowness. After that, I enabled, the widget, it worked fine until few hrs back, and now again it's happening again. I've also checked other sites running widget, and noticed same behavior. I cann't say, if the problem lies in DNS resolving for "api.microsofttranslator.com" (country specific or worldwide), or something wrong with Widget server itself. I've addressed the problem on the email you've provided in your reply.
    DG... http://www.ditii.com/
    • Proposed as answer by vexdz Wednesday, September 16, 2009 4:36 AM
    Monday, August 31, 2009 3:45 PM
  • Thank you DG... since your reports we have turned on health check services from various places worldwide to track down if there are any DNS issues that might cause this behavior. Once we are able to gather enough data we should have a clearer idea.
    Also - thank you for the suggestion on loading the widget asynchronously. We will shortly be adding it to the widget snippet. If you would like to test it - go ahead and add this javascript to your widget code snippet .
    <script type="text/javascript">
                    setTimeout(function()
                    {
                                    var s = document.createElement("script");
                                    s.type = "text/javascript";
                                    s.charset = "UTF-8";
                                    s.src = " http://api.microsofttranslator.com/v1/widget.svc/Embed?appId={appId}&from={siteLanguage}&layout={translationLayout}";
                                    document.documentElement.appendChild(s);
                    }, 0);
    </script>
    

    Vikram Dendi, Biz, Product Strategy & UX
    Microsoft Translator
    • Marked as answer by Vikram Dendi Saturday, September 5, 2009 5:37 AM
    Saturday, September 5, 2009 5:36 AM
  • Hi Vikram,

     

    Thanks for the new script code, I've added this code into my site, and will report you back, if anything unusual. The widget is really good and fast being Ajax-based.


    DG... http://www.ditii.com/
    Sunday, September 6, 2009 3:54 PM