locked
Can't start the Windows Phone Emulator

    Question

  • I just installed the Windows 8 Phone SDK and the emulator will not start. The full text of the message follows:

    The Windows Phone Emulator couldn't start because they hypervisor isn't running. The likely cause is that the hardware-assisted virtualization isn't turned on.

    I checked my BIOS and enabled it (It was off when I first installed the tools). I "repaired" the installation after enabling the virtualization support.  I check in services and the virtualization manager is running.  Anything else I can look at?

    Wednesday, October 31, 2012 1:22 AM

Answers

  • I had the same problem. Here is what I did to solve the issue:

    1. Make sure the environment meet all the requirements described in the page: http://msdn.microsoft.com/en-us/library/windowsphone/develop/ff626524(v=vs.105).aspx
    2. Make sure all the related features (e.g. Virtualization Technology) are enabled in the BIOS
    3. [Maybe not related] I had a dual boot with Windows 7 Home Premium and Windows 8 Enterprise. I uninstalled Oracle VM Virtual Box from Windows 7 just in case it may affect Hyper-V on Windows 8.
    4. Open Event Viewer > Windows Logs > System > filter logs by Source = "Hyper-V-Hypervisor" > Check errors. In my case, the error (event Id 48) is "Hypervisor launch failed; Processor does not provide the features necessary to run the hypervisor (leaf 0x80000001, register 0x3: features needed 0x28100800, features supported 0x28000800)."
    5. Update BIOS to the latest version, make sure virtualization features are still enabled in the BIOS after update. This solved my problem.

     
    Thursday, November 1, 2012 7:14 AM
  • Found my problem

    I needed to run the following from the command line

    bcdedit /set hypervisorlaunchtype auto


     See

    http://weikingteh.wordpress.com/2008/10/06/virtual-machine-could-not-be-started-because-the-hypervisor-is-not-running-boot-configuration-data-bcd/


    Sunday, February 3, 2013 2:15 PM

All replies

  • Do you have Windows 8 Pro Edition?  (Pro edition is required for Hyper-V)

    If so, check if you have "Hyper-V Manager" on your start screen or in your App Apps list.


    -Eric.

    Wednesday, October 31, 2012 3:33 PM
    Owner
  • I'm running Windows 8 Enterprise.

    On my Start Screen, I do have Hyper-V manager. When I open it, I don't have any VM's listed though.


    Pantelis

    Wednesday, October 31, 2012 4:43 PM
  • Hi,

    Does the SLAT tool report that your computer is SLAT capable?

    https://slatstatuscheck.codeplex.com/

    -Mark


    Mark Chamberlain Sr. Escalation Engineer | Microsoft Developer Support | Windows Phone 7

    Wednesday, October 31, 2012 7:23 PM
  • I ran the tool and it reports: You have a SLAT capable machine.

    All I did was install the WP8 SDK, fire up a project and hit F5. I've gone back to check for any steps I missed, but I don't see anything.


    Pantelis

    Wednesday, October 31, 2012 10:31 PM
  • I have the same problem, still finding answer.

    Thursday, November 1, 2012 12:58 AM
  • I had the same problem. Here is what I did to solve the issue:

    1. Make sure the environment meet all the requirements described in the page: http://msdn.microsoft.com/en-us/library/windowsphone/develop/ff626524(v=vs.105).aspx
    2. Make sure all the related features (e.g. Virtualization Technology) are enabled in the BIOS
    3. [Maybe not related] I had a dual boot with Windows 7 Home Premium and Windows 8 Enterprise. I uninstalled Oracle VM Virtual Box from Windows 7 just in case it may affect Hyper-V on Windows 8.
    4. Open Event Viewer > Windows Logs > System > filter logs by Source = "Hyper-V-Hypervisor" > Check errors. In my case, the error (event Id 48) is "Hypervisor launch failed; Processor does not provide the features necessary to run the hypervisor (leaf 0x80000001, register 0x3: features needed 0x28100800, features supported 0x28000800)."
    5. Update BIOS to the latest version, make sure virtualization features are still enabled in the BIOS after update. This solved my problem.

     
    Thursday, November 1, 2012 7:14 AM
  • I have an i7 processor, and all the bios settings are available and enabled. My BIOS version is a bit old, but the HP update is currently not updating it for whatever reason.

    Pantelis

    Thursday, November 1, 2012 12:05 PM
  • Thank you Ren. I will ensure the Emulator Troubleshooter contains your additional checks.

    -Mark


    Mark Chamberlain Sr. Escalation Engineer | Microsoft Developer Support | Windows Phone 7


    Thursday, November 1, 2012 2:44 PM
  • In my event viewer I have:

    Hypervisor launch failed; Processor does not provide the features necessary to run the hypervisor (leaf 0x80000001, register 0x3: features needed 0x28100800, features supported 0x28000800).

    So, I'm missing a feature, but I can't tell which one. I have an Envy14, and the BIOS update from HP isn't doing anything.


    Pantelis

    Friday, November 2, 2012 12:14 AM
  • Does the following app report success?

    https://slatstatuscheck.codeplex.com/

    Make sure the BIOS setup screen has everything related to virtualization enabled.

    -Mark


    Mark Chamberlain Sr. Escalation Engineer | Microsoft Developer Support | Windows Phone 7

    Friday, November 2, 2012 3:12 PM
  • It reports "You have a SLAT capable machine."

    Pantelis

    Friday, November 2, 2012 11:28 PM
  • Are you able to manually enable the Windows feature, Hyper-V Manager, via Programs and Features in the Control Panel?  If yes, can you launch Hyper-V Manager? 

    -Mark


    Mark Chamberlain Sr. Escalation Engineer | Microsoft Developer Support | Windows Phone 7

    Saturday, November 3, 2012 12:28 AM
  • I can launch the Hyper-V Manager. I assume the Windows 8 Phone SDK enabled it, or it was enabled by default by the Windows 8 Installation.

    When I go into Hyper-V Manager it says, No Virtual Machines were found on this server.


    Pantelis

    Saturday, November 3, 2012 12:32 PM
  • I am also having this exact same problem, I've been trying to resolve it for the last 3 days or so. I've tried just about everything that I've read about in this thread as well as others.

    I have gone down the entire list of prerequisites several times and everything checks out fine. I have Windows 8 Pro 64-bit, Intel Core i5-2500k Sandy Bridge, 8GB RAM. I've verified that hardware virtualization is enabled in my BIOS (even flashed my BIOS to the newest version available on Gigabit's site), verified that my computer is SLAT compatible and DEP is enabled.

    Hyper-V is running when I look in services, and I can run Hyper-V Manager just fine. I've looked in the EventViewer and there are absolutely no errors related to Hyper-V, merely just a bunch of "Information" logs.

    I'm really at a loss as to what the problem is, there's no errors for me to work off of and as far as I can tell everything about my computer checks out on the prerequisites checklist.

    Anybody have any other ideas on what could be causing this issue? Or at least any other way I can possibly get more information as to what could be causing this issue?

    Monday, November 5, 2012 8:22 AM
  • Hi,

    Gigabit or Gigabyte? There is a known issue with certain Gigabyte motherboards, but it is a boot issue. There could be other issues with the motherboard as well?

    One possible root cause of this is if you are using a Gigabyte motherboard’s USB3 controller.
    More information: Boot failure after installation of Hyper-V role on Gigabyte systems

    Can you provide the full motherboard manufacturer/model and BIOS version? This can help in determining if there is a hardware or 3rd party driver compatibility.

    -Mark


    Mark Chamberlain Sr. Escalation Engineer | Microsoft Developer Support | Windows Phone 7

    Monday, November 5, 2012 3:28 PM
  • Sorry, yeah, Gigabyte. My exact mother board is this. Yesterday I flashed the F7 bios from Gigabyte's website and verified that the Virtualization support was enabled.

    This morning before work I disabled the USB3.0 controllers in the BIOS and tried to run the emulator again. Unfortunately I still get exactly the same error.

    - Jeremy

    Monday, November 5, 2012 8:07 PM
  • I had the same issue. I was running Windows 8 Enterprise Preview, but in addition my HDD had W8 Consumer Preview as Well as Windows 7 all on different partitions. I basically got rid of all the partitions and installed a clean version of Windows 8 Pro. That did the trick! I don't know whether having all those partitions/OSs created some sort of conflict or not but WP8 Emulator works nicely now!

    PS

    ** Always backup your data before doing anything drastic***

    Tuesday, November 6, 2012 2:04 PM
  • I'm having a similar issue to TheJerm0034.

    I'm getting this message: 

    Error 1 Deployment failed because no Windows Phone 8 phone was detected. Make sure a phone is connected and powered on. 0 0

    Every time I try to deploy my project. I don't have a Windows phone connected and I'm 100% sure I meet all criteria to launch the emulator. I tried repairing my installation but it doesn't seem to make a difference. I have a new MSI motherboard and an i5 Ivy-Bridge processor, is there anything I can provide/look into that might help me figure out why the emulator simply won't launch?

    Thanks!

    Edit: Found it!

    http://social.msdn.microsoft.com/Forums/en-US/wptools/thread/c7b16c88-9c34-461d-bba3-24fac300a5d5

    TL;DR  I didn't have permissions, try creating a .bat file with these commands (replace the directories if you need to):

    @echo off
    "C:\Program Files (x86)\Microsoft XDE\8.0\xde.exe" -createDiffDisk "C:\Users\<USERNAME>\AppData\Local\Microsoft\XDE\dd.480x800.512.vhd" -vhd "C:\Program Files (x86)\Microsoft SDKs\Windows Phone\v8.0\Emulation\Images\Flash.480x800.vhd" 

    Hope this helps!


    -Everett 


    • Edited by NewETown Wednesday, November 7, 2012 2:08 AM Found my answer
    Wednesday, November 7, 2012 1:57 AM
  • My current setup only has 1 partition, which Windows 8 is installed to. When I upgraded to Windows 8 I got the "update" version that installs over Windows 7. So it was not a clean install of Windows 8. My hope was to avoid doing a clean install because I don't want to spend the time getting everything setup the way I like it again. I just wanted to be able to jump into Windows 8 and go.

    Do you think using the upgrade option for Windows 8 could be causing this problem? I would really really like to avoid having to do a clean install.

    - Jeremy

    Wednesday, November 7, 2012 2:37 AM
  • If you don't want to go through the trouble of doing a clean install, then I suggest you hold on until a proper fix comes out. It also depends on how badly you need the WP8 Emulator. If you urgently need it, its worth taking the risk. Just remember to backup your info.

    If you finally bite the bullet and do a clean install make sure you do all necessary Windows Updates and also install Hyper -V from 'Turn Windows Features On' before installing WP SDK 8.0. Also make sure Virtualization is set to Enabled from start to finish of all installations.

    Seriously, if your system specs check out this should definitely work. 

    Wednesday, November 7, 2012 11:28 AM
  • I had to slap on a new external hard drive, put on Win7, update my BIOS, then go back to Win8 and it worked.


    Pantelis

    Wednesday, November 7, 2012 2:26 PM
  • I'd really rather not have to do a clean install. The problem is I still don't even know what's causing this issue. People have mentioned that there is a boot issue if you have a Gigabyte motherboard with the USB 3.0 controller enabled, but I don't think that's the case here because my machine boots up just fine. The emulator is the only thing I'm having a problem with. I'm also not getting any errors whatsoever in the EventViewer related to Hyper-V so I'm not sure what's even causing this issue.

    I've been over the prerequisites many many times and ran all the tools and I am extremely confident that my system meets all the requirements (I built this machine under a year ago). Getting the emulator up and running isn't going to be an urgent matter pretty soon, I just ordered a Lumia 920 so I'll at least be able to test with that. But it still kinda bugs me that the emulator does not work, often times when developing I use the emulator so I don't have to deal with fumbling with my phone. But I guess for now testing on the device is my only solution.

    - Jeremy

    Thursday, November 8, 2012 5:59 AM
  • @Jeremy Honestly, it's a real pain when your system meets all the requirements and still can't figure out what the real problem is!

    I prefer doing all testing on a real device anyway, so even though my em works flawlessly well I doubt I'll use it that much.

    Good luck with finding a solution.

    - McKnight

     

    Thursday, November 8, 2012 10:05 AM
  • One option is to remove and set aside your existing hard drive (i.e. avoid cleaning it) and replace it with another new or used drive (internal or external). Then perform the clean install etc. using the replacement drive. If you are satisfied with the results, then you can use the Windows migration tool to migrate your disk settings by attaching your old disk as drive D:. If not successful, go back to using your original drive.

    -Mark


    Mark Chamberlain Sr. Escalation Engineer | Microsoft Developer Support | Windows Phone 7

    Thursday, November 8, 2012 5:05 PM
  • Hi ,

    I had the emulator working fine on my i7 Dell PC until I decided to add another display. In the BIOS I turned on Intel Multi Display and since this I get an error message saying the emulator couldnt start because the hypervisor isn't running.

    Is there any way around this?

    • Proposed as answer by Griffinx Sunday, February 3, 2013 2:14 PM
    • Unproposed as answer by Griffinx Sunday, February 3, 2013 2:14 PM
    Sunday, February 3, 2013 1:36 PM
  • Found my problem

    I needed to run the following from the command line

    bcdedit /set hypervisorlaunchtype auto


     See

    http://weikingteh.wordpress.com/2008/10/06/virtual-machine-could-not-be-started-because-the-hypervisor-is-not-running-boot-configuration-data-bcd/


    Sunday, February 3, 2013 2:15 PM
  • Too bad.  reinstalled vs 2012, wp8 sdk.  All worked.  But after restart, again started getting timeout issue.

    MS, please do not hide the problem.  Please provide a hot fix.  Taking too much of time.

    Sunday, February 17, 2013 8:57 PM
  • Hi Laktan,

    If it works right after installation, but fails after restart, this suggests there is third party software that is detecting the emulator and/or its virtual network switching, hooking itself in, and causing the failure. This could be a virus, malware, antivirus software, network monitoring software, registry monitoring software, or other virtualization software.

    -Mark


    Mark Chamberlain Sr. Escalation Engineer | Microsoft Developer Support | Windows Phone 8

    Tuesday, February 19, 2013 4:10 PM
  • I had the same problem, everything (BIOS/Hyper-V) settings appeared to be correct but the emulator will not launch.

    Mine got resolved after following steps

    1. Remove Hyper-V using "Turn windows feature on or off" 
    2. Restart 
    3. Add the Hyper-V feature back
    4. Restart
    5. Open the Windows Phone Project
    6. VS will ask you to run in elevated privileges to configure the emulator and hyper-v settings for the first time.
    7. Emulator will start

    Let me know if this works for anyone having this problem.

    Friday, March 22, 2013 6:37 AM
  • Thanks for the tip. This fix worked for me as I too had a dual-boot that I recently converted back to a single boot.
    Wednesday, May 22, 2013 1:02 AM
  • Just make sure all services  Hyper-V terminal are starting with your windows and service called "Iminent" as well . If not change windows start-up setting ( you can use command "msconfig" to change it).

    and restart your windows 

    It was works for me. Hope it will help you as well 

       
    Monday, June 10, 2013 10:11 PM
  • Hi I am having the same error, although I know this thread quite old, but found to be useful for me.

    Hypervisor launch failed; Processor does not provide the features necessary to run the hypervisor (leaf 0x80000001, register 0x3: features needed 0x28100800, features supported 0x28000800).

    Now as you have suggested that I should update BIOS, but Lenovo does not provide any BIOS update for the system. What shall I do now? Is there any other way? I bought this computer last day thinking that I would be developing windows phone apps but now I can't. Any idea how I resolve this issue.

    I don't understand why Microsoft / Lenovo or HP is making so much difficulty for the windows phone developers.

    Please help

    Sunday, July 28, 2013 6:33 PM
  • I'm have the same situation. I am porting an existing WM7 app to WM8. Bought a Lenovo Windows 8 Yoga. Just upgraded it from Windows 8 to Windows 8 Pro, as required. And I have been spending most of the day (thus far) attempting to get the emulator to start.

    I have done all of the recommended stuff above. SLAT tool says I am good, etc. No errors in the event viewer, can run the Hyper - V - Manager no problem. Still Emulator says "The Windows Phone Emulator couldn't start because Hypervisor is not running".

    What's the deal? When are we going to get a fix for this???

    We are stuck as far as I can tell.


    srs

    Friday, August 9, 2013 8:46 PM
  • It seems to me that Lenovo intentionally does some trick to improve their performance and they forget the Emulator and Hyper-V part, and it's creating the problem. Because I have the same type configuration in Dell System in my office which runs perfectly.

    Microsoft, there is no point to contact Lenovo because they are horrible in customer service.

    Monday, August 12, 2013 7:31 AM
  • I had the same issue. So I just uninstalled virtualbox and it worked for me 
    Friday, October 25, 2013 4:52 AM
  • I found this and it really helped me (thnx to http://stackoverflow.com/users/983906/ogur):

    I found this is the key thing to check, as per (WP8) Emulator (XDE) Troubleshooting Tips on msdn:

    1. Launch the “Network Connections” manager (from the home screen, type in “View Network Connections”, It will be listed under Settings)

    2. Right click on the adapter named: “vEthernet (Internal Ethernet Port Windows Phone Emulator Internal Switch)”

    3. For that adapter, the only items that should be checked under “This connection uses the following items:” should be:

      • Client for Microsoft Networks
      • QoS Packet Scheduler
      • File and Printer Sharing for Microsoft Networks
      • Microsoft LLDP Protocol Driver
      • Link-Layer Topology Discovery Mapper I/O Driver
      • Link-Layer Topology Discovery Responder
      • Internet Protocol Version 6 (TCP/IPv6)
      • Internet Protocol Version 4 (TCP/IPv4)
    4. All other items should be unchecked.

    Sunday, October 27, 2013 5:12 PM
  • Unfortunately this didn't work for me.  Is this a problem with having run this command?


    www.PCHenry.com

    Saturday, October 25, 2014 1:32 AM