none
DeviceStatusCheck step - Reporting issues with devices RRS feed

  • Question

  • Hello,

           I am running the Sleep and PnP (disable and enable) with IO Before and After (Certification - Software Device) test and it has a setup step called DeviceStatusCheck.

    This is the only reported error in the log:

    Message 12/6/2012 6:31:42.262 PM WDTF_TARGETS : Target: QEMU QEMU DVD-ROM ATA Device (D:\) IDE\CDROMQEMU_QEMU_DVD-ROM_______________________0.10____\5&5ECB6E4&0&1.1.0
    Error 12/6/2012 6:31:42.262 PM WDTF_TEST : Found a device that has a non-zero problem code or is phantom. Logging device info.
    File: Line: -1
    Error Type:
    Error Code: 0x0
    Error Text: Error 0x00000000

    Where does it log the error to?

    Thanks very much,

    Jonathan

    Thursday, December 6, 2012 11:30 PM

All replies

  • Device information is logged to the same file. See the lines next to what you pasted.

    This posting is provided AS IS with no warranties, and confers no rights.

    Friday, December 7, 2012 2:26 AM
  • Hi Jsalama,

    I used to face this problem whenever I run sleep and pnp test. Now, I get rid of it by uninstalling "High Definition Audio Device" from device manager of that particular client machine. Without uninstalling "HD Audio Device" this test wont pass in my case. This is what I do:

    a) Before applying sleep and pnp test, uninstall "HD Audio Device" from device manager on the client machine on which you are going to run this test.

    b) Apply test, it will run on client machine, Device Status check will pass (green text on cmd window indicates Device status check passed), then system will restart.

    c) As system loads after restart, keep uninstalling "HD Audio Device" again and again, untill some window containg a big white ball comes up.

    d) Thats it, after this window, test will continue as usual.

    I have raised this issue at http://social.msdn.microsoft.com/Forums/en-US/whck/thread/49dd30ce-c138-4adc-abd1-aaa4935f2bda . Lets see what MSFT people have to say about it.

    Friday, December 7, 2012 7:41 AM
  • Srepaka,

       Please forgive my confusion but what do you mean by "lines next to what you pasted"? 

    Do you mean the lines after the error one?

    Thanks!

    Friday, December 7, 2012 4:26 PM
  • Yes, I mean lines after the error message. Thanks.


    This posting is provided AS IS with no warranties, and confers no rights.

    Saturday, December 8, 2012 2:07 AM
  • No need to uninstall the HD Audio Device just disable from your bios configuration and if you have an optical drive try to disconnect. Are you using wifi or wired?

    Monday, December 10, 2012 3:18 AM
  • Per the link to the other thread you provided, uninstalling a device during testing to avoid a test failure is not a valid work around, as you are not addressing the cause of the error. Please review the contents of the log file to determine the root cause of the failure.
    Monday, December 10, 2012 6:33 PM
  • Hi, I hope I still can reply to this forum.

    I am using HCK 2.0 because with this tool I have already passed test for Win 7 32 bit.

    Is it good or shall I pass to HCK 2.1.

    I, I have similar problem on WIndows 7 64 bit, in the sense that I do not refer to HD audio device.

    As for "the lines next", they refer to my driver, my Device Under Test which I wish to be certified.

    Please notice that in WIndows 7 32 bit the same test has passed for the same device.

    As a workaround, I tried to boot before test using F8 and option to use unsigned driver, then I used something like "bcdedit set debug on" and now bcdedit shows debug settings as present. I hope this was correct, otherwise I can revert this.

    Is there any procedure I shall do in order to get my driver to appear as signed?

    Thanks in advance for any reply.


    • Edited by grippas Monday, November 11, 2013 10:10 AM
    Monday, November 11, 2013 10:09 AM
  • I'm a little confused how this relates to the current thread.

    To answer your first question about using HCK 2.0 or HCK 2.1, it is ok to use HCK 2.0 for now. At the end of this month, we will no longer accept HCK 2.0 submissions.


    John -- This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, November 13, 2013 5:32 PM
  • Hi John, 

    thanks for your info about the near end of the possibility to use HCK 2.0 submissions. I am sorry if this question was outside the scope of this forum.

    As for my second question, it is the same as asked before by Jonathan.

    The only additional info is that, in my case, the additional lines of the log refer to my Device Under Test. Any hint about how to solve this problem?

    It is curious that the problem appeared to me in Windows 7 64 bit, while it did not appear in Windows 7 32 bit.

    Thanks again for your first reply.

    Stefano

    Thursday, November 14, 2013 10:46 AM