locked
Can not deploy LightSwitch to local IIS RRS feed

  • Question

  • Hi All,

    I have tried to deploy my LightSwitch Application to local iis but when I try to validate connection, it throw an error: "Connected to localhost using the Web Deployment Agent Service, but could not authorize".

    My config: 

    - Service URL: http://localhost

    - Site/Application:  Default Web Site/Mango

    Please give me a way to resolved it.

    Thanks,

    Hien Phan

    Tuesday, December 29, 2015 10:35 AM

Answers

  • Having recently set-up a copy of IIS 10 on a new development machine for the purposes of publishing to localhost, I noted the following aspects that needed to be configured in addition to the default options: -

    Additional "Turn Windows feature on or off" settings

    • .NET Framework 4.6 Advanced Services \ WCF Services
      - HTTP Activation
      - TCP Port Sharing
    • Internet Information Services \ Web Management Tools
      - IIS Management Console
      - IIS Management Service
    • Internet Information Services \ World Wide Web Services \ Application Development Features
      - .NET Extensibility 3.5
      - .NET Extensibility 4.6
      - ASP.NET 3.5
      - ASP.NET 4.6
      - ISAPI Extensions
      - ISAPI Filters
    • Internet Information Services \ World Wide Web Services \ Health and Diagnostics
      - HTTP Logging
      - Logging Tools
      - Request Monitor
    • Internet Information Services \ World Wide Web Services \ Security
      - Request Filtering
      - Windows Authentication

    Options in IIS

    • Default Web Site Home \ IIS Group \ Authentication \ Enable Forms Authentication
    • Main Server Node \ RHS Actions \ Get New Web Platform Components \ Installed Web Deployment Tool 2.1

    HTH,

    Chris


    • Edited by ChrisCookDev Wednesday, December 30, 2015 10:49 PM
    • Proposed as answer by Angie Xu Thursday, January 7, 2016 1:58 AM
    • Marked as answer by Angie Xu Thursday, January 7, 2016 1:58 AM
    Wednesday, December 30, 2015 10:48 PM

All replies

  • Try run Visual Studio "As Administrtator".
    Tuesday, December 29, 2015 1:38 PM
  • It's already run as Administrator
    Wednesday, December 30, 2015 10:14 AM
  • Having recently set-up a copy of IIS 10 on a new development machine for the purposes of publishing to localhost, I noted the following aspects that needed to be configured in addition to the default options: -

    Additional "Turn Windows feature on or off" settings

    • .NET Framework 4.6 Advanced Services \ WCF Services
      - HTTP Activation
      - TCP Port Sharing
    • Internet Information Services \ Web Management Tools
      - IIS Management Console
      - IIS Management Service
    • Internet Information Services \ World Wide Web Services \ Application Development Features
      - .NET Extensibility 3.5
      - .NET Extensibility 4.6
      - ASP.NET 3.5
      - ASP.NET 4.6
      - ISAPI Extensions
      - ISAPI Filters
    • Internet Information Services \ World Wide Web Services \ Health and Diagnostics
      - HTTP Logging
      - Logging Tools
      - Request Monitor
    • Internet Information Services \ World Wide Web Services \ Security
      - Request Filtering
      - Windows Authentication

    Options in IIS

    • Default Web Site Home \ IIS Group \ Authentication \ Enable Forms Authentication
    • Main Server Node \ RHS Actions \ Get New Web Platform Components \ Installed Web Deployment Tool 2.1

    HTH,

    Chris


    • Edited by ChrisCookDev Wednesday, December 30, 2015 10:49 PM
    • Proposed as answer by Angie Xu Thursday, January 7, 2016 1:58 AM
    • Marked as answer by Angie Xu Thursday, January 7, 2016 1:58 AM
    Wednesday, December 30, 2015 10:48 PM
  • Thanks for your reply.

    Could you confirm  at config "Service URL: http://localhost" or "Service URL: localhost"?

    Thursday, December 31, 2015 4:30 AM
  • I receive the following successful validation message when using http://localhost which then successfully deploys:

    publish with http://localhost

    However, if I use just localhost, I see the following validation error (though it does go on to still publish successfully):

    Publish validation error with just localhost

    HTH,

    Chris


    • Edited by ChrisCookDev Thursday, December 31, 2015 1:02 PM
    Thursday, December 31, 2015 1:02 PM