locked
what versions of IIs and .Net are compatible? RRS feed

  • Question

  • User186897 posted

    Hello

    can I know what versions of IIS and .Net are required for my application to run.

    I am using visual studio community 2015

    Is there any compatible matrix link/links where I can see all these compatibilities?

    Friday, April 29, 2016 12:46 PM

Answers

  • User753101303 posted

    The point is that VS 2015 allows to create ASP.NET 2.0 to ASP.NET 4.x or even ASP.NET Core 1.0 applications so there is no such thing as a "VS Community 2015 application". What matters is the .NET Framework version you are targetting (which is defined in "project properties", you should see also a drop down when creating your project).

    Using .NET Framework 4.5 or later requires Windows Server 2008 SP2/R2 or later. Try https://msdn.microsoft.com/en-us/library/8z6watww(v=vs.110).aspx and the IIS version that comes with the OS is enough.

    Note also that all 4.x versions are a highly compatible replacement for the 4.0 version (ie you can't install 4.5.1 and 4.0 for example, 4.5.1 replaces 4.0 and will run all 4.x applications up to 4.5.1).

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, May 2, 2016 8:41 AM

All replies

  • User-1636183269 posted

    Lexis,

    Please refer

    http://docs.asp.net/en/latest/publishing/iis-with-msdeploy.html

    Friday, April 29, 2016 12:51 PM
  • User753101303 posted

    Hi,

    Depends on which .NET Framework version your app is targeting. Usually this is done AFAIK the other way round that is your see what will be available to deploy your app and you target that.

    4.x works on Windows Server 2008 and later. Windows Server 2003/IIS6 is limited to 4.0.

    Friday, April 29, 2016 1:00 PM
  • User1806930132 posted

    Is there any link which shows a table of compatability of .net versions, IIS and visual studio?

    Friday, April 29, 2016 11:46 PM
  • User1806930132 posted

    I want to know what versions of IIS and .Net framework should be installed on a server(minimum requirement on server) for a visual studio community2015 version applications to run on it?

    Sunday, May 1, 2016 9:06 PM
  • User753101303 posted

    The point is that VS 2015 allows to create ASP.NET 2.0 to ASP.NET 4.x or even ASP.NET Core 1.0 applications so there is no such thing as a "VS Community 2015 application". What matters is the .NET Framework version you are targetting (which is defined in "project properties", you should see also a drop down when creating your project).

    Using .NET Framework 4.5 or later requires Windows Server 2008 SP2/R2 or later. Try https://msdn.microsoft.com/en-us/library/8z6watww(v=vs.110).aspx and the IIS version that comes with the OS is enough.

    Note also that all 4.x versions are a highly compatible replacement for the 4.0 version (ie you can't install 4.5.1 and 4.0 for example, 4.5.1 replaces 4.0 and will run all 4.x applications up to 4.5.1).

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, May 2, 2016 8:41 AM