Debugging - breakpoints not being hit RRS feed

  • Question

  • User2096382003 posted

    Im having problems with running my application in debug mode. It doesn't hit my code at all, none of my breakpoints get hit...

    Its set to run in Debug and the web.config has the correct debug setting as true

    The application is using IIS to run and when i run in debug mode i see a process - w3wp.exe - in the dropdown

    there are no other options in this dropdown.

    however if i choose debug > attach to process, i see 2 w3wp.exe processes , one is greyed out, the one showing in the dropdown, if i attach to the other process and refresh the web page, it doesn't load, just stays loading with nothing happening as regards breakpoints being hit and i eventually have to close down the page.

    Tried restarting app pools, site in IIS, removing temporary files but nothing seems to be working...

    Also in IE i keep getting a just-in-time debugger popup asking if i want to connect to a new debugger instance in VS 2010, 2012 or 2017... i dont get this prompt in Chrome it just seems to hang and do nothing....

    Any ideas as to why debugging is not working properly?

    Tuesday, September 12, 2017 2:40 PM

All replies

  • User347430248 posted

    Hi mark-1961,

    from your description, its looks like you are not debugging the application in visual studio?

    so here I want to confirm with you that , whether you are using Visual Studio for debugging the Application or not.

    if you are not using the Visual studio then this is not the correct forum for the question.

    let us know how actually you are debugging like with only iis or in any other way.

    so that we can try to find the suitable forum and redirect you there.



    Wednesday, September 13, 2017 7:19 AM