locked
IIS getting rid of username and password authentication prompt RRS feed

  • Question

  • User1391312845 posted

    Hi,

    First of all, I'm a newbie, so forgive me.  I'm running IIS 5.1 on Windows XP Pro and I'm just trying to do something really simple.

    I'm just trying to test out loading a page on from my local computer, http://localhost/localstart.asp". When I run this local address on Firefox, it loads the page fine without any username/password authentication box.

    But when I run this in IE 7, a username/password authentican prompt always appears.  I'm trying to get rid of this prompt, so I can load the page without typing in any username/password.

    And even when I enter the username and password in the authentication prompt, it still cannot log me in or give me access to the page.

    THINGS I HAVE TRIED:

    1. Enabling Anonymous access and allowing IIS to control password.

    2. Enabling Anonymous access NOT allowing IIS to control password.

    3. Disabling Anonymous access, but enabling Integrated Windows authentication.

    I really need to get this fixed.  Please advise. Thanks!

     

    Tuesday, April 7, 2009 3:47 AM

Answers

All replies

  • User1632528892 posted

    Hi,

    What status code (error) do you see in your log files if you browse using IE7 now ? Try disabling 'Show Friendly Error Messages' in your browser.

    See if these KB articles help at all :

    "HTTP 500.100 - Internal Server Error - ASP Error" Error Message When Opening Default Web Site on Local Computer

    Internet Explorer May Prompt You for a Password

    Regards,

    Tuesday, April 7, 2009 5:01 AM
  • User-823196590 posted

    There are two pieces to authentication - the IIS settings and NTFS file permissions.

    Make sure that the IUSR_yourcomputername account has NTFS Read permissions to your content folder and files (C:\inetpub\wwwroot by default).

    Tuesday, April 7, 2009 9:52 AM
  • User1391312845 posted

    How and where can i check to see if the IUSR_yourcomputername account has NTFS Read permissions?

    In IIS, I checked the Home Directory tab, and it shows the C:\inetpub\wwwroot folder with the Read, Directory Browsing, Log visits, and Index this resource permissions enabled.

     

    Tuesday, April 7, 2009 2:56 PM
  • User-823196590 posted

    You need to use Windows Explorer.  The Security tab may not be present if you have simple file sharing enabled. Some general references:

    http://support.microsoft.com/kb/307874

    http://support.microsoft.com/kb/271071

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, April 7, 2009 3:52 PM
  • User1391312845 posted

    Ok, with IIS 5.1 installed on Windows XP Pro, there actually is a Web Sharing tab that shows up for the folder c:\inetpub\wwwroot.  I don't see any Security tab. 

    The Web Sharing tab shows the c:\inetpub\wwwroot folder with the Read, Directory browsing, etc. permission.  So I believe there is access to this folder.

    ---------------------------------------------------------------------------------------------------------------------------------------

    When IIS uses the authentication method "Integrated Windows authentication", and DISABLED Anonymous access, this is what happens:

    When I load http://localhost/localstart.asp in Firefox, it loads up fine.

    But when I try to load the same page in IE7,  it prompts for a username/password.  I tried my Adminstrator username and password, but it still can't login.

    This is error message I get:

    HTTP 401.2 - Unauthorized: Logon failed due to server configuration
    Internet Information Services


    Technical Information (for support personnel)

    • Background:
      This is usually caused by a server-side script not sending the proper WWW-Authenticate header field. Using Active Server Pages scripting this is done by using the AddHeader method of the Response object to request that the client use a certain authentication method to access the resource.

     ----------------------------------------------------------------------------------------------------------------------------------------

     Now when I ENABLED the Anonymous authentication method (and checked IIS control password option), I CANNOT load "http://localhost/localstart.asp" from BOTH Firefox and IE7.  This time IE7 doesn't pop up with the Login box to ask me for the username/password at all.  I get the error message:

    HTTP 500.100 - Internal Server Error - ASP error
    Internet Information Services


    Technical Information (for support personnel)

  • Error Type:
    Microsoft VBScript runtime (0x800A0046)
    Permission denied: 'GetObject'
    /localstart.asp, line 40

     

  • Browser Type:
    Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8

     

  • Page:
    GET /localstart.asp

     

  • Time:
    Tuesday, April 07, 2009, 3:05:09 PM
  •  
  • -------------------------------------------------------------------------------------------------------------
  •  
  •  
  • And I also tried the things in this link "http://support.microsoft.com/kb/255650" to try to resolve the issue, but was unsuccesfful.
  •  
  • Any thoughts?
  •  

     

     

     

Tuesday, April 7, 2009 6:14 PM
  • User1632528892 posted

    Ok, with IIS 5.1 installed on Windows XP Pro, there actually is a Web Sharing tab that shows up for the folder c:\inetpub\wwwroot.  I don't see any Security tab. 
     

    Refer to this KB article for details of how to enable the Security tab :

    How to disable simple file sharing and how to set permissions on a shared folder in Windows XP

    Regards,

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, April 8, 2009 5:48 AM
  • User-823196590 posted

    I don't see any Security tab.

    Didn't you read my post?  I warned you about that ahead of time ...

    Wednesday, April 8, 2009 9:27 AM
  • User619502925 posted

    I just have the same problem.

    IE ask me username and pass when I try to open .asp files (Not for html files).

    As you can see in the picture IUSR_mycomputername has the permissions.

    Permissions 

    So what should I do more?

    Thursday, April 23, 2009 10:30 AM
  • User-823196590 posted

    Make sure all permission are set correctly:

    http://support.microsoft.com/kb/812614

    Thursday, April 23, 2009 11:29 AM
  • User1586922133 posted

    There are two pieces to authentication - the IIS settings and NTFS file permissions.

    Make sure that the IUSR_yourcomputername account has NTFS Read permissions to your content

     

    That did it for me.  I manually added my specific administrator userid to the "Inetpub" folder with "full access" and now both the "localhost" url and the "server virtual machine" that I was trying to access are working.  Now if everything else goes like this (I'm trying to install a server/ms sql 2005 for exam 70-431) I will be in "hog heaven" (I hope)).

    Thanks,

    Tom Miller 

     

    Sunday, February 28, 2010 9:12 AM
  • User-2065464705 posted

     

    dear tom

    no chage there i chked all permissions but prompting is there i palce u the detauled response

    first it asks for username & Password after giving it right

     

    it shows this response

    Plz help

     

    Also i want to remove this prompting

    You are not authorized to view this page

    You do not have permission to view this directory or page using the credentials you supplied.</ID>

    Please try the following:

    • Click the Refresh button to try again with different credentials.
    • If you believe you should be able to view this directory or page, please contact the Web site administrator by using the e-mail address or phone number listed on the <script> <!-- if (!((window.navigator.userAgent.indexOf("MSIE") > 0) && (window.navigator.appVersion.charAt(0) == "2"))) { Homepage(); } //--> </script> localhost home page.

    HTTP 401.1 - Unauthorized: Logon Failed
    Internet Information Services


    Saturday, April 3, 2010 3:01 PM
  • User-823196590 posted

     The key here is the 401.1 response, which simply means bad user name or password.  Are you trying to allow anonymous access?

    Saturday, April 3, 2010 4:44 PM
  • User-1651381116 posted

    Just try this i had tried and my prob got solved..............

    For Firefox

    1. Open firefox and type in the address bar about:config

    2. type ntlm in the textbox.

    3. Double click on network.automatic-ntlm-auth.trusted-uris and type localhost there.

    4. Click on OK.

     

    In your IE Browser:

    1. Go to the Top menu "Tools" -> "Internet Options".

    2. Then choose the "Advanced" Tab.

    3. Then Scroll all the way down and "Uncheck" the Checkbox corresponding to "Enable Integrated Windows Authentication".

    4. Then Click the button that says "Apply" and then "OK".

    5. Close the browser and in a new browser try http://localhost.

    Saturday, November 13, 2010 3:55 PM
  • User-982921742 posted

    Originally, my websites, which were ASP.NET 4.0 and public facing, did not experience this because I had anonymous access enabled.

     However, to get MS Index Server 3.0 to return search results to my web page, I had to enable web sharing on the folders in my website.

    This then caused the username and password authentication prompt to be thrown.  If I refuse to enter credentials, I get:

    HTTP Error 401.2 - Unauthorized: Access is denied due to server configuration.
    Internet Information Services (IIS)

    What can I do to allow anonymous access again?

    Tuesday, August 16, 2011 6:38 PM
  • User-1922998215 posted
    Hi, I know you may have resolved this problem by now, but if it happens again, all you need to do is a) on internet explorer, 1) go to internet options under tools/settings 2)scroll down and click on internet options 3) click the Advanced tab, and then click on ''restore advanced settings'' this will restore the normal settings under advanced tab. 4)Click OK and that's all! Ensure that under the security tab, all the internet options are set to at least medium for security reasons. I experienced the same problem as you did but I was able to resolve it using the steps above. I hope this helps?.........
    Friday, October 21, 2011 8:09 PM
  • User-1882988399 posted

    I am also geting the same problem when we try to browse localhost in Firefox...

    But when we try to browse in IE then it is working fine..

    Saturday, December 29, 2012 5:33 AM