none
"The mailbox that was requested doesn't support the specified RequestServerVersion" -while trying to fetch data for room mailboxes RRS feed

  • Question

  • Hi,

     I try to get the room mailbox usage with the use of

    service->GetUserAvailability(IEnumerable<AttendeeInfo>, TimeWindow, AvailabilityData, AvailabilityOptions)

    where service is invoked by service = gcnew ExchangeService(ExchangeVersion::Exchange_version)

    but the API is throwing error as "The mailbox that was requested doesn't support the specified RequestServerVersion.GetType:Microsoft.Exchange.WebServices.Data.ServiceResponseExceptionToString:Microsoft.Exchange.WebServices.Data.ServiceResponseException: The mailbox that was requested doesn't support the specified RequestServerVersion."

    I'm loading the corresponding Exchange server version,even then I'm getting the above error. May I know what is the cause of the error and how to solve it ? Are there any possibility for the error to araise if I load Exchange2007_SP1 server version and try to read 2007 RTM data?

    Thanks in advance

    Wednesday, September 28, 2016 2:16 PM

Answers

  • >> Are there any possibility for the error to araise if I load Exchange2007_SP1 server version and try to read 2007 RTM data?

    Yes the ItemId format changed between RTM and SP1 in Exchange 2007 that is why there is this option with covertId to convert between the two different formats, but nobody be should be running 2007 RTM and if they are then they really really need help so it really pointless as a Test source. 

    Cheers
    Glen

    • Marked as answer by thq0813 Thursday, September 29, 2016 7:01 AM
    Thursday, September 29, 2016 2:55 AM