none
How do I enable the disclosure triangle next to files in Visual Studio 2013 Community Editon's Solution Explorer?

    Question

  • I installed vs 2013 community edition update 5 on a new computer yesterday (Windows 10) and can't enable the disclosure triangle next to the files in Solution Explorer.

    I have no triangles at all and I have to instead press F7 or right click the file, then click -view code- .

    Now most people I have seen on forums are asking how to shut it off, but I prefer it on.

    I tried the suggestion from this link by adding the DWORD = 1, but it won't work for me.

    Disable disclosure triangle next to files in Visual Studio Solution Explorer

    The odd thing is that I have also installed vs 2015 community edition and the disclose triangles are there!!

    I tried comparing the settings between 2013 and 2015 and simply can't find the difference.

    Thank you for any help you can provide!

    James


    James

    Monday, January 25, 2016 2:08 PM

Answers

  • Hello,

    Thanks for responding. Well, at least I am glad to see someone else having this issue. I did though forget to mention that at one point it was working and got the triangles, but something happened and they went away. I have the same VS 2013 Community Edition Update 5 on a different computer and that computer shows the triangles. You can even turn them on or off with link mentioned above. That being said, it is not a feature request. The only thing I haven't done is uninstall and reinstall VS 2013. There must be something corrupted somewhere. I think I will just take your advice and uninstall 2013 and just use 2015. I was using 2015 at one point, but it was buggy and kept crashing on me when I was debugging async code. I tried it again the other day and it wasn't crashing anymore. I now have update 1 for 2015. Maybe that fixed it.

    Thank you again.

    James


    James

    Tuesday, January 26, 2016 1:14 PM

All replies

  • Hi James,

    Thanks for your post.

    As far as I know, there is no related settings to set this function in Visual Studio.

    I just did a test in my side using both VS2013 and VS2015. And the result is same to yours.

    In VS2015:

    In VS2013:

    I also tested this function in VS2010. And the behavior is same to VS2013. 

    One idea is that you could use VS2015 Community instead of using VS2013 Community.

    Or if possible, I suggest you could submit a feature request to Visual Studio product team.

    http://visualstudio.uservoice.com/forums/121579-visual-studio

    The Visual Studio product team is listening to user voice there.

    Thanks for your understanding.

    Best Regards,

    Lake Xiao

    Tuesday, January 26, 2016 8:04 AM
    Moderator
  • Hello,

    Thanks for responding. Well, at least I am glad to see someone else having this issue. I did though forget to mention that at one point it was working and got the triangles, but something happened and they went away. I have the same VS 2013 Community Edition Update 5 on a different computer and that computer shows the triangles. You can even turn them on or off with link mentioned above. That being said, it is not a feature request. The only thing I haven't done is uninstall and reinstall VS 2013. There must be something corrupted somewhere. I think I will just take your advice and uninstall 2013 and just use 2015. I was using 2015 at one point, but it was buggy and kept crashing on me when I was debugging async code. I tried it again the other day and it wasn't crashing anymore. I now have update 1 for 2015. Maybe that fixed it.

    Thank you again.

    James


    James

    Tuesday, January 26, 2016 1:14 PM