locked
SSRS Hyperlink report with parameters not working properly RRS feed

  • Question

  • 1st Report:

    I have main report with 3 parameters and have 3 levels of drill downs. The last drill down is to register level and it shows a hyperlink when clicked on it, it should directly take user to register report.

    i.e If clicked  on 1st URL – 000018045 – Cert  in Childcare but it takes me to different one as below

    2nd Report:

    Everything works fine in my report except hyperlinked report which showing different values other than user selected in main report drill down list.

    I made sure I am using same parameters in both reports and identical datasets.

    Any idea where am I going wrong?


    • Edited by Aruna2015 Monday, February 15, 2016 11:04 AM
    Tuesday, February 9, 2016 2:38 PM

Answers

  • Hi Aruna2015,

    According to your description, you have created drill through action in the main report to open the target report, but the action doesn’t open the correct report, right?

    In your scenario, do you create the drillthrough action in the main report as a report action, or URL action? How do you pass the parameter values from the main report to target report? If you are creating a report action, you need to make sure passed parameters from the main report is available to filter the target report. If it’s a URL action, the resolved URL action needs to point to the correct report resides on report server. For more information, please refer to links below:

    Drillthrough Reports (Report Builder and SSRS)
    Add a Drillthrough Action on a Report (Report Builder and SSRS)

    Also please use DOM Explorer tool to check if the attributes of action are right. See: Diagnose and fix layout problems.

    If you have any question, please feel free to ask.

    Best regards,
    Qiuyun Yu


    Qiuyun Yu
    TechNet Community Support



    Thursday, February 11, 2016 8:00 AM