none
Framework 3.5 installation problem of Vista Ultimate RRS feed

  • Question

  • Hi All,

     I'm having a torid time trying to install Visual Studio 2008 on Vistal Ultimate. The issue is the installatin of Framework 3.5. Ive tried quite a few things but I end up with the same error: 
    "DepCheck indicates Optional Component 'Microsoft .Net Framework 3.0' is not installed."
    This is surprising considering that 3.0 is supposed to be part of Vista, and as such I can see it in the Windows\Microsoft.NET\Framework\3.0 directory. I've tried to install it separately using the dotNetFx35setup.exe package, same result. Looking at the generated log file - dd.dotnetfx35install.txt - is not very infrmative as far as I'm concerned. It containsconfusing entries, like:
    [12/27/08,17:47:38] InstallReturnValue: GFN_MID Optional Component 'Microsoft .Net Framework 3.0', 0x0
    [12/27/08,17:47:38] Optional Component 'Microsoft .Net Framework 3.0': Error code 0 for this component means "The operation completed successfully.
    which obviously doesn't mean what it says at least to DepCheck. I've cleaned the registry, made sure Vista SP1 is installed, reinstalled Windows installer 3.1, but nothing seems to help.
     If anyone has come across this kind of problem, I would really appreciate a hint or two how to overcome it. Honestly, my oppinion is that this kind of problem shuld have been sorted out by MS a while back. Neither Vista nor VS2008 are shining new anymore.
    Monday, January 5, 2009 3:12 AM

Answers

  • Hi Dezis,

    I found the following error in your Verification file logs.

    .Net Framework 2.0
    [01/10/09,23:28:10] File C:\Windows\Microsoft.NET\Framework\v1.1.4322\regsvcs.exe.config is not installed on the system
    [01/10/09,23:28:11] File C:\Windows\Microsoft.NET\Framework\v1.0.3705\installutil.exe.config is not installed on the system
    [01/10/09,23:28:11] File C:\Windows\Microsoft.NET\Framework\v1.0.3705\mscormmc.cfg is not installed on the system
    [01/10/09,23:28:12] Verification failed for product .NET Framework 2.0
    .Net Framework 3.0
    [01/10/09,23:20:26] Key: SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.0\Setup
    Value: InstallSuccess
    Expected Data: 1
    Actual Data: NOT FOUND
    [01/10/09,23:20:37] Verification failed for product .NET Framework 3.0

    These indicate that .Net Framework 2.0 and 3.0 are not well installed on your PC. Since .Net Framework 2.0 and 3.0 versions are installed as OS components on Windows Vista, you could try to repair the .NET Framework 2.0 and 3.0 according to the following useful blog:
    http://blogs.msdn.com/astebner/archive/2007/03/26/how-to-repair-the-net-framework-2-0-and-3-0-on-windows-vista.aspx
    Then you could install .Net Framework 3.5.

    Hope that helps.

    Thanks
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    • Marked as answer by YiChun Chen Thursday, January 15, 2009 2:44 AM
    Monday, January 12, 2009 3:30 AM

All replies

  • Hi Dezis,

    Net Framework 3.0 SP1 is applied if Vista SP1 is installed.

    Could you please try to help me to collect all the log files of .Net Framework 3.5 from your "%temp%" folder or use collect tool to collect the log files: http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx

    Then compress them into a zip file and post a link back?

    Steps:
    - Try to clean your "%temp%" folder
    - Install .Net Framework 3.5 separately
    - Collect all the latest log files or Collect Tool file logs from "%temp%" folder

    Thank you for your help.

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    • Edited by YiChun Chen Tuesday, January 6, 2009 9:25 AM
    Tuesday, January 6, 2009 6:13 AM
  • Hi YiChun,

     I've done the steps, got the zip file but I'm not sure how to get it back to you. Could you give me a hint?

     Many thanks

    Dezis

    Tuesday, January 6, 2009 9:22 AM
  • Hi Dezis,

    You could use use SkyDrive - Windows Live (http://skydrive.live.com/) to upload your zip file and post the link back.

    Thanks
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Tuesday, January 6, 2009 9:31 AM
  • Hi YiChun,


    I hope I got it wright.

    Tanks,
    Dezis.
    Wednesday, January 7, 2009 1:29 AM
  • Hi Dezis,

    I've read your log files, but I found no error code in it and just found the error you mentioned.

    [01/06/09,19:10:03] WapUI: ***ERRORLOG EVENT*** : DepCheck indicates Optional Component 'Microsoft .Net Framework 3.0' is not installed.

    Could you please help me to use Verification Tool mentioned in the following blogs to verify the .Net Framework on your PC?
    http://blogs.msdn.com/astebner/pages/8999004.aspx

    Thanks


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Wednesday, January 7, 2009 5:16 AM
  • Hi YiChun.

     I've run the tool twice once for 3.0 and once for 2.0. Both failed. The link to the log file is:

     Hope that helps.


    Thanks,
    Dezis
    Saturday, January 10, 2009 1:39 PM
  • Hi Dezis,

    I found the following error in your Verification file logs.

    .Net Framework 2.0
    [01/10/09,23:28:10] File C:\Windows\Microsoft.NET\Framework\v1.1.4322\regsvcs.exe.config is not installed on the system
    [01/10/09,23:28:11] File C:\Windows\Microsoft.NET\Framework\v1.0.3705\installutil.exe.config is not installed on the system
    [01/10/09,23:28:11] File C:\Windows\Microsoft.NET\Framework\v1.0.3705\mscormmc.cfg is not installed on the system
    [01/10/09,23:28:12] Verification failed for product .NET Framework 2.0
    .Net Framework 3.0
    [01/10/09,23:20:26] Key: SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.0\Setup
    Value: InstallSuccess
    Expected Data: 1
    Actual Data: NOT FOUND
    [01/10/09,23:20:37] Verification failed for product .NET Framework 3.0

    These indicate that .Net Framework 2.0 and 3.0 are not well installed on your PC. Since .Net Framework 2.0 and 3.0 versions are installed as OS components on Windows Vista, you could try to repair the .NET Framework 2.0 and 3.0 according to the following useful blog:
    http://blogs.msdn.com/astebner/archive/2007/03/26/how-to-repair-the-net-framework-2-0-and-3-0-on-windows-vista.aspx
    Then you could install .Net Framework 3.5.

    Hope that helps.

    Thanks
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    • Marked as answer by YiChun Chen Thursday, January 15, 2009 2:44 AM
    Monday, January 12, 2009 3:30 AM