locked
Wrong columns from content type in document library RRS feed

  • Question

  • I have several content types (derived from Document Set) assigned to a document library. After I did a small change to one of the content types, I deleted all content types and all columns from the (empty) library and re-assigned the modified content types. Now several of the library columns are wrong: Somehow the column links in the library settings page reference the wrong columns, something like column A points to column B (but with the name A), etc. Within the content type the column references are correct, also the site columns are correct.

    Emptying the recycle bins does not help, even deleting and re-creating the complete site collection does not help. The same wrong references re-appear. The document library is in a subite of the site collection.

    What can be the reason for this strange behavior?

    Saturday, January 17, 2015 9:56 PM

Answers

  • Hi,

    According to your post, my understanding is that you get wrong columns from content type in document library.

    To narrow down the issue, I recommend that you can create a new library which include Document Set content type to check whether it works.

    If it works correctly, you can create a new content type derived from Document Set and add it to the issued library.

    If it works correctly, the issue is caused by the changed content type.

    Then you can create a new library and new content type to achieve what you want.

    Best Regards,

    Linda Li


    Linda Li
    TechNet Community Support

    • Proposed as answer by Victoria Xia Tuesday, February 10, 2015 3:13 AM
    • Marked as answer by Rebecca Tu Wednesday, February 11, 2015 9:49 AM
    Monday, January 19, 2015 6:37 AM