none
WES7: Add Legacy Hardware - missing file RRS feed

  • Question

  • Hi,

    Could someone please tell me how to detect which file is missing when trying to add legacy hardware on a custom built (no template used) Windows Embedded Standard 7 machine.

    I have tried to install different legacy drivers but all came out with the same error:

    "The following hardware was not installed: xxxx

    An error occurred during the installation of the device

    Cannot find the file specified."

    I have tried the same on a Windows Embedded Standard 7 machine where the image was installed using the Application Compatibility template and then removing some features to fit the 4 GB disk. This time the legacy driver was installed correct.

    It seems that I might be missing some driver package in the custom built WES7 image.

    BR,

    Morten

    Tuesday, March 31, 2015 11:23 AM

All replies

  • First look at the system where the device was installed successfully which driver (sys/inf) files have been installed for that. This can be seen in the "Driver" tab in the device's properties when you click on "Driver Details". The corresponding INF file can be determined via the "Details" tab of the device's properties (walk through the property nodes and look for values containing INF files).

    Once you got the file names you can use ICE to search the corresponding component that contains a file file that name.

    Tuesday, March 31, 2015 2:09 PM
  • Compare two answer file via "answer file diff", you will see the missing component. But it seems not to download from MS website now.

    Answer file diff

    Tuesday, March 31, 2015 2:40 PM
  • Thank you for your input.

    I think the answer file based on the Application Compatibilty template have more than one different component as the faulty answer file is pretty much stripped of any unnecessary components/features. But I will definitely give it a try when I get the opportunity again using some filedif tool.

    Friday, April 10, 2015 8:15 AM
  • Thanks!

    At the system where the device was installed successfully, I can see in the properties, that the driver uses an oem5.inf file, which the system seems to have created when installing the driver. The original inf-filename is not present in the properties.

    On the faulty system the setupdev.log file in windows\inf folder shows: Installing NULL driver! and later it shows a FAILURE. But what this means , I do not know.

    Friday, April 10, 2015 8:28 AM
  • Can you give more details about the device from the system where it has been installed successfully?

    • Name of device shown in Device Manager
    • Hardware IDs
    • Type of device (Ports, Disk Drive,...)

    Friday, April 10, 2015 8:56 AM