locked
Error in navigation after restore of databases RRS feed

  • Question

  • Hi All,
        Im having a MOSS 2007 test server . Also we are having a production server with MOSS 2007.
    I tried to test whether the backup and retore for the production server works fine or not...
    I took the backup from the SQL server (2008) from the production server .
    I restored it in the sql server of test server and created the site using that database.
    At first it throwed for error then i installed all the custom web parts and the site got opened...
    But in the site of the production server we had several tabs.. Those are not displayed now in the test server...  An error is Displaying in that area... But i could see those sites through clicking on view all site content and getting it from there...
    What may be the problem here. All are fine other than this...
    NO quick link is displayed only view all site content and Recycle bin are displayed for others an error tab is displayed..
    What to do for this...

    Thanks in Advance...

    Regards,
    Siva..
    Thursday, December 31, 2009 10:09 AM

All replies

  • Hi Siva,

    Could you please elaborate on this -

    ---
    But in the site of the production server we had several tabs.. Those are not displayed now in the test server...  An error is Displaying in that area... But i could see those sites through clicking on view all site content and getting it from there...
    ---

    If you can see the sites on view all site content, but there is an error on the top tab that would mean structural issues  - what is the error message being displayed?

    Cheers

    Geoff
    Sunday, January 3, 2010 10:22 AM
  • I'd be interesting if you elaborate how exactly you did "I took the backup from the SQL server (2008) from the production server ." 
    the issue can lie beneath. Did you use Farm Backup or only SQL content DB backup?! did you move only content DB or all SQL instance?! Did you update the name of the SQL server in the Central Administration if you moved the DB instance?! 

    SharePoint 2007 -2010 Tips & Tricks Portal | Microsoft MVP | My Blog about Information Management | My twitter
    Sunday, January 3, 2010 9:50 PM
  • Hi,
      Thanks for your interest in my issue...
    Actually i didnt backup the farm.. I took backup of the content database of the particular site and restored it in my test server by creating a new database with the same name and then restored the backup of the database.
    I created a new site in my test server with the restored database.
    I installed all the custom web parts and opened the site..
    The site is opening but the navigation is not displayed an error is displaying there.
    Also there is nothing in quick launch an error button is displayed there.
    But when i click the view all site content it is displaying the tree view of all the sites..

    When i hover the error button an error message is displayed it is...

    "An error occured while rendering navigation for requested URL/ Exception message: Updates are currently disllowed on GET requests. To allowupdates on a GET set the AllowUnsafeUpdates property onSPWeb.Stacktrace: at MIcrosoft.Sharepoint.Library.SetWebMetainfo(String bstrUrl,Object varMetainfo) at Microsoft.Sharepoint.publishing.publishingWeb.<>_DisplayClass2d.<CleanupInternalIDS)"......And it goes long telling lot of things like the above.... telling lot of things in navigation.

    Can u suggest me with the above error or should i provide the full error message..

    Thanks in Advance..
    Regards,
    Siva.

    Monday, January 4, 2010 5:21 AM
  • Hi Siva,

    See this before I had errors like this with picture libraries and when running in SSL and basic authentication, or there was a change to the web.config to enable blobcaching - also, it could be that the site is not structurally complete.

    Things to try:
    1: Enable and disable Publishing Infrastructure Site Collection feature
    2: Access the environment using Windows Integrated security
    3: Use basic authentication and disable the blobcache

    Hope this helps

    Geoff

    Monday, January 4, 2010 10:30 AM
  • Hi Geoff,
       Thanks for your response..
    I tried disable and enable publishing site collection feature..
    As im little new to moss i couldnt get the 2nd and 3rd points...
    For accessing using windows integrated security and disable blobcache what should i do..?

    Thanks In Advance..
    Regards,
    Siva...
    Monday, January 4, 2010 11:07 AM
  • Hi ,

       As per the information from rest of the members i would like to ask few things.plz calrify

      1) Did you used any Custom styles to get those Tabs on your home masterpage.
      2)which version of IE currently your using.Check with Compatibility view
      
    3) check did you replaced any content place holders in masterpage.

      
     
      

     
    Monday, January 4, 2010 11:18 AM
  • Hi Nivas,
         No we didnt used any custom styles for those tabs.
    IE 6 is using in both production as well as in test server. I tested the site with opening with different browsers but the error is same..
    No we didnt change any content place holders in masterpage..

    but once we changed the subsites number to 3.. i.e by default only two levels of subsite is displayed i changed it using sharepoint designer and edited the value... Should it be done here also ah..?

    Thanks in Advance..
    Regards,
    Siva..
    Monday, January 4, 2010 11:30 AM
  • Hi Siva,

    Without starting to get off topic  :))

    Firstly, When you disabled and then enabled the publishing site collection feature on the site in question did you still see the errors on the site?

    As for blobcaching and Windows Integrated Security:
    When a SharePoint is application is created, a web.config file is created in the application folder you specified. One of the entries inside the SharePoint element is BlobCache. By default, it looks like this:
    <BlobCache location="C:blobCache" path=".(gif|jpg|png|css|js)$" maxSize="10" enabled="false" />

    In order to improve the performance of your site, the BlobCache might be enabled.
    <BlobCache location="C:blobCache" path=".(gif|jpg|png|css|js)$" maxSize="10" enabled="true" />

    To disable it:
    set enabled="true" to enabled = "false"

    As for Windows Integrated Security, there's a bit to do here, and its best you see the general article on it:
    http://office.microsoft.com/en-us/winsharepointadmin/HA011608071033.aspx

    Hope this helps

    Cheers

    Geoff
    Monday, January 4, 2010 11:47 AM
  • Hi Geoff,
       Thanks for your detailed reply..
    I tired to disable and enable the publishing feature but the error button is still there.

    As for blobcaching i checked it and found that it is disabled ..
    the enabled  value is false. enabled="false"

    Also i tried with the windows integrated security followed those steps.. This also end up with the same state..

    Any other option to make it work....?

    Thanks in advance..
    Regards,
    Siva...

    Monday, January 4, 2010 2:05 PM
  • Hi Siva,

    Ok, then something maybe got an issue from your backup and restore method - time to try a proper stsadm backup and restore.

    Are you able to run a stsadm -o backup on the old site, then restore it into a new site collection on the new site?

    Summary.
    1: Go onto the old sites server
    2: Run stsadm -o backup -url http://yoursharepointsite -filename yoursharepointsite.spb
    3: Copy that file to the new server
    4: Log onto the new server
    5: Create a new web application, with one blank site in it - ensure you can access the new site
    6: Restore the yoursharepointsite.spb into it: stsadm -o restore -url http://yournewsharepointsite -filename yoursharepointsite.spb

    Cheers

    Geoff


    Monday, January 4, 2010 2:31 PM
  • Hi Geoff,
       I folowed the steps provided by you.
    Took backup using stsadm command and then restored by creating a new site in my test server.
    But the same error comes here also..
    The site will get open but in the tab i.e navigation area there will be a error button when clicking on it no response.
    When hover that button it will prompt for the error message which i already posted..
    So the problem is with the site and not with the backup and restore process.
    But incase of the production server the site is getting open with all the tabs...

    So where may be the problem..


    Thanks in Advance,
    Regards,
    Siva....
    Wednesday, January 6, 2010 12:54 PM