locked
Access is denied when try to record any application in Coded UI test RRS feed

  • Question

  • Hi,

    I tried to record the application and got the following error in Coded UI Test Builder. And it generated the following codes. Please let me know if there are any possible solution for this issue.

    public partial class AdminUIMap
        {
           
            /// <summary>
            /// RecordedMethod1
            /// </summary>
            public void RecordedMethod1()
            {

                // Access is denied.

                // The following element is no longer available: IE web control; Process Id [5256], window handle [133182]

                // The following element is no longer available: IE web control; Process Id [5256], window handle [133182]

                // Access is denied.

                // Access is denied.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The control is not available or not valid.

                // The following element is no longer available: IE web control; Process Id [5256], window handle [133182]

                // The last action was not recorded because access to the application was denied.
            }
        }

     


    Thanks, Manikandan
    Monday, June 13, 2011 10:00 PM

Answers

  • Are you running IE or Visual Studio as Administrator?

    These messages generally appear when one of the processes is running as Admin and the other is not.

    If you have to record on an application running as Admin, you need to be running Visual Studio also as admin.

    Tuesday, June 14, 2011 5:14 PM
    Moderator

All replies

  • Are you running IE or Visual Studio as Administrator?

    These messages generally appear when one of the processes is running as Admin and the other is not.

    If you have to record on an application running as Admin, you need to be running Visual Studio also as admin.

    Tuesday, June 14, 2011 5:14 PM
    Moderator
  • I am recording the application as user and running Visual studio as user. I have formatted my machine and the issue got resolved. I dont know why I had this issue.

     

    Thanks

    Manikandan


    Thanks, Manikandan
    Monday, June 20, 2011 9:00 PM
  • Hi,

    I am facing this very same issue currently and formatting the machine is not an option :(.

    Please let me know any other solution for this issue. 

    Thanks,

    Someswara S

    Monday, October 22, 2012 11:04 AM