none
[UWP] Submission failed with error code 1300 and no .appxsym file inside .appxupload package

    Question

  • For some reason when I've created new .appxupload package of my UWP app for Store submission in in VS2015 Update 2 RTM the package doesn't contain debug symbols file .appxsym.

    Also when I've tried to submit such .appxupload packages (for x86, x64 and ARM platforms) to the Store, submission failed with the following error:

    The submission failed with error code(s) 1300. More info about the error(s) can be found here.

    The following is a short quote from the "here" link above:

    UWP apps

    If you are submitting a UWP app, you may see an error during preprocessing if your package file is not an .appxupload file generated by Visual Studio for the Store. Be sure that you follow the steps in Packaging Universal Windows apps for Windows 10 when creating your app's package file, and only upload the .appxupload file on the Packages page of the submission, not an appx or .appxbundle.

    And a bit more from the same "here" link:

    Another error that you might see after submitting your app is error 1300. This occurs when one or more assemblies (or the entire package) is already precompiled. To fix this issue, rebuild the app's package in Microsoft Visual Studio and then submit the newly-generated package.

    I've tried clean/rebuild/resubmit 3+ times already, so the error is persistent.

    The thing is code changes from previous app version are rather minor (this is mostly bug fix release), so I have no idea what could be wrong with submission this time.

    Now I'm kind of blocked by this issue and can't update the app.

    If that matter - the last app submission packages were created in VS2015 Update 1 and all of them contains .appxsym file (apart from regular .appx file). And this app version is live in the Store for quite a while already. So this is the only reason I thought that may be absence of .appxsym file in the new packages could be the cause of the error 1300 during submission to the Store.

    Does anyone have any clue?


    Tuesday, May 31, 2016 11:15 AM

All replies

  • Hello Ekateryna,

    I will help you move this thread to publish forum so you can get more proper response.


    Thanks MSDN Community Support Please remember to Mark as Answer the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Wednesday, June 01, 2016 5:59 AM
  • Thanks, Krunal.
    Wednesday, June 01, 2016 7:47 AM
  • Last week we resubmitted same code, but new packages were generated in Visual Studio 2015 Update 1 and during the last week submission was in still in "pre-processing" state. Usually (based on previous submissions) it took only a few hours for "pre-processing" and then it changed to "Certification" state where it could be up to 3 days. So yesterday we canceled this submission and now I don't know how to update the app - it either stuck or return 1300 error depending how we build the packages.

    Any help?

    Thursday, June 09, 2016 7:37 AM
  • Hi

    Was there any resolution for this issue? I'm experiencing similar error 1300 issue without having been able to find fix for the issues. Clearly rebuilding the package does not fix the issue...TT

    Tuesday, June 28, 2016 3:36 PM
  • I have this issue, too. Looks like it appeared after installing Update 3
    Tuesday, June 28, 2016 4:11 PM
  • same here :/

    Microsoft Certified Solutions Developer - Windows Store Apps Using C#

    Tuesday, June 28, 2016 5:14 PM
  • I have exactly the same issue, i never had before. I tried many things i found on the web but Nothing is working. Anyone from MS to help us ?
    Tuesday, June 28, 2016 8:41 PM
  • Visual studio 2015 update 3 same error during the submission
    Tuesday, June 28, 2016 10:52 PM
  • I have the exact same problem.
    Wednesday, June 29, 2016 7:19 AM
  • Same here. This is a critical problem, can we expect a statement from Microsoft please?
    Wednesday, June 29, 2016 9:49 AM
  • Same here!!! error 1300 with Visual studio 2015 update 3 on one machine and Visual studio 2015 update 2 on another.  Both do not work!!
    Wednesday, June 29, 2016 5:34 PM
  • check out this, this should be the reason: https://social.msdn.microsoft.com/Forums/en-US/e766a904-7346-4f76-bad2-852d3b301b0e/known-issue-version-52-of-microsoftnetcoreuniversalwindowsplatform-delisted-all?forum=Win10SDKToolsIssues

    Microsoft Certified Solutions Developer - Windows Store Apps Using C#

    Wednesday, June 29, 2016 6:38 PM
  • When can we expect this to be fixed? I am not able to use the recently released Entity Framework 7 without the 5.2.0 version of this package.
    Wednesday, June 29, 2016 7:02 PM
  • same problem here... :(

    Microsoft Certified Solutions Developer - Windows Store Apps Using C#

    Wednesday, June 29, 2016 7:08 PM
  • update: https://social.msdn.microsoft.com/Forums/en-US/796bc9b5-b967-431b-85a7-714d385d4290/known-issue-store-submission-fails-with-error-code-1300-all?forum=Win10SDKToolsIssues

    Microsoft Certified Solutions Developer - Windows Store Apps Using C#

    Wednesday, June 29, 2016 7:25 PM
  • I can confirm that downgrading the nugget package “Microsoft.NETCore.UniversalWindowsPlatform” from 5.2 to 5.1 fixed the issue for me.

     

    • Proposed as answer by KonstantinUrZ Monday, July 04, 2016 2:40 PM
    Wednesday, June 29, 2016 8:31 PM
  • I also confirm, the downgrade fixed the issue.
    Wednesday, June 29, 2016 8:36 PM
  • Same here, after update 3 and trying to submit application update, now it is fails with 1300. More is that even if I rebuild in Update 2, delete submission, and start it again, I will get this error. It is very sad because the planned release date has passed :(, and we can't do anything about that.

    Update. "I can confirm that downgrading the nugget package “Microsoft.NETCore.UniversalWindowsPlatform” from 5.2 to 5.1 fixed the issue for me." 

    Also confirm this. Downgrade works.


    Monday, July 04, 2016 2:40 PM