none
Unable to use selected certificate to sign the package! RRS feed

  • Question

  • Hello,

    i`m trying to sign my result in HCK with x.509 certificate but i`m getting error message. Please for help!

    What should we do?!?!

    Regards!!!

    Monday, December 10, 2012 8:56 AM

Answers

All replies

  • Can you share more information in the Windows Event Viewer as to the error (exception)?


    John -- This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, December 10, 2012 9:41 AM
  • Log Name:      HCK - Hardware Certification Kit
    Source:        Studio UI
    Date:          12/10/2012 9:49:20 AM
    Event ID:      0
    Task Category: None
    Level:         Information
    Keywords:      Classic
    User:          N/A
    Computer:      WIN-KI32NIKJQKF
    Description:
    Could not create submission package - Signing key is not loaded.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Studio UI" />
        <EventID Qualifiers="0">0</EventID>
        <Level>4</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2012-12-10T08:49:20.000000000Z" />
        <EventRecordID>292</EventRecordID>
        <Channel>HCK - Hardware Certification Kit</Channel>
        <Computer>WIN-KI32NIKJQKF</Computer>
        <Security />
      </System>
      <EventData>
        <Data>Could not create submission package - Signing key is not loaded.</Data>
      </EventData>
    </Event>

    Bojan Antic

    Monday, December 10, 2012 9:47 AM
  • Is it a code signing certificate?
    Looks like it is not.

    Or while installation of the certificate you might have chosen wrong key export option.
    • Edited by Nilesh90 Monday, December 10, 2012 10:40 AM
    Monday, December 10, 2012 10:38 AM
  • Yes it is, you can see picture on first post.

    Bojan Antic

    Monday, December 10, 2012 10:48 AM
  • Ohh! Yes it is.

    However, if you select "ask for password when certificate key is used" [something like that], while installation of the certificate, can cause such problem, because studio GUI will ask for the password if it supports that functionality otherwise it must end up with error.

    Try using third option ("Use a certificate file") if you have the certificate file, it may give you an idea what is going wrong. 

    Monday, December 10, 2012 11:02 AM
  • Certificate is isntalled without any password.

    In HCK Step-By-Step guide signs that i need x.509 certificate, and that is what i gave to him, i do`nt know what can be wrong!?!

    Third option could maybe pass, but it reqiures files with *.cer and *.pfx extension. I tried with conversion my *.crt to other two but without success.


    Bojan Antic

    Monday, December 10, 2012 11:24 AM
  • I tried with third option, with *.cer file extension, also same mistake. Left *.pfx option.

    Bojan Antic

    Monday, December 10, 2012 11:45 AM
  • Okay.

    I do not understand what is wrong.

    I hope MSFT people can help you.

    I would be eager to know the solution.

    Monday, December 10, 2012 12:32 PM
  • Hi Telix1,

    If you still can not properlyuse the Signing use the certificate store,please refer to here.

    http://social.msdn.microsoft.com/Forums/zh-TW/1295/thread/691e712d-d654-4f2b-a756-3043af151c0d

    Thanks, Steve

    Monday, December 10, 2012 2:48 PM
  • It sounds like you tried this but does the thread http://social.msdn.microsoft.com/Forums/en-US/whck/thread/9aedb5b3-498b-451c-adc5-69e260050163 and it's follow-up thread http://social.msdn.microsoft.com/Forums/en-US/wdk/thread/511f8fb7-966a-49d8-88c7-9f73ffe7ac5a offer any additional help. Those threads appear to address similar issues.

    John -- This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, December 10, 2012 4:30 PM
  • Problem solved, thanks everyone. Here is detailed explanation:

    1. You must use same PC and web browser when you reissued certificate (most usable information :) ).

    2. After you get certificate (x.509 with *.crt extension), import him into Internet Explorer from certmgr or IE. From same PC and web browser export to PFX with private key.

    3. Install that exported certificate on same way.

    4. In HCK you can use second option with Certificate Store and submission will be signed (my submission passed).

    Note. Everything you must do from same PC and same web browser (IE).

    Many regards from Novi Sad, Serbia :)


    Bojan Antic

    Tuesday, December 11, 2012 12:57 PM