none
Trying to install SQL Sever Express, SQL Server Mgmt Studio RRS feed

  • Question

  • Your post Subject: Trying to install SQL Sever Express, SQL Server Mgmt Studio so I can access my SQL Server posted on 12/29/2016 3:35:57 PM in forum Upgrading DNN Platform has  been approved.

    Hello: I have been trying to download and install either SQL Server Express 2012 or Sql Server Management Studio 2012 so I can access my remote SQL Server 2012 tables in my Dot Net Nuke website. I am using Windows 7 OS, X86.  I have installed and verified that ALL of the following versions of the Dot Net Framework are 

    installed and verified:

    .NET Framework 2.0

    .NET Framework 3.5

    .NET Framework 4.0

    .NET Framework 4.5

    .NET Framework 4.5.1

    .NET Framework 4.5.2

    Each and every time I attempt to install either SQL Server Express 2012 or Sql Server Management Studio 2012 I get an error message that 

    "You must install either .NET Framework 2.0 or .NET Framework 4.0 to install SQL Server Express 2012"

    I have done this many times, I have installed and uninstalled all of these, trying different orders and different sequences starting with 2.0 by itself, then adding the others. Same error. I have looked online and I can see that many others have had similar problems, sometimes a registry hack was suggested. However, I was wondering if anyone had a suggestion that works.

    Thanks,

    Robert


    • Edited by RFolden2 Sunday, January 8, 2017 4:35 PM
    Sunday, January 8, 2017 3:40 AM

All replies

  • Please note that DotNetNuke is a different thing than .NET framework.

    Please install x86 version of .NET framework v4 runtime instead.


    • Edited by cheong00Editor Sunday, January 8, 2017 11:29 AM
    • Proposed as answer by Kristin Xie Tuesday, January 10, 2017 2:11 AM
    Sunday, January 8, 2017 11:29 AM
    Answerer
  • Hi Robert,

    Please click here to download the official .Net framework.

    Best regards,

    Kristin


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Proposed as answer by Kristin Xie Tuesday, January 10, 2017 2:11 AM
    Monday, January 9, 2017 2:33 AM
  • Hi Robert,

    Any updates now?


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, January 26, 2017 3:01 AM
    Moderator
  • Hi Robert,

    Please verify that the .NET framework version is the full version and not the client version.  The link provided by Kristin Xie is useful.

    Tuesday, February 28, 2017 5:37 PM