none
I can't insert pictures from my local site in EW3. RRS feed

  • Question

  • When I try to insert a picture from my local site in EW3 it sends me to a picture folder on my C drive. How do I get to the picture files on the site? I used to have FP 2002 and that gave a browse option that would let me go to different places. There are options offered on EW3, like an EW3 icon, but clicking that gives, "there are no items listed." The other icons don't help.     Thanks, ericqb
    ericqb
    Thursday, April 21, 2011 12:54 AM

Answers

  • EW is not FrontPage. You would be best served by simply presuming that nothing that you knew from FP is of any value when working with EW. Seriously.

    Create an /images folder in your site root folder. Either use Import to import your images to that folder before trying to insert them, or use Explorer to move them there, then Refresh the Folder List so that EW recognizes the added files.

    Cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.
    • Marked as answer by ericqb Saturday, April 23, 2011 9:16 AM
    Thursday, April 21, 2011 1:23 AM
  • I assume you have tried the standard method to insert images, as per this procedure?

    To open the images folder within your site, you of course need the site open to begin with, or else just browse back to the correct folder.

    I tried this a couple of times, and the "browse" or "open file" window seems to default to the last-opened folder e.g. if you have Site 1 open and you insert an image save the page, close the site and then open site 2, open a page and insert an image, the 'browse' window will then apparenlty open the last opened folder i.e. site1/images rather than site2/images as you might expect.

     


    Andrew M


    http://www.murraywebs.com

    "Nothing spoils numbers faster than arithmetic!"
    -- Peppermint Patty (Peanuts, Charles M. Schulz)
    • Marked as answer by ericqb Saturday, April 23, 2011 9:16 AM
    Thursday, April 21, 2011 9:31 AM

All replies

  • Click the dropdown arrow next to the folder name.

    Or click one of the "Look in" options on the left.

    Or navigatge using the "up one folder" icon.


    (I have no idea what you mean by the "EW3 icon".)

    Of course, the easiest way to insert an image into a page, where the image is already in your site, is just to locate the image in the Folder List pane, and drag it onto your page.


    • Marked as answer by ericqb Saturday, April 23, 2011 9:16 AM
    • Unmarked as answer by ericqb Saturday, April 23, 2011 10:14 AM
    Thursday, April 21, 2011 1:22 AM
  • EW is not FrontPage. You would be best served by simply presuming that nothing that you knew from FP is of any value when working with EW. Seriously.

    Create an /images folder in your site root folder. Either use Import to import your images to that folder before trying to insert them, or use Explorer to move them there, then Refresh the Folder List so that EW recognizes the added files.

    Cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.
    • Marked as answer by ericqb Saturday, April 23, 2011 9:16 AM
    Thursday, April 21, 2011 1:23 AM
  • I assume you have tried the standard method to insert images, as per this procedure?

    To open the images folder within your site, you of course need the site open to begin with, or else just browse back to the correct folder.

    I tried this a couple of times, and the "browse" or "open file" window seems to default to the last-opened folder e.g. if you have Site 1 open and you insert an image save the page, close the site and then open site 2, open a page and insert an image, the 'browse' window will then apparenlty open the last opened folder i.e. site1/images rather than site2/images as you might expect.

     


    Andrew M


    http://www.murraywebs.com

    "Nothing spoils numbers faster than arithmetic!"
    -- Peppermint Patty (Peanuts, Charles M. Schulz)
    • Marked as answer by ericqb Saturday, April 23, 2011 9:16 AM
    Thursday, April 21, 2011 9:31 AM
  • The regular procedure for inserting an image opens a folder with images I went to before, as you say EW3 tends to do. My question is how do I get it to go to the images on my live site. I can't get it to list my live site image files (as F.P. did) or direct it to my local site where I store images. There seems to be no browse option. I will work on the other processes recommended above, but I am still curious as to whether there is no way to get to the image insertion process to go to either of those places, my live site or my local site. Among the options is "Libraries", but that doesn't give me anything......Paladyn says before trying to insert an image make a folder for images but I don't see what makes this folder the one "insert images" will go to.
    ericqb
    Saturday, April 23, 2011 9:31 AM
  • Thank you for responding. The dropdown arrow next to the folder name gives "month, day, rating, tag." The options, icons, on the left yield nothing.  By EW3 icon, one of the icons on the left, I mean the green box with a W that identifies Expresson Web under all programs and elsewhere. When I click it  I get "no items listed." ....... I don't see an "up one folder" arrow or icon like Front Page had.  ....By "folder list pane", do you mean the list given when you click "site view" tab? If so I am unable to drag an image file to a page file.

    Thank you for your attention to my situation, but none of these expectable options seem to me working.

     


    ericqb
    Saturday, April 23, 2011 10:39 AM

  • Thank you for the reply. Does "site root folder" refer to my local or live site? Sorry for ignorance. Thanks. I woulod like to try what you're recommending.

    Once I create this folder, how is it that this folder is the designated one that "insert image" goes to? Shouldn't I at least be able to insert images from a folder in either my local or remote EW site, even if it means I have to reimport these images to get EW to recognize them (they were first put there by FP)? So there should be some browse function, right? I can't get the "insert image" function to go anywhere but this one image folder on my C drive. I can't get it to look at the folders in my live or local site. So after creating this folder, if EW (or Windows 7) continues to do what it is doing now, I'll still be stymied.  


    ericqb
    Saturday, April 23, 2011 11:02 AM
  • The regular procedure for inserting an image opens a folder with images I went to before, as you say EW3 tends to do. My question is how do I get it to go to the images on my live site. I can't get it to list my live site image files (as F.P. did) or direct it to my local site where I store images. There seems to be no browse option. I will work on the other processes recommended above, but I am still curious as to whether there is no way to get to the image insertion process to go to either of those places, my live site or my local site. Among the options is "Libraries", but that doesn't give me anything......Paladyn says before trying to insert an image make a folder for images but I don't see what makes this folder the one "insert images" will go to.

    ericqb
    Saturday, April 23, 2011 11:28 AM
  • Thank you for the reply. Does "site root folder" refer to my local or live site? Sorry for ignorance. Thanks. I woulod like to try what you're recommending.

    Once I create this folder, how is it that this folder is the designated one that "insert image" goes to? Shouldn't I at least be able to insert images from a folder in either my local or remote EW site, even if it means I have to reimport these images to get EW to recognize them (they were first put there by FP)? So there should be some browse function, right? I can't get the "insert image" function to go anywhere but this one image folder on my C drive. I can't get it to look at the folders in my live or local site. So after creating this folder, if EW (or Windows 7) continues to do what it is doing now, I'll still be stymied.  



    ericqb
    Saturday, April 23, 2011 11:31 AM
  • Site root folder in this context refers to the local folder that is the root of your website as defined in Expression Web. That's where you index.html fle lives. For example on my computer that would be D:/www/site (by default Expression Web uses something like C:/users/username/My Documents/My Web Sites/site but I don't recommend keeping your local sites in your user directory.)

    Site root folder on your hosted site it the folder that contains the index.html file that it sends when a browser types in just your site name. Typically when you log into your hosting account via ftp would be something like wwwroot or public_htm or http_docs  depending on your hosting configuration.


    Free Expression Web Tutorials
    For an Expression Web forum with without the posting issues try expressionwebforum.com
    Saturday, April 23, 2011 2:54 PM