locked
Getting error in MSBuilds (I've deleted old workspaces) RRS feed

  • Question

  • Summary

    Other Errors and Warnings

     1 error(s), 1 warning(s)

    Exception Message: Multiple identities found matching 'Shikha'. Please specify one of the following identities:- Shikha (STFS\Shikhas)- Shikha (STFS\Shikha)- Shikha (PTFS\Shikha) (type MultipleIdentitiesFoundException)Exception Stack Trace:    at System.Activities.Statements.Throw.Execute(CodeActivityContext context)   at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)   at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

    TF270003: Failed to copy. Ensure the source directory D:\Project\Live\UnitTestProject3\AboutUsTest\bin exists and that you have the appropriate permissions.



    • Edited by Devsoft1 Friday, May 17, 2013 8:51 AM
    • Moved by Ego Jiang Monday, May 20, 2013 7:53 AM
    Friday, May 17, 2013 8:50 AM

Answers

  • Hi Devsoft,

    Thanks for your post.

    What’s the version of your TFS and VS?

    What’s the “deleted old workspaces” mean?

    Please check the Workspace setting in your build definition. And check this directory D:\Project\Live\UnitTestProject2\AboutUsTest\bin exists.

    Additionally, please share the detailed TFS build log here.


    John Qiao [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, May 20, 2013 7:58 AM
    Moderator
  • Hi Devsoft, 

    Thanks for your reply.

    Your build definition using the default build process template?

    Which account is your TFS Build Service account? Please ensure this D:\\bin exists on your build machine and your TFS Build Service account has required permissions on it.

    And please refer to the answer reply in this post: http://social.msdn.microsoft.com/Forums/en-US/tfssetup/thread/e86b9d78-7bd3-425b-80d3-b9db449b2174.


    John Qiao [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Devsoft1 Thursday, May 30, 2013 6:08 AM
    Friday, May 24, 2013 8:03 AM
    Moderator
  • Hi Devsoft, 

    Thanks for your reply.

    In Build Definition>>Source Setting tab, set your solution server path folder($/xxx/solutionName) as the Source Control Folder, then set the $(SourceDir) as Build Agent Folder.  


    John Qiao [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Devsoft1 Thursday, May 30, 2013 6:07 AM
    Monday, May 27, 2013 9:47 AM
    Moderator
  • Hi Devsoft, 

    Thanks for your reply.

    Default value in Working Directory is $(SystemDrive)\Builds\$(BuildAgentId)\$(BuildDefinitionPath) 

      


    John Qiao [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Devsoft1 Thursday, May 30, 2013 6:07 AM
    Monday, May 27, 2013 10:19 AM
    Moderator

All replies

  • Hi,

    From your post, it seems an issue about TFS build. I am moving this case to TFS forum for further support.

    Best regards,


    Ego [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, May 20, 2013 7:53 AM
  • Hi Devsoft,

    Thanks for your post.

    What’s the version of your TFS and VS?

    What’s the “deleted old workspaces” mean?

    Please check the Workspace setting in your build definition. And check this directory D:\Project\Live\UnitTestProject2\AboutUsTest\bin exists.

    Additionally, please share the detailed TFS build log here.


    John Qiao [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, May 20, 2013 7:58 AM
    Moderator
  • I'm Working with tfs2012 and vs2012

    Now, i'm getting error:

    Other Errors and Warnings

     1 error(s), 2 warning(s)
     Exception Message: Illegal characters in path. (type ArgumentException)
    Exception Stack Trace:    at System.Activities.Statements.Throw.Execute(CodeActivityContext context)
       at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)
       at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

     
    Failed to copy. Ensure the source directory D:\\bin exists and that you have the appropriate permissions.

    What to do for path?

    Friday, May 24, 2013 7:34 AM
  • Hi Devsoft, 

    Thanks for your reply.

    Your build definition using the default build process template?

    Which account is your TFS Build Service account? Please ensure this D:\\bin exists on your build machine and your TFS Build Service account has required permissions on it.

    And please refer to the answer reply in this post: http://social.msdn.microsoft.com/Forums/en-US/tfssetup/thread/e86b9d78-7bd3-425b-80d3-b9db449b2174.


    John Qiao [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Devsoft1 Thursday, May 30, 2013 6:08 AM
    Friday, May 24, 2013 8:03 AM
    Moderator
  • Yes, i'm using the default build process template in the build definition.

    I am using mydomain/tfsservice as the account name. 

    What path to give in "Build Agent Folder" in workspaces, and, also, in "working directory" for build agent properties.  

    Monday, May 27, 2013 9:31 AM
  • Hi Devsoft, 

    Thanks for your reply.

    In Build Definition>>Source Setting tab, set your solution server path folder($/xxx/solutionName) as the Source Control Folder, then set the $(SourceDir) as Build Agent Folder.  


    John Qiao [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Devsoft1 Thursday, May 30, 2013 6:07 AM
    Monday, May 27, 2013 9:47 AM
    Moderator
  • Hi John,

    Thanks for your quick reply. Can you tell me what to put  in "Working Directory" for build agent properties window of Manage Build Controllers.  

    • Marked as answer by Devsoft1 Thursday, May 30, 2013 6:07 AM
    • Unmarked as answer by Devsoft1 Thursday, May 30, 2013 6:07 AM
    Monday, May 27, 2013 10:10 AM
  • Hi Devsoft, 

    Thanks for your reply.

    Default value in Working Directory is $(SystemDrive)\Builds\$(BuildAgentId)\$(BuildDefinitionPath) 

      


    John Qiao [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Devsoft1 Thursday, May 30, 2013 6:07 AM
    Monday, May 27, 2013 10:19 AM
    Moderator
  • Hi John,

    I'm getting this error:

    C:\Windows\system32\$(System Drive)\3\Default Agent - LN12T\45\MyProject\AboutUsTest1\src\.nuget
    uget.exe: Access to the path 'C:\Windows\system32\$(System Drive)\3\Default Agent - LN12T\45\MyProject\AboutUsTest1\src\.nuget' is denied.

    How to resolve it?

    Also, please tell me do I need to configure agent for running builds on local PC?
    • Edited by Devsoft1 Wednesday, May 29, 2013 9:43 AM
    Wednesday, May 29, 2013 9:17 AM
  • Getting assembly errors like mentioned below, don't know why after all the references are there in the solution.

    ERROR: CacheUtility.cs (13): The type or namespace name 'DataCacheFactory' could not be found (are you missing a using directive or an assembly reference?)

     
    Thursday, May 30, 2013 12:53 PM