Client FTP Error Code 12029


  • Hi,

    Following code is written in Visual Studio 2005 C++ for PDA(MC3000).
    PDA is Motorola/Symbol's MC3000 and it has Windows CE 5.0 Operating System.

    FTP Error Code 12029 meaning "Internet can not connect" as per Microsoft Documentation.

    I am using following code to do FTP Send file to FTP Server:

    int JSCFTPSendFile(TCHAR *tszLocalFileName, TCHAR *tszRemoteFileName)

    HANDLE hInternetHandle = 0;
    HANDLE hFTPHandle = 0;
    TCHAR tszFTPServerName[256];
    TCHAR tszFTPUserId[51];
    TCHAR tszFTPPassword[51];
    INTERNET_PORT ipFTPPortNo = 21;

    _tcscpy(tszFTPServerName, _T("");
    _tcscpy(tszFTPUserId, _T("MyUserid");
    _tcscpy(tszFTPPassword, _T("MyPassword");

    hInternetHandle = InternetOpen(_T("Microsoft Internet Explorer"), INTERNET_OPEN_TYPE_DIRECT, NULL, NULL, INTERNET_INVALID_PORT_NUMBER);
    if ( hInternetHandle == 0 )
    return FALSE;

    hFTPHandle = InternetConnect(hInternetHandle, tszFTPServerName, ipFTPPortNo, tszFTPUserId, tszFTPPassword, INTERNET_SERVICE_FTP, INTERNET_FLAG_PASSIVE, 0);

    if ( hFTPHandle == 0 )

    return FALSE;
    // upto here code works fine but when it executes FtpPutFile() I get Error code 12029
    iRetStatus = FtpPutFile(hFTPHandle, tszSendFileName, tszRemoteFileName, FTP_TRANSFER_TYPE_BINARY, 0);
    if ( iRetStatus )
    bFileSent = true;


    return TRUE;


    In the above function upto "InternetConnect()" code works fine but when it executes "FtpPutFile()" I get Error code 12029.

    This code works fine to conect to any standard FTP Server.
    I am first connecting to PC using ActiveSync(Version 4.1) and once ActiveSync Connection established I can connect to any FTP Server(Local Network or Remote thru the gateway ) and transmit file. But if I try to send file from PDA(MC3000) to ActiveSync Connected PC(FTP Server Name is V4000) then it does not work.
    I tried server name as "ppp_peer", "localhost", "V4000"(which is actual FTP Server Name for the local PC ). and it did not work.
    Your help will be greatly appreciated.


    Thursday, October 11, 2007 10:49 PM

All replies

  • Can anybody help me to solve this problem?

    I have still no clue to this problem.

    Your help will be appreciated.


    Monday, October 15, 2007 8:02 AM
  • hello:
    I had met this 12029 ftp error message. my environment looks like yours. I used ActiveSync to connect Pocket PC with my
    PC to be client , in the other hand, I used another PC being FTP Server and sent file would get some problem liked yours.
    sometimes it would hold down on time,I couldn't find any solution anymore.Please you have some idea or solution please let
    me know and I would tell you if I found this solution,thanks for you.

    Tuesday, November 13, 2007 10:46 AM
  • I am also facing the same issue. application able to send command from client (pocket PC) to server (FTP server running on my machine).
    My program is able to delete the file as well from server by sending "dele" command

    However, when i try to put or get file the same error occurs. dataconnection can't be made.

    Can any one please assist me in the issue ?

    Thursday, December 20, 2007 1:36 PM
  • You could try to use the real ip in the case the ftp is on the same machine that your device is connected to by activesync.





    Maybe this is a problem with the ActiveSync internal SocketProxy.


    Saturday, December 22, 2007 9:12 PM
  • Hi Patrick,

    I tried using real IP and it did not work.

    My device has wireless as well. If I try to connect thru wireless then there is no problem. It works fine using wireless connection. But if I connect thru ActiveSync it does not work. Unfortunately we have to connect using ActiveSync because of cost factor.






    Monday, January 07, 2008 10:55 PM
  • Hi,


    I am having the same problem the rest of you are having, but can pinpoint when this started to happen. I installed mozilla 3.0 beta (yesterday) and the ie add-on button. Now I get timed out whenever I try to connect through a link in Outlook and many times doing Google searches and my favorite bookmarks also get timed out. I do not understand any of the suggestions in this posting and feel like an idiot!!


    If anyone can help with extremely simple terms, I would greatly appreciate it!


    Thank you,




    Monday, March 24, 2008 3:47 PM
  • I have same problem,  but when I connect Ftp server thru GPRS . It's works well , maybe this problem is ActiveSync's Bug I think so.

    Wednesday, July 30, 2008 5:56 AM