locked
Web synchronization - cannot propagate changes to subscriber RRS feed

  • Question

  • Hi,

    Brief summary of my setup :

    • SQL Server version : 2005, SP2
    • Merge replication with web sync
    • Subscriber : PDAs running SQL Compact Edition 
    • Snapshot : Character format, placed in the "default" snapshot folder (a UNC path). Security and share permission look fine.
    • IIS used for sync is on a different machine

    When I tried to synchronize, I got the following error :

    0 - A call to SQL Server Reconciler failed. Try to resynchronize.
    1 - The schema script '\\mfadc\ReplData\unc\MFASQLSVR_BHSWL_WLPERSON\20101102000540\BLReasonCode_2.sch' could not be propagated to the subscriber.
    2 - The merge process was unable to deliver the snapshot to the Subscriber. If using Web synchronization, the merge process may have been unable to create or write to the message file. When troubleshooting, restart the synchronization with verbose history logging and specify an output file to which to write.

    This problem cannot be reproduced in my test environment. It is reported only in my production environment.

    I have tried deleting the SDF files on my PDA, and regenerating snapshots. But the problem persists.

    How can I enable verbose logging (since this is a web sync, there's no merge agent job entry on the server)? Where can I find the generated log file?

    Appreciate any pointers for me to troubleshooting this problem.

     

    Thanks.

    Wednesday, November 3, 2010 9:28 AM

All replies

  • I suspect this is a problem with permissions. Can you give the everyone group rights to read the share, and to read and list files and folders to the folders underlying the snapshot share. 
    looking for a book on SQL Server 2008 Administration? http://www.amazon.com/Microsoft-Server-2008-Management-Administration/dp/067233044X looking for a book on SQL Server 2008 Full-Text Search? http://www.amazon.com/Pro-Full-Text-Search-Server-2008/dp/1430215941
    Wednesday, November 3, 2010 1:10 PM
    Answerer
  • Hi,

    I have granted the said permissions, but the problem persists. Anything else that I can check?

    Thursday, November 4, 2010 5:11 AM