none
IntelliSense Never Completes and Stops Working

    Question

  • After using Visual Studio for a while, IntelliSense seems to kick in and never finish. The icon in the task bar keeps displaying the animation over and over and any kinda of InteliSense operation stops working. The only way to get things working again seems to be to restart Visual Studio.

    Has anybody else experienced this problem? Can anybody more familiar with Visual Studio help me debug the problem?

    Friday, May 20, 2016 5:14 PM

All replies

  • Hi Simon John Morgan,

    Could do you please tell us which specific intellisense function do you use in Visual Studio and which version of Visual Studio do you use? Please provide some screenshots to help us understanding your problem.

    I'm using Visual Studio Enterprise 2015 Update 2 and all IntelliSense functions work fine on my machine. For example, if I add a control in my project, when I type the control name in my code-behind, it will prompt all control related properties and events in a list. After I choose one of them, the prompt window will disappear immediately.

    Please check whether your Visual Studio has installed the latest update. To prevents all third-party VSPackages from loading when Visual Studio starts, thus ensuring stable execution, please try run your Visual Studio in safe mode.

    And please try reset all settings from Tools -> Import and Export settings -> Reset all settings to check whether the problem caused by some settings.

    If misunderstanding, please feel free to let me know.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, May 23, 2016 6:42 AM
    Moderator
  • I'm using Visual Studio Community 2015 Update 2.

    I've tried resetting all settings and starting in safe mode and the problem still occurs. Once the IntelliSense icon in the bottom bar displays indicating that IntelliSense is "busy", IntelliSense functions such as autocompletion of variables etc. stops working. IntelliSense never finishes it's activity and the only way to get things working again seems to be to restart Visual Studio. I'm pretty convinced this is a bug in Visual Studio.

    Friday, May 27, 2016 3:20 PM
  • Hi Simon John Morgan,

    The intellisense function works fine in my Visual Studio 2015 Community with Update 2. So I suggest you check the ActiveLog.xml under the path of %AppData%\Microsoft\VisualStudio\14.0. This file will log all operations when you operate Visual Studio. Please check whether there has any error log about the intellisense function in this file.

    If you don't find this file in that path, please turn on the /log swith for your Visual Studio and then operate your Visual Studio again to let it generate log file.

    And please check whether you have enable your Visual Studio to list all members in Tools menu -> Options -> Text Editor to checked "Auto list members" and "Parameter information".

    In addition, please close all third part software, such as antivirus to check whether this problem caused by third part software. Then please tell us your Windows version and other machine environment to help us reproduce your problem. If possible, please try on another machine to confirm whether it is related to machine environment.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Saturday, May 28, 2016 8:53 AM
    Moderator
  • I tried enabling logging but couldn't find anything to do with IntelliSense in the generated log fil. Unfortunately your other suggestions didn't help either.
    Friday, June 03, 2016 3:47 PM
  • Hi Simon John Morgan,

    Please clean the Visual Studio caches in following paths, which may cause Visual Studio slowly when do any operations.

    C:\Users\v-weiwca\AppData\Local\Temp
    C:\Users\username\AppData\Local\Microsoft\WebsiteCache
    C:\Users\username\AppData\Local\Microsoft\VisualStudio\14.0\ComponentModelCache
    C:\Users\username\AppData\Local\Microsoft\VisualStudio\14.0\ManifestCache

    Is this function works fine before? If it works fine before, please try repair your Visual Studio to check whether something broken in Visual Studio installation. If it has problem after installing, please try reinstall your Visual Studio to check whether there has any problem when installing Visual Studio.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, June 06, 2016 2:24 AM
    Moderator