locked
Cannot open include file RRS feed

  • Question

  • Let me say up front I have no experience with C++, however I have been tasked with supporting a multi-project application that contains 3 VS C++ projects.

    After creating a new dev branch in tfs, I updated the Additional Library Directories links to reflect the change.  I have done this before and did was able to build the project successfully.  This time however, I am getting errors similar to the following, "Cannot open include file: 'xercesc/util/XMLString.hpp': No such file or directory.  I have added the path to the Additional library property, "C:\Development\ThirdParty\xercesc" and "C:\Development\ThirdParty\xercesc\util". 

    Can someone point me in the right direction?

    Visual Studio 2010

    .NET Framework 4

    Friday, October 17, 2014 6:11 PM

Answers

  • Sorry for the delayed response, I'm not getting alerts on this thread.

    #include "xercesc/util/XMLString.hpp"

    Complete path name of file: C:\Development\ThirdParty\xercesc\util\XMLString.hpp

    Not certain what you mean by non-library list of the linker libraries.

    A variation of the path, "C:\Development\ThirdParty\xercesc\util" was in the

    Additional Library Directories property when I took over support for the app. I updated

    the path because the location of the xercesc folder was changed. The actual filename

    was/is not include. Hope I am making sense.

    I don't know what you mean by "A variation of the path ..." but if your project says to search directory C:\Development\...\uitl then your #include directive should specify only the file name and none of the directories.

    Tuesday, October 21, 2014 7:37 AM
  • Sorry for the delayed response, I'm not getting alerts on this thread.

    #include "xercesc/util/XMLString.hpp"

    Complete path name of file: C:\Development\ThirdParty\xercesc\util\XMLString.hpp

    Not certain what you mean by non-library list of the linker libraries.

    A variation of the path, "C:\Development\ThirdParty\xercesc\util" was in the

    Additional Library Directories property when I took over support for the app. I updated

    the path because the location of the xercesc folder was changed. The actual filename

    was/is not include. Hope I am making sense.

    Hi,

    You might also try to add the folder which contains xstr.h to the Include files section of the VC++ Directories, Projects and Solutions, Options Dialog Box("Tools" -> "Options.." -> "Projects and Solutions" ->"VC++ Directories").

    The similar thread may be useful for you.

    trying to include .hpp file but can't find file

    May


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, October 21, 2014 8:32 AM

All replies

  • I did that first and got the error,"Cannot open include file: 'xercesc/util/XMLString.hpp'."  I've added the path to both Include Directories under VC++ Directories in the Property pages dialog as well as  Additional Library Directories under Linker in the Property pages dialog.   Same error on both.

    Friday, October 17, 2014 7:34 PM
  • Show us the complete path name of the file, the contents of Include Directories property, and the #include directive.

    Adding a non-library to the list of linker libraries can cause the linker to behave badly.  Remove the hpp file from the Additional Library Directories property.

    Friday, October 17, 2014 9:10 PM
  • Let me say up front I have no experience with C++, however I have been tasked with supporting a multi-project application that contains 3 VS C++ projects.

    After creating a new dev branch in tfs, I updated the Additional Library Directories links to reflect the change.  I have done this before and did was able to build the project successfully.  This time however, I am getting errors similar to the following, "Cannot open include file: 'xercesc/util/XMLString.hpp': No such file or directory.  I have added the path to the Additional library property, "C:\Development\ThirdParty\xercesc" and "C:\Development\ThirdParty\xercesc\util". 

    Can someone point me in the right direction?

    Visual Studio 2010

    .NET Framework 4

    click on the properties for the project

    click on vc directories and find the include section

    add the folder for any desired headers there

    same for libraries etc



    MSFT Signature

    Place your rig specifics into your signature like I have, makes it 100x easier!

    Hardcore Games Legendary is the Only Way to Play!
    Vegan Advocate How can you be an environmentalist and still eat meat?

    Friday, October 17, 2014 10:32 PM
  • Sorry for the delayed response, I'm not getting alerts on this thread.

    #include "xercesc/util/XMLString.hpp"

    Complete path name of file: C:\Development\ThirdParty\xercesc\util\XMLString.hpp

    Not certain what you mean by non-library list of the linker libraries.

    A variation of the path, "C:\Development\ThirdParty\xercesc\util" was in the

    Additional Library Directories property when I took over support for the app. I updated

    the path because the location of the xercesc folder was changed. The actual filename

    was/is not include. Hope I am making sense.

    Monday, October 20, 2014 1:23 PM
  • That's what I did, which is why I'm confused that I'm getting the error mention in the initial post.
    Monday, October 20, 2014 1:24 PM
  • Sorry for the delayed response, I'm not getting alerts on this thread.

    #include "xercesc/util/XMLString.hpp"

    Complete path name of file: C:\Development\ThirdParty\xercesc\util\XMLString.hpp

    Not certain what you mean by non-library list of the linker libraries.

    A variation of the path, "C:\Development\ThirdParty\xercesc\util" was in the

    Additional Library Directories property when I took over support for the app. I updated

    the path because the location of the xercesc folder was changed. The actual filename

    was/is not include. Hope I am making sense.

    I don't know what you mean by "A variation of the path ..." but if your project says to search directory C:\Development\...\uitl then your #include directive should specify only the file name and none of the directories.

    Tuesday, October 21, 2014 7:37 AM
  • Sorry for the delayed response, I'm not getting alerts on this thread.

    #include "xercesc/util/XMLString.hpp"

    Complete path name of file: C:\Development\ThirdParty\xercesc\util\XMLString.hpp

    Not certain what you mean by non-library list of the linker libraries.

    A variation of the path, "C:\Development\ThirdParty\xercesc\util" was in the

    Additional Library Directories property when I took over support for the app. I updated

    the path because the location of the xercesc folder was changed. The actual filename

    was/is not include. Hope I am making sense.

    Hi,

    You might also try to add the folder which contains xstr.h to the Include files section of the VC++ Directories, Projects and Solutions, Options Dialog Box("Tools" -> "Options.." -> "Projects and Solutions" ->"VC++ Directories").

    The similar thread may be useful for you.

    trying to include .hpp file but can't find file

    May


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, October 21, 2014 8:32 AM
  • anyone using the old style hpp files may want to look to the more modern naming conventions of cpp and h file names



    MSFT Signature

    Place your rig specifics into your signature like I have, makes it 100x easier!

    Hardcore Games Legendary is the Only Way to Play!
    Vegan Advocate How can you be an environmentalist and still eat meat?

    • Proposed as answer by Barry-Schwarz Friday, October 31, 2014 6:02 AM
    Wednesday, October 29, 2014 3:02 AM