none
Visual Studio integration with Unity broken

    Question

  • I've been working with Unity for a while and updating to 5.4 and on has made it basically unusable.

    While the main editor works fine, no matter what I do when reinstalling/updating it, Visual Studio never downloads correctly, but won't recognize anything Unity-based (GameObject, GetComponent, etc.) and upon startup, gives three errors, "Could not load project " with unknown solution item type '{E097FAD1-6243-4DAD-9C02-E9B9EFC3FFC1}'",

    It basically doens't recognize the Unity extension while it was working before.

    I already tried to: - Reinstall from scratch Visual Studio 15 (community edition) - Uninstall and Reinstall VS Unity add-on - Remove UnityVS folder and recreate it - Upgrade Unity to the latest version, 5.5

    The only way to make it work is to open the csproj property file, remove the text for the tags ProjectGuid and ProjectTypeGuids and reload the solution again.

    But then, when I close Unity and reopen it again, the same problem happens.

    It was working properly with unity 5.3 but all that happened when I did the upgrade to Unity 5.4

    Now I'm on Unity 5.5

    Saturday, February 25, 2017 7:53 AM

All replies

  • Hi StefanoGiu,

    This forum discuss and ask questions about extending and integrating with Visual Studio, Since your issue is more related to visual studio general, we'll move it to vs general forum for suitable support.

    Thanks for your understanding and cooperation.

    Best regards,

    Cole Wu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, February 27, 2017 8:35 AM
  • Hi StefanoGiu,

    Welcome to the MSDN forum.

    >> "Could not load project " with unknown solution item type '{E097FAD1-6243-4DAD-9C02-E9B9EFC3FFC1}'"

    Did you meet the same issue when you try to create a new unity project?

    Refer to the error message, please have a try with the following to troubleshot this issue:

    1. Forcibly re-import the Visual Studio Tools for Unity asset in my Unity project (by importing a custom package and navigating to the package in the Program Files folder)

    2. Make sure no devenv.exe process is running, and download Visual Studio 2015 Tools for Unity to re-install UnityVS for server times to test, I found some community members solved it after many times.

    3. Enable/install .NET Framework 3.5, if your OS is windows 10, please check this

    4. Back to the unity 5.3 and check if it works or not

    Please reproduce this issue and run the command: devenv /log in the evaluated command prompt if you can, then upload the activity file (%APPDATA%\Microsoft\VisualStudio\Version\ActivityLog.xml) to https://onedrive.live.com/ and share the link here.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, February 28, 2017 5:29 AM
    Moderator
  • Hello, I already tried everything you described, but still not working.

    Please find the ActivityLog.xml file.

    https://1drv.ms/u/s!AijAdr9tl0eqgTmYTng6CcWmSxFa

    I've also created a brand new Unity project and I have the same issue. This is the project properties file created:

    <?xml version="1.0" encoding="utf-8"?>
    <Project ToolsVersion="4.0" DefaultTargets="Build" xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
      <PropertyGroup>
        <Configuration Condition=" '$(Configuration)' == '' ">Debug</Configuration>
        <Platform Condition=" '$(Platform)' == '' ">AnyCPU</Platform>
        <ProductVersion>10.0.20506</ProductVersion>
        <SchemaVersion>2.0</SchemaVersion>
        <ProjectGuid>{6584D966-536B-F726-E799-D6C08B2FA6F0}</ProjectGuid>
        <OutputType>Library</OutputType>
        <AssemblyName>Assembly-CSharp</AssemblyName>
        <FileAlignment>512</FileAlignment>
        <ProjectTypeGuids>{E097FAD1-6243-4DAD-9C02-E9B9EFC3FFC1};{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}</ProjectTypeGuids>
        <TargetFrameworkIdentifier>.NETFramework</TargetFrameworkIdentifier>
        <TargetFrameworkVersion>v3.5</TargetFrameworkVersion>
        <TargetFrameworkProfile>Unity Subset v3.5</TargetFrameworkProfile>
        <CompilerResponseFile></CompilerResponseFile>
        <UnityProjectType>Game:1</UnityProjectType>
        <UnityBuildTarget>StandaloneWindows:5</UnityBuildTarget>
        <UnityVersion>5.5.0f3</UnityVersion>
        <RootNamespace></RootNamespace>
        <LangVersion Condition=" '$(VisualStudioVersion)' != '10.0' ">4</LangVersion>
      </PropertyGroup>
      <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Debug|AnyCPU' ">
        <DebugType>pdbonly</DebugType>
        <Optimize>false</Optimize>
        <OutputPath>Temp\UnityVS_bin\Debug\</OutputPath>
        <IntermediateOutputPath>Temp\UnityVS_obj\Debug\</IntermediateOutputPath>
        <ErrorReport>prompt</ErrorReport>
        <WarningLevel>4</WarningLevel>
        <DefineConstants>DEBUG;TRACE;UNITY_5_3_OR_NEWER;UNITY_5_4_OR_NEWER;UNITY_5_5_OR_NEWER;UNITY_5_5_0;UNITY_5_5;UNITY_5;UNITY_ANALYTICS;ENABLE_AUDIO;ENABLE_CACHING;ENABLE_CLOTH;ENABLE_DUCK_TYPING;ENABLE_GENERICS;ENABLE_MICROPHONE;ENABLE_MULTIPLE_DISPLAYS;ENABLE_PHYSICS;ENABLE_SPRITERENDERER_FLIPPING;ENABLE_SPRITES;ENABLE_TERRAIN;ENABLE_RAKNET;ENABLE_UNET;ENABLE_LZMA;ENABLE_UNITYEVENTS;ENABLE_WEBCAM;ENABLE_WWW;ENABLE_CLOUD_SERVICES_COLLAB;ENABLE_CLOUD_SERVICES_ADS;ENABLE_CLOUD_HUB;ENABLE_CLOUD_PROJECT_ID;ENABLE_CLOUD_SERVICES_UNET;ENABLE_CLOUD_SERVICES_BUILD;ENABLE_CLOUD_LICENSE;ENABLE_EDITOR_METRICS;ENABLE_EDITOR_METRICS_CACHING;INCLUDE_DYNAMIC_GI;INCLUDE_GI;PLATFORM_SUPPORTS_MONO;RENDER_SOFTWARE_CURSOR;INCLUDE_PUBNUB;ENABLE_PLAYMODE_TESTS_RUNNER;ENABLE_SCRIPTING_NEW_CSHARP_COMPILER;UNITY_STANDALONE_WIN;UNITY_STANDALONE;ENABLE_SUBSTANCE;ENABLE_RUNTIME_GI;ENABLE_MOVIES;ENABLE_NETWORK;ENABLE_CRUNCH_TEXTURE_COMPRESSION;ENABLE_UNITYWEBREQUEST;ENABLE_CLOUD_SERVICES;ENABLE_CLOUD_SERVICES_ANALYTICS;ENABLE_CLOUD_SERVICES_PURCHASING;ENABLE_CLOUD_SERVICES_CRASH_REPORTING;ENABLE_EVENT_QUEUE;ENABLE_CLUSTERINPUT;ENABLE_VIDEO;ENABLE_VR;ENABLE_WEBSOCKET_HOST;ENABLE_MONO;ENABLE_PROFILER;DEBUG;TRACE;UNITY_ASSERTIONS;UNITY_EDITOR;UNITY_EDITOR_64;UNITY_EDITOR_WIN;UNITY_TEAM_LICENSE;ENABLE_VSTU</DefineConstants>
        <AllowUnsafeBlocks>false</AllowUnsafeBlocks>
      </PropertyGroup>
      <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Release|AnyCPU' ">
        <DebugType>pdbonly</DebugType>
        <Optimize>false</Optimize>
        <OutputPath>Temp\UnityVS_bin\Release\</OutputPath>
        <IntermediateOutputPath>Temp\UnityVS_obj\Release\</IntermediateOutputPath>
        <ErrorReport>prompt</ErrorReport>
        <WarningLevel>4</WarningLevel>
        <DefineConstants>TRACE;UNITY_5_3_OR_NEWER;UNITY_5_4_OR_NEWER;UNITY_5_5_OR_NEWER;UNITY_5_5_0;UNITY_5_5;UNITY_5;UNITY_ANALYTICS;ENABLE_AUDIO;ENABLE_CACHING;ENABLE_CLOTH;ENABLE_DUCK_TYPING;ENABLE_GENERICS;ENABLE_MICROPHONE;ENABLE_MULTIPLE_DISPLAYS;ENABLE_PHYSICS;ENABLE_SPRITERENDERER_FLIPPING;ENABLE_SPRITES;ENABLE_TERRAIN;ENABLE_RAKNET;ENABLE_UNET;ENABLE_LZMA;ENABLE_UNITYEVENTS;ENABLE_WEBCAM;ENABLE_WWW;ENABLE_CLOUD_SERVICES_COLLAB;ENABLE_CLOUD_SERVICES_ADS;ENABLE_CLOUD_HUB;ENABLE_CLOUD_PROJECT_ID;ENABLE_CLOUD_SERVICES_UNET;ENABLE_CLOUD_SERVICES_BUILD;ENABLE_CLOUD_LICENSE;ENABLE_EDITOR_METRICS;ENABLE_EDITOR_METRICS_CACHING;INCLUDE_DYNAMIC_GI;INCLUDE_GI;PLATFORM_SUPPORTS_MONO;RENDER_SOFTWARE_CURSOR;INCLUDE_PUBNUB;ENABLE_PLAYMODE_TESTS_RUNNER;ENABLE_SCRIPTING_NEW_CSHARP_COMPILER;UNITY_STANDALONE_WIN;UNITY_STANDALONE;ENABLE_SUBSTANCE;ENABLE_RUNTIME_GI;ENABLE_MOVIES;ENABLE_NETWORK;ENABLE_CRUNCH_TEXTURE_COMPRESSION;ENABLE_UNITYWEBREQUEST;ENABLE_CLOUD_SERVICES;ENABLE_CLOUD_SERVICES_ANALYTICS;ENABLE_CLOUD_SERVICES_PURCHASING;ENABLE_CLOUD_SERVICES_CRASH_REPORTING;ENABLE_EVENT_QUEUE;ENABLE_CLUSTERINPUT;ENABLE_VIDEO;ENABLE_VR;ENABLE_WEBSOCKET_HOST;ENABLE_MONO;ENABLE_PROFILER;DEBUG;TRACE;UNITY_ASSERTIONS;UNITY_EDITOR;UNITY_EDITOR_64;UNITY_EDITOR_WIN;UNITY_TEAM_LICENSE;ENABLE_VSTU</DefineConstants>
        <AllowUnsafeBlocks>false</AllowUnsafeBlocks>
      </PropertyGroup>
      <ItemGroup>
        <Reference Include="mscorlib" />
        <Reference Include="System" />
        <Reference Include="System.XML" />
        <Reference Include="System.Core" />
        <Reference Include="Boo.Lang" />
        <Reference Include="UnityScript.Lang" />
        <Reference Include="System.Runtime.Serialization" />
        <Reference Include="System.Xml.Linq" />
        <Reference Include="UnityEngine">
          <HintPath>Library\UnityAssemblies\UnityEngine.dll</HintPath>
        </Reference>
        <Reference Include="UnityEngine.UI">
          <HintPath>Library\UnityAssemblies\UnityEngine.UI.dll</HintPath>
        </Reference>
        <Reference Include="UnityEngine.Networking">
          <HintPath>Library\UnityAssemblies\UnityEngine.Networking.dll</HintPath>
        </Reference>
        <Reference Include="UnityEngine.PlaymodeTestsRunner">
          <HintPath>Library\UnityAssemblies\UnityEngine.PlaymodeTestsRunner.dll</HintPath>
        </Reference>
        <Reference Include="UnityEngine.Analytics">
          <HintPath>Library\UnityAssemblies\UnityEngine.Analytics.dll</HintPath>
        </Reference>
        <Reference Include="UnityEngine.HoloLens">
          <HintPath>Library\UnityAssemblies\UnityEngine.HoloLens.dll</HintPath>
        </Reference>
        <Reference Include="UnityEngine.VR">
          <HintPath>Library\UnityAssemblies\UnityEngine.VR.dll</HintPath>
        </Reference>
        <Reference Include="UnityEditor">
          <HintPath>Library\UnityAssemblies\UnityEditor.dll</HintPath>
        </Reference>
        <Reference Include="UnityEditor.iOS.Extensions.Xcode">
          <HintPath>Library\UnityAssemblies\UnityEditor.iOS.Extensions.Xcode.dll</HintPath>
        </Reference>
        <Reference Include="UnityEditor.iOS.Extensions.Common">
          <HintPath>Library\UnityAssemblies\UnityEditor.iOS.Extensions.Common.dll</HintPath>
        </Reference>
      </ItemGroup>
      <ItemGroup>
        <Compile Include="Assets\scri.cs" />
      </ItemGroup>
      <Import Project="$(MSBuildToolsPath)\Microsoft.CSharp.targets" />
      <Target Name="GenerateTargetFrameworkMonikerAttribute" />
    </Project>

    Friday, March 3, 2017 4:58 PM
  • Hi StefanoGiu,

    Thank you for your update. Since the new project also has this issue, could you please run the commands: devenv /safemode or devenv /resetuserdata to troubleshot this issue? It can help us to excludes some possible factors about VS, thanks for your support.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, March 6, 2017 10:22 AM
    Moderator
  • Hello,

    I executed:

    1) devenv /resetuserdata  from cmd, nothing happened.

    2)  devenv /safemode from cmd. Opened VS and asked me to insert my credentials, then it did the reset of setting to the factory ones.

    3) I tried to open from that VS window the solution files previously created by Unity, but I had the same issue.

    4) I closed the VS window

    5) I deleted the sln and csproj files

    6) I clicked in Unity Open C# project. It recreated the sln and csproj files, but still I have the error message project not supported.

    What should I do?

    Monday, March 6, 2017 11:18 AM
  • Hi StefanoGiu,

    Have you tried to start a new thread for your issue in the Unity support forum: http://answers.unity3d.com/, since your issue is more relates to the newer Unity version, and you will get a more professional support from there to help you solve this issue.

    I found a similar issue in the above forum and you can have a look at this, please try to run Unity as administrator to test it.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, March 7, 2017 7:51 AM
    Moderator
  • Hello, I opened a thread on Unity and they told me it's a problem of Visual Studio. Moreover the thread you are referring to is from 2012 and is about Monodevelop, not VS.

    The problem is actually VS one, as, if I open the csproj property file, remove the text for the tags ProjectGuid and ProjectTypeGuids and reload the solution again, it works!!!

    Tuesday, March 7, 2017 8:24 AM
  • But then... everytime I close Unity/VS and reopen them again, the problem starts again...
    Tuesday, March 7, 2017 8:24 AM
  • Hi StefanoGiu,

    Thanks for your reminder, I will invite a higher support engineer to help you to research this issue and please waiting for a while :)

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, March 7, 2017 8:45 AM
    Moderator
  • Hello, any news?
    Wednesday, March 15, 2017 7:13 AM
  • Hello, no one has a solution for that? Support request is 1 month old.

    Thanks

    Thursday, March 23, 2017 4:50 PM
  • No solution for this?

    As usual the support is very poor!!!

    Thursday, May 18, 2017 6:46 AM