none
.NET Dependencies RRS feed

  • Question

  • How can I make my project support XP, Vista, 7, 8, 8.1, and 10+? What are the correct dependencies needed to support everyone? In Visual Studio 2017 I plan on using a Setup project. Can I include the dependencies needed so the setup will install what it needs to run. This is all very new to me. Thanks for the help.
    Thursday, April 12, 2018 2:22 PM

Answers

  • Hi,

    Welcome to MSDN forum.

    >>How can I make my project support XP, Vista, 7, 8, 8.1, and 10+?

    .net framework 4.5 and the later version of .net framework are not supported in windows XP, the project should target .net framework 4.0 or below.

    All .NET Framework versions since .NET Framework 4 are in-place updates,  so windows 7, 8, 8.1 and 10 are compatible with .net framework 4.0.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by vbNeil Friday, April 13, 2018 1:12 PM
    Friday, April 13, 2018 6:58 AM

All replies