none
Open link in outlook app in IE11 / OWA RRS feed

  • Question

  • TO demonstrate my problem, I created a new mail app for office using Visual Studio 

    in home.html, i add a link

    <a href="https://www.microsoft.com/" target="_blank">powered by microsoft</a>

    If I run the project and click the link in Internet Explorer, nothing happens, the microsoft does not open in a new window or tab.

    Why is this and how can this be resolved?

    kind regards,

    TDER





    • Edited by TDER Wednesday, November 27, 2013 2:36 PM
    Wednesday, November 27, 2013 2:33 PM

All replies

  • Sunday, December 1, 2013 3:33 PM
  • Hi, 

    Thank you for your reply.

    I don't think this thread has anything to do with it.

    I can't even op a link to microsoft.com in my mail app in OWA using IE 11, while this was still working in the thread above.

    kind regards

    Tom

    Wednesday, December 4, 2013 8:25 AM
  • Hi,

    This does not seems to be issue with Mail app but the browser. "Protected Mode" setting (Tools>Internet Options>Security) in IE 11 could be the culprit. Turn Off the protected mode and test.

    You can verify this without creating Office app also.You can perform a  quick test by creating a simple html page. Save the below two test html in two different html file on same folder. Run TestPage2.html in IE and you should see the same behavior. However, if you host both the files in IIS, you may not have issue. There is a setting security setting in IE 11 which does not allow this.

    TestPage1.html

    ******

    <! DOCTYPE html>

    <HEAD><TITLE>Link Test</TITLE></HEAD>

    <BODY><a href="https://www.microsoft.com/" target="_blank">powered by microsoft</a></BODY>

    </HTML>

    *******

    TestPage2.html

    ********

    <! DOCTYPE html>

    <HEAD><TITLE>Link Test</TITLE></HEAD>

    <BODY><IFRAME src="TestPage1.html" height="600" width="600" sandbox="allow-scripts, allow-forms, ms-allow-popups" /> </BODY>

    </HTML>

    *******

    Regards,
    Pallav[NOT MSFT]

    Wednesday, January 15, 2014 11:15 AM