none
Steps to upgrade dotnet 2.0 to 3.5 RRS feed

  • Question

  • I have upgraded my website to 3.5 running fine on the test server but I get errors after I copied and ran on the Live server. I probably need to install framework 3.5 on the Live server. Can anyone advice of the bset and safest way to achieve that?
    Tuesday, May 11, 2010 2:52 PM

Answers

  • Hi Baruch,

    Thank you for your post.

    You're right. Since your website is developed on .NET Framework 3.5, you should install .NET Framework 3.5 at least on the server to support your website.

    If the OS of your server is Windows Server 2003 or Windows Server 2008, I would suggest you to download .NET Framework 3.5 full package and install it directly on it. Then deploy your website onto the server.

    If the OS is Windows Server 2008 R2, it includes the .NET Framework 3.5.1 as an OS component. This means you will get the .NET Framework 2.0 SP2, 3.0 SP2 and 3.5 SP1 plus a few post 3.5 SP1 bug fixes. The feature of 3.5 SP1 can be added or removed via the Programs and Features control panel.
    For more information, please check: http://blogs.msdn.com/astebner/archive/2007/03/14/mailbag-what-version-of-the-net-framework-is-included-in-what-version-of-the-os.aspx

    To turn on the feature of .NET 3.5.1, please go to Start menu >> Administrative Tools >> Server Manager.
    In Server Manager, please select "Features" >> Add Features >> Check the box next to Microsoft .NET Framework 3.5.1. Then follow the wizard to complete the installation.

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Tuesday, May 18, 2010 1:48 AM
    Thursday, May 13, 2010 8:02 AM

All replies

  • Hi,

    what errors did you got?

    I think the normal installation is the best without any parameters. It should be the best way.

     

    Regards

    martinwy

    Tuesday, May 11, 2010 6:40 PM
  • Hi Baruch,

    Thank you for your post.

    You're right. Since your website is developed on .NET Framework 3.5, you should install .NET Framework 3.5 at least on the server to support your website.

    If the OS of your server is Windows Server 2003 or Windows Server 2008, I would suggest you to download .NET Framework 3.5 full package and install it directly on it. Then deploy your website onto the server.

    If the OS is Windows Server 2008 R2, it includes the .NET Framework 3.5.1 as an OS component. This means you will get the .NET Framework 2.0 SP2, 3.0 SP2 and 3.5 SP1 plus a few post 3.5 SP1 bug fixes. The feature of 3.5 SP1 can be added or removed via the Programs and Features control panel.
    For more information, please check: http://blogs.msdn.com/astebner/archive/2007/03/14/mailbag-what-version-of-the-net-framework-is-included-in-what-version-of-the-os.aspx

    To turn on the feature of .NET 3.5.1, please go to Start menu >> Administrative Tools >> Server Manager.
    In Server Manager, please select "Features" >> Add Features >> Check the box next to Microsoft .NET Framework 3.5.1. Then follow the wizard to complete the installation.

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Tuesday, May 18, 2010 1:48 AM
    Thursday, May 13, 2010 8:02 AM