none
Error on installing outlook 2013 add in RRS feed

  • Question

  • Hello all,

    When installing an add-in on test computer the installation succeeds, but the add-in doesn't load when I start outlook.

    When i search for the add-in, i find that is in the disabled section of the add-ins list. I tried to turn it on by selecting the checkmark on the right, but it still doesn't show.

    It says: "not loaded. A runtime error occurred during the loading of the COM Add-in."

    I am running this on windows 7, outlook 2013 professional.
    I also installed the next two pre-requisites on the test computer which should be enough to make it work (at least normally it should be).
    - Microsoft .Net FrameWork 4.5
    - Microsoft Visual Studio 2010 Tools for Office Runtime (x64)

    does anyone have any experience concerning this kind of problem?

    I installed it with a Click Once installation. Is it because of this? And do I need to perform a Windows Application Installation to make it perform correctly? It would be strange if it does..

    Kind Regards

    Yor

    Friday, May 15, 2015 1:30 PM

All replies

  • Hello Yor,

    Microsoft Office applications can disable add-ins that behave unexpectedly. If an application does not load your add-in, the application might have hard disabled or soft disabled your add-in.

    Hard disabling can occur when an add-in causes the application to close unexpectedly. It might also occur on your development computer if you stop the debugger while the Startup event handler in your add-in is executing.

    Soft disabling can occur when an add-in produces an error that does not cause the application to unexpectedly close. For example, an application might soft disable an add-in if it throws an unhandled exception while the Startup event handler is executing.

    When you re-enable a soft-disabled add-in, the application immediately attempts to load the add-in. If the problem that initially caused the application to soft disable the add-in has not been fixed, the application will soft disable the add-in again.

    Read more about that in the How to: Re-enable an Add-in That Has Been Disabled article in MSDN. 

    Also I'd suggest checking the Trust Center settings in Outlook. Are macro security setting applied to add-ins as well?

    Friday, May 15, 2015 2:00 PM
  • Yor,

    What do you see in a debugger? 

    Friday, May 15, 2015 2:04 PM
  • Hi Eugene,

    It is a soft-disabled add-in. It show unchecked in the COMM Add-In list, but it automatically unchecks the add-in again as soon as I click the OK button after checkmarking the add-in.

    I also checked the trust center settings and even by allowing everything the add-in still doesn't run.

    Friday, May 15, 2015 2:12 PM
  • I don't see anything in debugger, because of the simple reason that it builded correctly, it deployed correctly when debugging in development, but it doesn't run in deployment..

    Friday, May 15, 2015 2:13 PM
  • Make sure that you installed/included all the required prerequisites to the installer. See Deploying an Office Solution by Using ClickOnce for more information. 

    Should add-ins be signed with a digital signature? 

    Friday, May 15, 2015 2:24 PM
  • Go through the steps described in the Troubleshooting COM Add-In load failures article and try to find the cause. 
    Friday, May 15, 2015 2:25 PM