locked
Windows 8 and multitouch on Dell XT2

    Question

  • Hi,

    I have dell latitude XT2 and just installed windows 8 x64 dev preview on it. Almost everything seems to work ok except my pen and multi-touch.

    It was working fine when I had windows 7 x64 but after upgrading to windows 8, its stopped working. In the device manager I have exclamation marks against the DuoSense drivers and have ? against N-Trig_Digitizer.

    It seems like windows 8 is not re-cognizing this hardware or firmware. is anybody else having the same issue?

    if this is monitor by MSFT folks can you please take a note of this and let me know if there is any solutions for this issue?

    Thanks in advance.

     

    Wednesday, September 14, 2011 10:14 PM

Answers

All replies

  • I've got an older HP Touchsmart TX2 notebook and I'm having the same issue.  It senses touch ok, but I can't "click" with my finger.  The DuoSense device shows up with an exclamation mark as well.  I've tried reinstalling the latest Win7 DuoSense drivers for my model but it fails during the install.  Tried install with compatibility set to Win7 as well. I'm guess we will need to wait for new drivers for it to work properly. 
    Thursday, September 15, 2011 2:02 AM
  • Extract the XT drivers from the exe, and install them with dpinst (which is also in the exe) and you'll be all set.
    Thursday, September 15, 2011 2:17 AM
  • Just ended up doing the same thing and was going to reply back :) Thanks Hoff
    Thursday, September 15, 2011 2:43 AM
  • Hi JHoff,

     

    Is that for HP "XT drivers"?

    Can I use it on Dell? if yes, where this driver is and how i can extract it?

     

    thanks for your response.

    Thursday, September 15, 2011 2:59 AM
  • Download the DuoSense drivers from Ntrig, use an application that can extract from InstallShield .exes and then browse to the x86 or x64 folder and run the DpInst exe to install the drivers.

    Thursday, September 15, 2011 3:25 AM
  • Thanks again JHoff for the quick response. I think i am one step closer.

    All the exclamation marks are gone from the device manager. But now i am left with three question marks against DuoSense and N-Trig Digitizer.

     

    When i double clicked on DuoSense it tells me that no device drivers is install. but when i ran DpInst, it says N-Trig digitizer is ready to use.

    Can you help with this?

    Thursday, September 15, 2011 3:51 AM
  • one more thing now i don't have N-Trig Digitizer under device manager. Only left with two DuoSense device drivers options and both have ? mark
    Thursday, September 15, 2011 4:01 AM
  • Sorry, not really sure, that worked for me.  Here's how Device Manager looks for me (notice one section that still has the question mark, but I think maybe that's the emergency firmware recovery mode).  Regardless of the question mark, everything is working perfectly for me.


    Before I installed the drivers, I was able to scroll with Touch but not click on anything, just like mentioned above:

     

     

    I actually since have disabled the Secondary Interface entirely (right click and disable) and it's still working perfect.

    • Edited by JHoff80 Thursday, September 15, 2011 4:37 AM
    Thursday, September 15, 2011 4:37 AM
  • I have done the same things on my dell xt2, but no touch. I have the same device manager view as jhoff80. Did you enable somewhere touch? It's enabled in my pen and touch settings...
    Thursday, September 15, 2011 7:39 PM
  • I have done the same things on my dell xt2, but no touch. I have the same device manager view as jhoff80. Did you enable somewhere touch? It's enabled in my pen and touch settings...


    Nope, did nothing to enable touch.  Maybe try running the N-trig applet extracted from the driver installer and check to see if you're in pen only mode?

     

    Thursday, September 15, 2011 7:58 PM
  • I did run the applet and it tells me hardware not found? and when i try to install the windows 7 drivers it wont let me :(

    Reason I installed windows 8 to test all the new multi-touch features :(

    Thursday, September 15, 2011 8:04 PM
  • Same issue, I haved install with dpinst and no driver on Device Manager. I have only visuel respond and not click when touch. Helppp !!
    Friday, September 16, 2011 10:36 PM
  • Can you provide detailed instructions ?  What program can be used to extract from install shield exe.
    Tuesday, September 27, 2011 10:54 PM
  • With InstallShield under W8 Preview : Fatal error during installation  The operating system is not adequate for running.

    With DPInst, Driver Package Installer, but MSDN subscription and sing is required.

    Friday, September 30, 2011 8:18 AM
  • But how do we use dpinst to install the drivers?  Extracting the installer using universal extractor, I went into the x64 folder inside of the extracted folder, ran dpinst and all it installed was Ntrig diag.  Now I can move around with touch but am not able to select anything.  I am very close to breaking this tablet in half, packing it with thermite and chucking it off a ravine LOL.

     

    I don't remember how I did it the first time but there for awhile I was able to move and select stuff but the cursor would sometimes jump.  I turned it on today after applying windows updates and there was no touch recognition at all so I've been trying this dpinst driver install method for a good 6 hours now :((  What duosense drivers do I need to download from Ntrig?  There site is not helpful at all lol The one's I downloaded and extracted are... DuoSense_MT_RC_XT2_64bit_3.118.026.zip

     

    I don't even really care about multitouch, I'd just like to be able to move around and select stuff!

     

    Please help :)

     

    Specs:  Dell Latitude XT with 3GB of RAM and the highest CPU and ATI graphics available (umm core duo u7700 and ati x1275 i think?) for it.  I also have an SSD (jmicron?)  Running the 64 bit version of Windows 8 and all updates installed

    Tuesday, October 11, 2011 8:06 AM
  • I have the same issue but with a Hp envy14. What drivers should I look for?
    Wednesday, November 2, 2011 7:15 PM
  • Can you provide detailed instructions ?  What program can be used to extract from install shield exe.

     

    Use the one that the failed install opened.  You need to leave the error message open to do that; otherwise it gets deleted when the install ends.

    FWIW what I did was first Unblock the .zip file (e.g. right-click Properties, Unblock).   Then opened it.   Then used the Compatibility mode (assumes Admin mode) and specified W7 compatibility.   That got me much further but still a fail message.  So, with the failed message still showing I got into an Administrator: Command Prompt and did a  cd  %TEMP%  and  dir/a/b/s dpinst.exe   I think there were two and I think I chose the Disk1  one (because the directory was later) then I drilled down into that directory (e.g. right-click Mark, select, Enter; then cd right-click, Paste); then issued the dpinst.exe  (so because of the Administrator: Command Prompt that would be run as an elevated command.)   Then once that was done gave Ok to the original install and Ok to the Compatibility dialog.

     

    Good luck

    Robert Aldwinckle
    ---

    Wednesday, November 2, 2011 9:36 PM
  • I can move around with touch but am not able to select anything.


    Are you in a multi-monitor configuration?   With varying sized monitors?   FWIW I think the OS gets confused about where touch should be applied.   Try disconnecting your  Projector   (Win-P Disconnect)  before assessing your touch capability.

    See also a more detailed description of my case here:

    http://social.msdn.microsoft.com/Forums/en-US/windowsdeveloperpreviewgeneral/thread/3ea91350-aa2d-438f-a5af-a8b5d4bb4b5a#1d33ae44-1095-4aae-a06a-0904d8c61f2e

     

    FYI

    Robert Aldwinckle
    ---

    Wednesday, November 2, 2011 9:44 PM
  • Hi!

    I have a solution to this problem that actually works (well, I know it worked for me)...

    Copy the folders (there are two folders, both of which you MUST copy) from the temp directory during the installation. Then, go to the folder named with an ID (e.g.-  "{18C71DD4-0147-4318-8689-AE836278FBFE}") and run the following (all with Admin privileges and Win 7 compatibility);

    - DPInst.exe

    - Manual_Fwup.exe

    - NtrigFwup.exe

    - NtrigFwup_247135_INST.exe

    - NtrigFwup_RR.exe

    (NOTE! - Do not run the "NtrigFwRb.exe" - It rolls back all the drivers...)

    Next go the folder named "Disk1" and run the following(all with Admin privileges and Win 7 compatibility);

    - DPInst.exe

    - DPInst.exe (inside the "x64" folder, if running a 64 bit version of the Dev Preview)

    • Edited by Raven_95 Friday, November 25, 2011 6:38 AM
    Friday, November 25, 2011 6:36 AM
  • I have a solution to this problem that actually works


    @ Raven_95

    Do you dual boot to W7 on that machine?  IF so do you have that same package installed there?   And notice an additional message that I reported from the install about updating "firmware"?   (Maybe not, I suppose it would depend on when your Dell xt2 was manufactured.   FWIW my HP TouchSmart tx2 is over two years old.)   In any case I don't think I saw that message when I tried to recover from a failed install on W8, so I'm wondering if we have yet found a complete workaround for this problem.   E.g. it was only after doing the install normally on W7 and then retrying it on W8 that the dpinst.exe workaround finally resulted in great Touch support for me in W8.

    BTW I still get very flakey Touch and Pen support in the Boot menu.   Sometimes (rarely) Touch works there.   Usually the Pen works there.   Today neither worked there.   YMMV.   ; )

     

    Robert
    ---

    Friday, November 25, 2011 3:02 PM