locked
Unable to run my .net core app in local as well as on server with IIS RRS feed

  • Question

  • User147581952 posted

    I created a .net core api (version 2.2.0) and I'm getting the following error when I try to run on IIS.

    The application process failed to start The application process started but then stopped The application process started but failed to listen on the configured port

    I verified my web config and it appears to have correct set of values.Enabled logging and log file comes as empty.

    Event log shows the following error.

    enter image description here

    I installed hosting bundle and checked still getting same error. Also tried giving permission to IIS_IUSRS to the output folder. It didn't make any difference. Having said that error code "'0x80004005' " suggests a permission error. Still couldn't figure it out. Appreciate any help !

    Saturday, January 11, 2020 4:02 PM

Answers

All replies

  • User-474980206 posted

    the error is probably in your startup.cs. See this doc to debug

    https://docs.microsoft.com/en-us/aspnet/core/test/troubleshoot-azure-iis?view=aspnetcore-3.1

    note: core 2.2 is no longer supported. You should fallback to 2.1 LTS or upgrade to 3.1 LTS.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, January 11, 2020 6:05 PM
  • User147581952 posted

    Thank you ! I'll check it out.

    Sunday, January 12, 2020 2:07 AM
  • User147581952 posted

    Unfortunately suggestions given there didn't help me solve my problem.  Had a few (custom)log entries at different points in the flow.  I don't see any of them logged and looks like the application is not started at all.  Also when I execute app using command line "dotnet ./myapp.dll" it just prompts and then exits. 

    Sunday, January 12, 2020 11:20 AM
  • User-782232518 posted

    You might run some diagnostics to rule out common issues,

    https://docs.jexusmanager.com/tutorials/ancm-diagnostics.html

    Monday, January 13, 2020 3:34 PM
  • User147581952 posted

    For some reason I didn't get the custom file entry added at the very first in the program main when I executed. Anyway the issue was in the first code line added there. as mentioned the issue was with my code. Thank you for the help! 

    Friday, January 17, 2020 4:55 AM
  • User147581952 posted

    Thank you for the suggestions ! 

    Friday, January 17, 2020 4:55 AM