locked
Problem with Android adhoc distribution after publishing new version RRS feed

  • Question

  • User346507 posted

    Hi everyone. I compiled a release version of my Xamarin Forms app (android) to give it to my client (adhoc). He tested it and everything worked fine. After some more code added, i published another adhoc release to give him. I changed the version number and used the same keystore. He was unable to install it, even after removing previous version. As if there was some traces of the last install messing around.

    Did someone ever had the same problem?

    Wednesday, October 24, 2018 9:21 PM

All replies

  • User346507 posted

    No one out there? It only happens on a particular device, and on a particular project. When i create a new one, everything is ok...

    Tuesday, October 30, 2018 3:42 PM
  • User76049 posted

    You might have better luck posting it in the Android forum.

    Tuesday, October 30, 2018 4:33 PM
  • User346507 posted

    Yeah! you are right. Anyway, i just solved my problem by changing the package name in android manifest. It was clear that something desinstalled badly. I tried to remove every traces of the app on my device but with no sucess.

    Tuesday, October 30, 2018 5:06 PM
  • User76049 posted

    Does your app persist data using SQLite etc?

    Tuesday, October 30, 2018 5:09 PM
  • User346507 posted

    My app connect to a symfony web app and send POST data to it, and retrieve data. Using Httpclient. Works well otherwise

    Tuesday, October 30, 2018 5:15 PM